Calculator is not opening

Page 2 of 3 FirstFirst 123 LastLast

  1. Posts : 1
    Windows 10

    Had this same problem Calculator would not load.... went to Store and re-downloaded the calculator app and now is working fine ... this is the 1st thing that has been easy to fix. Hope it helps.
      My Computer

  2. Posts : 30
    Windows 10 Pro

    I recommend Microsoft Calculator Plus.

    It has 3 views: Standard, Scientific, and Conversion which includes converting currencies, as well as all the usual units such as International metric to/from the US antique units.

    It has one memory with the usual MC (clear) MR (recall) MS (set) M+ (add).

    It hasn't been changed since 2005, but who cares, it still works perfectly in Windows 10 and has a more complete feature set than a trendy new app.

    You can get it direct from Microsoft: Download Microsoft Calculator Plus from Official Microsoft Download Center


    By the way, it recently stopped launching from my Start Menu. So I deleted the shortcut its installer had made, from:
    C:\ProgramData\Microsoft\Windows\Start Menu\Programs

    Then I created a new shortcut in my Start Menu, by Right-Click dragging C:\Program Files (x86)\Microsoft Calculator Plus\CalcPlus.exe
    into C:\ProgramData\Microsoft\Windows\Start Menu\Programs
    then giving the new shortcut a more friendly name.
      My Computer

  3. Posts : 3
    Windows 10

    I have a fix that will allow you to still keep UAC enabled, provide no prompting for a user, while still being able to run all Metro apps - calculator, Edge, weather, news, calendar, etc

    Name Original Data Updated Data
    ConsentPromptBehaviorAdmin 0x00000003 0x00000000
    ConsentPromptBehaviorUser 0x00000003 0x00000000
    EnableLUA 0x00000001 0x00000001

    Change (Default) from the (value not set) to

    Reboot your Windows 10 machine and enjoy all the metro apps that require UAC/escalation without the nags

      My Computer

  4. Posts : 114
    Windows 10 Edu

    Sorry to piggy-back on your thread, but Why is this happening? I just lost the calculator app. Was working fine and in use one day, then the next it's gone! (not even a reboot, but windows updates may or may not have occurred automatically.)

    Now, the app itself seems to be calc.exe and can be found and run. but typing CALC into the the search box does not return the calculator anymore it returns CALC ... Search my stuff. Totally bogus!

    Dear Microsoft,

    I want the "normal" tile, recognition of the app in the search, etc. back!
      My Computer

  5. Posts : 2,296
    Windows 10 Pro (64 bit)

    Not a solution but I find if a native app updates itself, then the potential for it to no longer work for a specific user can happen. I've had it happen on the photos and calculator app. Works on mine, but not on other user accounts. It's very irritating. Manually uninstalling the app and re installing the app sometimes works but on occasions I couldn't fix other than to delete the affected user accounts and create new ones. This is not an appealing fix. So app updates seem to be the trigger at least for me. Sometimes I noticed updates for apps get stuck and need pausing and kicking off again. I believe these could be at the root of the issue. I'm hoping going forward things will be better as in latest cumulative update MS referenced a fix for App Store updates.
      My Computer

  6. Posts : 1
    Windows 10 Pro

    I figured out a solution that works even when deregistering (i.e. uninstalling) and reinstalling the App does not work. The problem is that deregistering the app does not remove the files, and so when reinstalling the app (whether from PowerShell or the Windows Store) the broken files are not necessarily replaced. Here are the steps I used:
    1. Enable the Administrator Account (enter 'net user Administrator /active:yes' in PowerShell/Command Prompt)
    2. Switch to the Administrator user account
    3. Go to C:\Program Files
    4. Find WindowsApps (the Windows 10 apps folder), then go to Properties and grant full access to your user account
    5. Switch back to your user account
    6. Go to C:\Program Files\WindowsApps
    7. Look for every folder that says WindowsCalculator. For each of these folders, you need to go to properties and change the ownership from SYSTEM to your user account. Then grant full access to your user account. Then you can delete the folder.
    8. When all folders are deleted, reinstall Calculator from the Windows Store. It should now work. (You should notice that this time when you download from the Store that the download is bigger.)
    9. Disable the Administrator Account (enter 'net user Administrator /active:no')

    I hope that helps.
      My Computer

  7. Posts : 1
    windows 10

    Worked for me like Cornishman said, i tiped in Run PowerShell and paste Get-AppxPackage *windowscalculator* | Remove-AppxPackage and now is all working great.
      My Computer

  8. Posts : 1
    windows 10 64 bit

    calculator stopped working in windows 10

    This was the only solution that worked! I tried other "solutions" with no success. I didn't want to reinstall Windows 10 leaving personal files alone and so on which would mean reinstalling a bunch of extra apps all over again (I am assuming). I tried the old "uninstall and reinstall" but that didn't work.

    This procedure is a bit convoluted but it works (at least for me) and Calculator is back. :)
      My Computer

  9. Posts : 3
    Windows 10

    The solution that works for me:

    1. Right click on your C:\ drive and select "Properties".
    2. Go to the Security tab. Click "Edit" and "Add".
    3. In the text box asking for object names, type ALL APPLICATION PACKAGES.
    4. Press OK.
    5. Then select the new entry "ALL APPLICATION PACKAGES" and, under Allow in the box below, click "Full Control".
    6. Press "Apply".

    It works like a charm for me... Calculator is back!

    WARNING: Be advised that this gives downloaded apps from the Microsoft Store complete access to your computer.

      My Computer

  10. Posts : 26
    Win 10 Pro 64-bit


    after struggling to contact anyone, I've managed to get the website bods to fix the captcha that's been bust at least a week stopping anyone joining.

    Now for my experience of the calculator, I wouldn't usually worry, but these days Office take so long to fire up for the odd simple calc its a useful extra, but as of about a two months I see Microsoft have managed an update that broke something that was working.

    I reset the app its made no difference, I've replaced calc.exe and I even did an sfc/ scanow but its broken. It flashes up the basic opening skin waits a few seconds then just closes itself. I do not wish to enable please disclose everything about everything so am not going to try some of the steps posted above.

    Anyone else seeing the calculator dead for that last few months?
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:43.
Find Us

Windows 10 Forums