Windows 10: ShowKeyPlus

Page 60 of 67 FirstFirst ... 10505859606162 ... LastLast
  1.    01 Mar 2017 #591

    DavidY said: View Post
    If it based on hardware changes, then it would make sense that a freely-upgraded windows 10 may only allow a few changes, but retail version would allow more.
    From my testing, there is definitely a limit on how many times you can transfer a digital licence to a new device (only three times) - in my tests I was using a digital licence upgraded from a retail licence. When it would not let me do it, I simply entered the retail key as normal and it activated - I then though perhaps the digital transfer count had been reset but no - still would not let me!

    As far as I can tell, the digital licence does not carry the history of how it was created i.e. from an oem licence or retail. This is presumably why you can transfer a digital licence even if original was oem.

    Whilst Windows still allows you to use original 7/8 retail key to activate windows 10, then none of this is is a problem. However, if and when they stop that (it will be interesting to see if CU version still allows old keys), then there will be some people who get caught with the limit.

    Best advice I can give people if they install Windows on a new PC, try to use a product key first, as that sets up a new digital licence with transfer count set to zero. Only use the activation troubleshooter method when you have to e.g. you do not have a product key to save using up a valuable transfer count.
      My ComputerSystem Spec

  2.    02 Mar 2017 #592

    thecritter99 said: View Post
    Superfly, I've just been referred to your extremely useful tool. I'm trying to work out if a machine has been previously upgraded to Windows 10 (via Microsoft's free promotion), but has since been restored to its original OS (7/8/8.1). In other words, can I see if a machine has a digital licence for Windows 10 despite it running the original OS? I'm asking because I have bought a job lot of used laptops that have been restored to factory settings and running 7/8/8.1. It would be very useful to see if the previous owner had upgraded to 10 so that I can then upgrade the machines back to 10 myself without buying a product key. If I do risk installing Windows 10 (and the activation server cannot find a digital licence in the BIOS), then I no longer have an activated OS!

    Are there any tell tale signs or something to look for in your tool for my case?

    Thanks
    As others have mentioned ShowKey+ only reads current info (registry and firmware). So, no, there is no further info one can get from it in your case.
    Digital licences are not written to the firmware and gets retrieved from the Activation server when an activation request is made. ie. can only be checked on Windows 10 - you will need to run ADT to see it tho'

    AFAIK you can still upgrade those machines with their current installations of 7/8 to 10 to get DL.


    ICIT2LOL said: View Post
    now in my last post I did mention the Showkey was not working on this machine I am on - currently running 7 and I am wondering why because a while ago Superfly posted an answer for the same question form me and said that running it in 7 needed a few bugs to be ironed out.

    Now I think he did that and it worked but now it is again not working - any reasons??
    I'm stumped m8... ShowKey+ should throw an error if it was application related.

    I specifically included error handling routines that will point to the exact code that was breaking...so dunno.

    Only thing I can think of is that the .Net 4 is flaky on 7..
      My ComputerSystem Spec


  3. Posts : 692
    7 and 10 on various machines
       02 Mar 2017 #593

    I'm stumped m8... ShowKey+ should throw an error if it was application related.

    I specifically included error handling routines that will point to the exact code that was breaking...so dunno.

    Only thing I can think of is that the .Net 4 is flaky on 7..
    Ok mate it really isn't that important at the moment I thought maybe it would come in handy when I dual boot this machine as I have an OEM 10 for it.

    The .NET thing I am not real sure what to do about that I will have a look to see how one checks it out.

    But thanks for the headsup
      My ComputerSystem Spec

  4.    04 Mar 2017 #594

    @Kyhi.. see the latest issue raised at github: Non silent when no Windows installation found . Issue #10 . Superfly-Inc/ShowKeyPlus . GitHub

    That functionality is WinPE specific, is it necessary to show the pop-up or should I remove that it when no windows installations are found?

    I don't do much WinPE stuff let alone networked installs, and haven't tested CLI mode in PE, but that would be the silent option IMHO.

    If anything I could improve that functionality if need be, rather than tamper with the GUI.

    Wot say you?
      My ComputerSystem Spec


  5. Posts : 1,870
    Windows 3.1 to Windows 10
       04 Mar 2017 #595

    It is outputting to the txt file just find, but it is showing the GUI with the message:
    "Auto-discovery did not find any Windows installations"
    "OEM information found..."
    Would think most users would like to see message > NO Installations Found or present
    As long as OEM BIOS Key is read - Cool..

    GUI a Non-Issue, seems to me, he trying to output key to txt file, but do it without user knowing ????
      My ComputerSystem Spec


  6. Posts : 692
    7 and 10 on various machines
       09 Mar 2017 #596

    Ok Superfly mate it worked this afternoon maybe my previous downloads were bad or whatever but at least it is working for me now on my 7 laptop
      My ComputerSystem Spec

  7.    10 Mar 2017 #597

    ICIT2LOL said: View Post
    Ok Superfly mate it worked this afternoon maybe my previous downloads were bad or whatever but at least it is working for me now on my 7 laptop
    That's just peachy Johnno... good to hear and thanx for reporting back.
      My ComputerSystem Spec


  8. Posts : 692
    7 and 10 on various machines
       10 Mar 2017 #598

    No worries mate I tied it again today just to ma sure it wasn't a fluke but it ran spot on and very quick
      My ComputerSystem Spec

  9.    19 Mar 2017 #599

    Just seen this article.
      My ComputersSystem Spec


  10. Posts : 12,199
    W10Prox64
       19 Mar 2017 #600

    swarfega said: View Post
    Just seen this article.
      My ComputerSystem Spec


 
Page 60 of 67 FirstFirst ... 10505859606162 ... LastLast

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:59.
Find Us