ShowKeyPlus

  1. Superfly's Avatar
    Posts : 3,328
    Thread Starter
       #541

    RobertJ said:
    Can't you create a really verbose version that logs everything for debugging purposes? That way you can run it till it crashes at random, and hopefully the log should help you track down what exception condition you've missed.
    Yup... I used log4net when developing WDT:
    Windows Diagnostic Tool (WDT) - Page 2

    RobertJ said:
    Edit: I see now you've posted a new version. Will give that a go and report back.

    Just for the record, I never launched multiple instances of the program and it still crashed during the update check. Is this exception you've fixed different and the update-related one is still present?
    With asynchronous execution, it's normally a timing issue when one thread conflicts with another - and objects have not been initialised yet by the time execution returns to the calling thread - that throws these errors at runtime - just needed a way to check.

    Berton said:
    A late posting but I have a Dell Inspiron 530S that has the Vista COA sticker with Product Key that I first Upgraded to Win7 Pro then put it in the Technical Preview program [now is the Insider Preview] that displays that same message in ShowKey.
    That's correct, you have a genuine Vista OEM firmware - it's just odd that MS has it in Hyper-V...

    ICIT2LOL said:
    Spot on Craig on my main machine - desktop and so quick really impressed with the work you have put into this
    John
    Good to hear, John... it's still flaky but Thanx
      My Computer

  2. Superfly's Avatar
    Posts : 3,328
    Thread Starter
       #542

    Version 1.0.6125 has been released. This is a fix to 6084 (probably one of the shoddiest builds...)

    Those running it should get an update notice (when it works...LOL)
      My Computer

  3. Cliff S's Avatar
    Posts : 25,548
    Win10 Pro, Win10 Pro N, Win10 Home, Windows 8.1 Pro, Ubuntu
       #543

    ShowKeyPlus-image-003.png
      My Computers

  4. Cliff S's Avatar
    Posts : 25,548
    Win10 Pro, Win10 Pro N, Win10 Home, Windows 8.1 Pro, Ubuntu
       #544

    ShowKeyPlus-image.png

    Since when have you added transparency Craig!?
    It turned transparent when it wen to download the new version!
      My Computers

  5. Superfly's Avatar
    Posts : 3,328
    Thread Starter
       #545

    Thanx Cliff

    Transparency should only appear when a pop-up gets displayed and should go back to normal thereafter - that build is more broken than I thought...
      My Computer

  6. Cliff S's Avatar
    Posts : 25,548
    Win10 Pro, Win10 Pro N, Win10 Home, Windows 8.1 Pro, Ubuntu
       #546

    ShowKeyPlus-image.png
    got the new one


    ShowKeyPlus-image.png
    Craig, you might want to think about switching to a gold colored font for the dark skin. That way there is less color bleeding and artifacts, plus it rally is easier on the eyes also.
    Gold:
    RGB(190,158,111)
    C++ (0x6F9EBE)
      My Computers

  7. Superfly's Avatar
    Posts : 3,328
    Thread Starter
       #547

    OK, cool - I'll it give it a go once the functionality is stable.
    BTW, transparency seems to work better with the dark colours, but if you give me the values for each of the components (I think it's Window, Windows Text, HotTracking (for the lines) and Highlight (for the links))
      My Computer

  8. simrick's Avatar
    Posts : 16,108
    W10Prox64
       #548

    Updater works great. :) Took me to the download for 1.0.6125, which also worked flawlessly.

    ShowKeyPlus-showkey-updater.png

    This is on GR 14393.222 (non-Insider)
      My Computer

  9. Superfly's Avatar
    Posts : 3,328
    Thread Starter
       #549

    Thanx budette,
    Transparency still needs a load of work - I'm thinking darken with blur etc... will call on the Theme Team for that, when the time comes

    BTW... I noticed somewhere in the AV thread it being flagged by WD... is this a common issue? See Virustotal results in the OP.
      My Computer

  10. simrick's Avatar
    Posts : 16,108
    W10Prox64
       #550

    Superfly said:
    Thanx budette,
    Transparency still needs a load of work - I'm thinking darken with blur etc... will call on the Theme Team for that, when the time comes

    BTW... I noticed somewhere in the AV thread it being flagged by WD... is this a common issue? See Virustotal results in the OP.
    Yeah, that was here:
    Can't update Windows 10 Anniversary - Page 7 - Windows 10 Forums

    That's the first time I've ever had anyone mention it to me, to be honest. That system is infected though, so ... yeah... working on that.
    I've run it on my systems with Defender for months and never had problems; I've also run it today with ESET without issue; also Avast (but that's been a few revs ago).

    EDIT: Just FYI - his Defender is not working properly.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:14.
Find Us




Windows 10 Forums