Removing dead icons from Start menu All Apps

Page 2 of 2 FirstFirst 12
  1. Peter D's Avatar
    Posts : 7
    Windows 10 Home x64

    Fix Corrupt All Apps list in Start Menu

    After days of trying to find a fix for the corrupted All Apps list in my Start Menu (apparently caused by uninstalling the rubbish apps that I neither need nor want), I finally came across this thread. This alerted me to the existence/use of the AppData\Local\TileDataLayer\Database\vedatamodel.edb. Didn't want to go down the track suggested by AcuraTML (too complicated for my limited skills) but the lx07/halasz solution didn't quite work either (xcopy failed).

    However, the info from both led me to another (simpler?) variation that after a bit of testing using newly created local Administrator accounts, took only about 10 minutes and worked perfectly.

    Three local Administrator accounts, including my own with the corrupt Start Menu, and one "clean" one using the halasz/Ix07 guidelines along with the "Take Ownership" function in my context menus (ref.

    1. Set up a new clean Administrator account (mine plus one other was already in place - otherwise set up two new ones)
    2. Log on to the a/c that is neither the problem one nor the new clean one and use the normal Windows File Explorer (set to view hidden files) to access the AppData\Local\TileDataLayer\Database\ folder in the Clean User account structure.
    3. Copy the vedatamodel.edb file in that folder and then paste it to the AppData\Local\TileDataLayer\Database\ folder in the Problem User structure, overwriting the file already there.
    4. If there is a permission problem (like when I tried to paste the vedatamodel.edb file) just "Take Ownership" of the target AppData\Local\TileDataLayer\Database\ folder before pasting the vedatamodel.edb file).
    5. Log out of the account and log back into the problem one - found problem fixed and User Menu fully restored to original glory with full "All Apps" list in place, including all the links to the traditional desktop applications (MS Office 2010, various audiovisual editing and specialist database packages) that had been in place on the PC before the problem occurred. Just because I'm a bit paranoid, I went to the AppData\Local\TileDataLayer\Database\ folder and used the "Take Ownership" function again from within my own account.
    6. Delete the "clean" user account if no longer required (can be easily recreated if problem comes up again).

    Worked for me...but one point that may/may not be relevant:
    Everything on my PC is Local Account based - I do not have a Microsoft account and do not use any sort of cloud based synching between my various PCs/Laptop/Tablet (the hard-wire and WiFi home network is adequate for that) and I have a Symbian phone rather than Apple/Android/Windows because I'm not surgically attached to the phone. I have no idea what would happen if the above fix was attempted where one of the user accounts involved a link to a Microsoft account.

    For interest, while I was testing this fix, I deleted the AppData\Local\TileDataLayer\Database\vedatamodel.edb file from a clean user account structure from within another user account. When I logged into the user account with the missing file, the Start Button worked but there were no apps in the start window. Over the next few minutes the whole "All Apps" list fully rebuilt itself but apps needed to be manually "pinned to the start menu" to show up in the apps window.

    Thanks for the help people...this is the only really useful source of ideas that I've found so far in dealing with Windows.
    Last edited by Peter D; 13 Dec 2015 at 18:54.
      My Computer

  2. Posts : 260
    Win 10 Pro X64
    Thread Starter

    I found the easiest way was to boot up with a live CD of any flavour of Windows and rename the file and upon booting back in it recreates it but might need a restart a couple of times. At least it worked for me
      My Computer

  3. Posts : 4
    win 10 pro

    AcuraTML said:
    That will work but also look at my work around above it corrects the permission or access problem also and faster

    Unless you or someone removed their apps like Cortina and other apps or all of them, then you need to get a hold of me to send you the commands and a tool to sort out and repair your start menu its again very simple have no fear
    Hey AcuraTML

    Any chance I could see this tool?

    I have a similar issue... I removed all my default apps through Powershell, but the tiles for them (no icon in the tile, just a coloured square) are still there, for example for "maps" or "alarms". When I click them nothing happens (makes sense since the app is uninstalled) but I can see no way to remove these dead entries from the "all apps" menu.

    If you could help out that would be great.

    I tried the fixes in this thread of renaming the EDB file... it just leaves me with a blank start menu :)
      My Computer

  4. Posts : 260
    Win 10 Pro X64
    Thread Starter

    The tools from AcuraTML won't help you remove the dead icons but the method he suggested will and try to follow it to the letter creating another account and giving permissions to the folder he suggested and it should work as it worked for me
      My Computer

  5. Posts : 4
    win 10 pro

    shimshom said:
    The tools from AcuraTML won't help you remove the dead icons but the method he suggested will and try to follow it to the letter creating another account and giving permissions to the folder he suggested and it should work as it worked for me
    Ahh thanks.

    I did end up just copying the edb file from the admin account... seemed to work fine!

    Was hoping there was a way to just repair my profile's file though but ah well, such is life.

    Thanks for the help :)
      My Computer

  6. Posts : 1
    w 10

    my broken tile points to a folder [deleted and forgotten] so any suggestions regarding an "app" fix for this tile do not help me
      My Computer

Page 2 of 2 FirstFirst 12

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:24.
Find Us

Windows 10 Forums