There are only a few metro app I have installed after installing and refreshing Windows 10. One of them is "Star Wars: Commander". I used to play it almost everyday. But suddenly, one day the app doesn't run anymore. When I click on the tiles (or from All Apps list), nothing comes; not even splash screen.

First thing I checked was the Store. Nothing was wrong there; no updates.
Second, I noticed there's no uninstall option when I right click the tiles. On the All Apps list, there's only a "Pin to Start" when I unpinned the tiles.
I tried uninstalling by the help of a tutorial using something like GetAppx on Powershell. Still nothing happens.
I tried DELETING the app data folder from Packages (on Local AppData) and WindowsApps (on Program Files). Went to store, it installed again, but the problem persists.
There's another user on my PC which is my brothers who also have Star Wars Commander installed, but in that account, it runs.

Anyone can help me with fixing this app?! Further details can be provided if required.