Any help would be appreciated, I upgraded my PC from Windows 8.1 to Windows 10 Pro (build10240) via the free upgrade. Everything worked fine until last week, when I was sitting at the PC and the Windows 10 Apps shortcuts vanished from the taskbar and now when I left click the Windows 10 start icon it does not work. Everything else appears to work OK. I have not added any programs or made any changes to the PC prior to the start menu and Windows 10 Apps failing to work.

On checking the web and various forums I have tried the following:

Result, Windows Resource Protection found corrupt files but was unable to fix some of them. I have run sfc at least six times with no change.

I then ran C:\WINDOWS\system32>Dism/Online /Cleanup-Image /ScanHealth
Result, The component store is repairable.

I then ran C:\WINDOWS\system32>Dism/Online /Cleanup-Image /CheckHealth
Result, The component store is repairable.

I then ran C:\WINDOWS\system32>DISM/Online /Cleanup-Image /RestoreHealth
Result, The source files could not be found.

I had created a Windows 10 installation disc (ESD-ISO) from the Microsoft Mediacreator and tried various ways to link this as the “Source” for DISM but it still shows “source files could not be found”. I also tried re-registering the Windows 10 Apps by using Powershell (Admin) with the following command Get-AppXPackage -AllUsers |Foreach {Add-AppxPackage -DisableDevelopmentMode -Register"$($_.InstallLocation)\AppXManifest.xml"}
which appeared to run OK but did not resolve the problem.

On checking another user profile the Windows Apps and start menu worked OK. I then created a new user profile and enabled “Show hidden files and folders” and cleared the “Hide protected operating system files” transferred all the folders and files from the non-working start menu profile with the exception of “Ntuser.dat”,Ntuser.dat.log1”, Ntuser.dat.log2” and Ntuser.ini”.

When I restarted the PC using the “new” user profile, the start menu and Windows 10 Apps still did not work, also in addition to this Windows File Explorer did not work with the error message “no file or programme associated with this” (or something to that effect, I am sending this from a different location).

I know that some users have reported problems with Avast anti-virus, however I am using AVG.

So in conclusion I am well and truly lost as how to resolve this apparently quite common problem, any help from the forum users would be greatly appreciated.

Many thanks,