1. Joined : Jan 2015
    Posts : 7
    Windows 10
       23 Sep 2015 #1

    Microsoft utility 'subinacl.msi'


    Can someone tell me if the Microsoft utility 'subinacl.msi' will work for W10.
    I've made a bit of a mess of my permissions I think. I have a MSI Nightblade with a 2 x mSATA boot drive for Windows and major apps, and a HDD for everything else.
    Most things seem OK, but some programs don't run. I'm told to login with administrator privileges and try again. This is for an old program that worked previously on another W10 box.
    I figured a utility like subinacl.msi may put things back to normal, if it works for 10.
    Any ideas please.
    Trevor

      My System SpecsSystem Spec


  2. Joined : Oct 2015
    Posts : 1,391
    Windows 10 Pro X64
       02 Jan 2016 #2

    Hi,

    I hope you solved your problem in the mean time but still:

    Yes it works fine under W10 not sure if it will help with your particular problem though.

    After installing 'subinacl.msi' open an admin command prompt and run the following by pasting it into the command box:

    @echo off
    title Resetting ACLs...
    cd /d "%ProgramFiles(x86)%\Windows Resource Kits\Tools"
    echo.
    echo Resetting ACLs...
    echo (this may take several minutes to complete)
    echo.
    echo ==========================================================================
    echo.
    echo System Drive...
    subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
    echo.
    echo.
    echo Windows Directory...
    subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f
    echo.
    echo.
    echo ==========================================================================
    echo.
    echo FINISHED.
    echo.
    echo Press any key to exit . . .
    pause >NUL
    Alternatively, you can save the above text as a batch file by opening notepad and paste it there then saving it and changing the .txt extension to .bat. Remember to run it with admin rights though.

    Cheers,
      My System SpecsSystem Spec


  3. Joined : Jan 2015
    Posts : 7
    Windows 10
       03 Jan 2016 #3

    Hi,
    Thanks for the reply.
    I still have an issue or two, but I'll give it a go when I can.
    Thanks
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Solved Lifecam HD-3000 appropriate drivers & software utility for Windows 10
I have a LifeCam HD-3000 webcam, the webcam works just fine, however, I can not get the software suite it normally comes with to work. The installation stops and says that something went wrong. On my previous installation of Windows 10, somehow I...
Drivers and Hardware
Share Port Utility
My share port utility and associated D-Link D-628 router will not work with Windows 10. I first installed Shareport Utility, then replaced it with SX Virtual Link which is suppose to work with W 10. With SX Virtual Link, and the firewall...
Network and Sharing
Multi Desktop utility's
Hey, So I just upgraded from 7 on which I used ultramon. I found this very useful and used a few of the utilities it came with, mainly the move window to next screen which I assigned to a macro key on my keyboard Now I know windows does this...
Software and Apps
Realtek Wireless lan utility AP mode
In windows 8.1 I could setup an access point trough realtek lan utility and set a network authentication but since I installed windows 10 the only option I have is open system: 27320
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:49.
Find Us
Twitter Facebook Google+



Windows 10 Forums