After going from w8.1 to w10 (clean installation) I have noticed my FAX program (Avanquest's Classic PhoneTools) isn't working well.

I can send faxes but I cannot receive them. I have noticed also that when the modem is working there is no sound at all (under w8.1 it sounded like an Spectrum computer loading from tape sound).

I have noticed that CPT must be run as administrator or it will have some permissions issues (it stores data at the ProgramData folder). I have also tried Vista compatibility mode (but there is no difference).

I have tested Windows internal built-in FAX program and it's the other way around: I can receive but it gives me an error when trying to send (line is occuppied or something like that).

Any ideas about how to test this issue?

PS - I forgot to say that I have also tried two different modem drivers (CXT). The original one (2006) and the one detected by Windows Update. No difference either. In fact, Windows one gets stuck in limbo after closing Classic PhoneTools with a dialog saying "releasing modem..."