Cannot install/uninstall Visual C++ 2015-2022

Page 4 of 4 FirstFirst ... 234

  1. Posts : 2,962
    Windows 10 Pro for the Bro
       #31

    garlin said:
    Try the Uninstaller troubleshooter, and reboot.
    https://support.microsoft.com/en-us/...b-e9f927e1eb4d
    I think he already tried that; post #16.
      My Computer


  2. Posts : 6
    Windows 10
       #32

    here's what i did
    - upgrade to windows 11 for business reasons (end of windows 10 support and testing windows 11)
    - pc neither does have tpm 2.0 or a modern cpu but windows 11 runs fine,
    setup.exe /product server from Windows 11 auch ohne TPM und Secure Boot installieren Deskmodder Wiki helped me
    - one medical x-ray device for USB doesn't work, twain software can start but driver for scanner utility won't be loaded, even manufacturer acteon is confused because they thought their x-ray-scanner from year 2013 works on windows 11. also a very new device called hp laserjet pro MFP 4102fdw doesn't work. printing works but scanner doesn't work. it's like windows 11 hates scanners
    - downgrade to windows 10. now the error as OP mentioned appears. i think it happened because of all the driver install tests from acteon

    now i have the same problem (at least only on one pc) and can't solve it.

    - - - Updated - - -

    saw this: https://answers.microsoft.com/en-us/...5-f7ed1f62f70e

    and did this
    Cannot install/uninstall Visual C++ 2015-2022-image_146.png
    went back to https://learn.microsoft.com/de-de/cp...rted-vc-redist
    to install the newest Microsoft.VCRedist.2015+.x64 version 14.38.33130
    my Microsoft.VCRedist.2015+.x64 was version 14.38.32919.0
    opened the VC_redist.x64.exe file because i was too unsure about cmd => winget upgrade Microsoft.VCRedist.2015+.x64 or cmd => winget install Microsoft.VCRedist.2015+.x64 and this appeared
    Cannot install/uninstall Visual C++ 2015-2022-image_147.png
    seems like the Microsoft Program Install and Uninstall troubleshooter REALLY did help me!
    to be sure i clicked on deinstall and installed the VC_redist.x64.exe for Visual C++ Redistributable Runtimes 2015-2022 again.


    thank you people!

    - - - Updated - - -

    this is interesting too: Developer Community

    it's not "...Minimum Runtime" but "...Additional Runtime" for me. i don't know were i read this but for me it was "...Additional Runtime"

    - - - Updated - - -

    when i run cmd => winget upgrade there is still Microsoft.VCRedist.2015+.x64 package version 14.38.32919.0 which wants to get upgraded to version 14.38.33130 and when i enter cmd => winget upgrade Microsoft.VCRedist.2015+.x64 it's like nothing specific happens except "installed successfully" somehow intereferin with the local installation i did and winget database.

    i will wait until the next version of Microsoft.VCRedist.2015+.x64

    - - - Updated - - -

    cmd => winget uninstall didn't work Microsoft.VCRedist.2015+.x64
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:07.
Find Us




Windows 10 Forums