1. Joined : Jul 2015
    Posts : 41
    Windows 10 Home 64-Bit
       29 Aug 2015 #1

    remove-AppxProvisionedPackage Unspecified Error


    Does anyone know how to fix these errors?

    Click image for larger version. 

Name:	ps.png 
Views:	5 
Size:	14.8 KB 
ID:	34573

    This happens for any provisioned package I attempt to remove (as listed by Get-AppxProvisionedPackage -online).
      My System SpecsSystem Spec


  2. Joined : Oct 2013
    Posts : 17,410
    64-bit Windows 10 Pro build 15007
       29 Aug 2015 #2

    Hello Clayton,

    See if the tutorial below may help for now.

    Apps - Uninstall in Windows 10
      My System SpecsSystem Spec


  3. Joined : Jul 2015
    Posts : 41
    Windows 10 Home 64-Bit
       29 Aug 2015 #3

    Actually, Option Three of that tutorial was my introduction to Remove-AppxProvisionedPackage.
      My System SpecsSystem Spec


  4. Joined : Oct 2013
    Posts : 17,410
    64-bit Windows 10 Pro build 15007
       29 Aug 2015 #4

    In your screenshot, you have an error in the command. You shouldn't have the gray -package included in the command.

    Instead, it should be this below substituting the part in red with the Finance app name instead.

    remove-AppxProvisionedPackage PackageFullName
      My System SpecsSystem Spec


  5. Joined : Jul 2015
    Posts : 41
    Windows 10 Home 64-Bit
       29 Aug 2015 #5

    Click image for larger version. 

Name:	ps2.png 
Views:	3 
Size:	50.5 KB 
ID:	34597

    Get-Help indicates that PackageName is not a positional parameter (that would be [-PackageName] <String>). It can be piped though. Actually, this cmdlet has no positional parameters.
    Last edited by claytoncarney; 29 Aug 2015 at 13:51.
      My System SpecsSystem Spec


  6. Joined : Jul 2015
    Posts : 41
    Windows 10 Home 64-Bit
       29 Aug 2015 #6

    Very odd. Structured this way, the command works:

    Code:
    PS C:\Windows\system32> Get-appxprovisionedpackage –online | where-object {$_.packagename –like "*BingFinance*"} | remove-appxprovisionedpackage –online
    
    Path          :
    Online        : True
    RestartNeeded : False
      My System SpecsSystem Spec


  7. Joined : Oct 2013
    Posts : 17,410
    64-bit Windows 10 Pro build 15007
       29 Aug 2015 #7

    Interesting. I'll have to do some more testing.
      My System SpecsSystem Spec


  8. Joined : Oct 2013
    Posts : 17,410
    64-bit Windows 10 Pro build 15007
       29 Aug 2015 #8

    I've updated the tutorial for this.

    Apps - Uninstall in Windows 10
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Explorer.EXE "Unspecified error" in "User's Files
Hi all, Just installed Win 10 pro on a new SSD, so a clean install. Started installing all my programs etc. Everything seems to be running well, except on thing that is annoying... I have placed a few icons on the desktop via right clicking...
General Support
Cannot run any files, get error File System Error (-1073741819)
So I just updated to ten, and have all the updates, but whenever I try to run a .exe file, it gives me the error File System Error (-1073741819)
General Support
Recovery --> Reset this pc --> Remove everything - Error: INACCESSIBLE
Hi there, About 4 hours ago I updated Windows on my laptop from Windows 7 to Windows 10. After waiting for some time, my laptop was successfully upgraded to Windows 10, working perfectly! :D Since it's an old laptop, I decided to give it a...
Windows Updates and Activation
Upgrade from 7: Update Error Code 80200053, & MediaCreationTool error
http://puu.sh/jj8wQ/4cad6d8add.png I have tried what I believe to be everything at this point. Clearing out the update download folder and retrying the update does not help whatsoever. Forcing the update through a command prompt just gets the...
Windows Updates and Activation
Build 10158 - Cannot remove foreign keyboard after adding it in error
Hi there I'm glad I'm testing on a VM - I accidentally added GEORGIAN keyboard layout - now I can't get rid of it. The REMOVE is greyed out in the options. Grhhhhh !!!!! Cheers jimbo
Windows Insider
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:24.
Find Us
Twitter Facebook Google+



Windows 10 Forums