Page 1 of 2 12 LastLast
  1.    29 Aug 2015 #1

    Audio engine missing


    Since installing Windows 10, I have tried to open two programmes that I had previously used successfully and received error messages about the audio engine.

    The first was Audacity (Wave recorder and editor) and I got two messages on trying to open it - "Error while opening sound device. Please check the input device settings and the project sample rate." The other message was "Could not find any audio device. You willl not be able to play or record audio. Error: Internal Port/Audio error."

    The second programme I tried to open gave me the following message "No audio devices. Audio Engine Error: Bas settings."

    The curious thing is that I can play things through iTunes for instance quite satisfactority (admittedly through and external amplifier, but that must mean that there's an audio output).

    Is it possible that Windows 10 has removed the audio devices or altered the audio engine settings (whatever that means!)? If so, how do I regain the status quo as far as audio is concerned?

    Many thanks to anyone who can help.


    Roy
      My ComputerSystem Spec
  2.    31 Aug 2015 #2

    Has anyone got any ideas on this? Thanks.
      My ComputerSystem Spec
  3.    07 Sep 2015 #3
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,469
    Win 10 Pro (1703)

    Hi, same symptom- also Ashampoo programs fail to find a sound card (Conexant HD 221, HP g60 5 yr old laptop). Ashampoo says they think they have a work-around- that was over a week ago.

    Audacity v2.03 works - later doesn't. I spotted that from a comment on the Audacity forum. Audacity sent me an email saying they had made some detailed changes.

    What is your sound card/driver? How old is your laptop?
      My ComputerSystem Spec
  4.    07 Sep 2015 #4

    Hi

    I've got Audacity 2.11 and 1.3 Beta, neither of which will work (audio engine missing). They worked perfectly OK with Windows 7 but refuse to work on Windows 10. According to the Device Manager on my 5-year-old Packard Bell PC, the Sound Video and Game Controllers are NVIDIA High Definition Audio and Realtek High Definition Audio. That's the sum total of my knowledge - I'm stumped!
      My ComputerSystem Spec
  5.    07 Sep 2015 #5
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,469
    Win 10 Pro (1703)

    Hi, so we both have older HP PCs and the same audio driver (I think).

    See:
    Audacity Forum View topic - InternalPortAudio error since windows 10 update

    Try Audacity v2.03, and see if you can play sound (load a file and play it in Audacity).

    Likewise, try e.g. Ashampoo Burning Studio 2015 - When it launches (after all the popups) you'll probably get a message about not finding a sound card.

    Everything else seems fine (and I've a lot of programs installed from Aimersoft to Zoom!).
      My ComputerSystem Spec
  6.    09 Sep 2015 #6

    I've now got my Lenovo laptop to work with Audacity 2.0.0 and the Conexant sound card. However the Hewlett Packard PC won't work (it uses Realtek) with any version of Audacity.
      My ComputerSystem Spec
  7.    09 Sep 2015 #7
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,469
    Win 10 Pro (1703)

    Hi roymathers,
    From the Audacity forum thread I quoted-
    "As some other people already told about it, the best solution is to update the audio drivers.
    In my case, it was a Realtek "High Definition Audio Codecs".
    The current version is R2.79 and with it, Audacity v2.1.1 can run perfectly under Windows 10."


    I've come across two other things some have said helped them:
    1. disable audio enhancements
    2. change the bit rate

    It's worth going to the Audacity forum and searching for, say,
    Realtek "Windows 10"
    Realtek no sound

    E.g.
    Audacity Forum View topic - Windows 10!!!
      My ComputerSystem Spec
  8.    09 Sep 2015 #8

    Thanks - I'll try that.
      My ComputerSystem Spec
  9.    09 Sep 2015 #9
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,469
    Win 10 Pro (1703)

    - I would be interested if you could try an Ashampoo product e.g. Burning Studio 2015.

    This reports on launch that it could not find a sound card, so functions will be restricted.
    (Their Movie Studio has a similar problem- I think the same will apply to any of their products that need a sound card).

    My HP laptop uses the Conexant driver.. but it may be interesting if I could report your findings to them as well, as they have been working on this for 2 or 3 weeks now, and asked me to collect several logs for them.
      My ComputerSystem Spec
  10.    10 Sep 2015 #10

    Hi

    I've just downloaded Ashampoo Burning Studio to my PC and it's working with no problems (although should a disc-burning application need a sound card, as it's just basically copying data?).
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Fingerprint. scanner Driver and Beats Audio missing
Recently installed win10 on my hp envy dv6-7363cl. Laptop came with win8. It had a fingerprint scanner and beats audio speakers. Is there a way I can get both back since the two are all hardware of the machine? I have installed the fingerprint...
Drivers and Hardware
Announcing Dolby Audio for high performance audio in Microsoft Edge
Source: http://blogs.windows.com/msedgedev/2015/05/26/announcing-dolby-audio-for-high-performance-audio-in-microsoft-edge/
Windows 10 News
strange audio, missing enhancements in audio settings
hello, since ive installed windows 10 on my macbook, ive had a few driver problems. one really annoying one is sound. it works but the options in playback devices are missing such as the enhancements. i use speaker fill but the option is...
Drivers and Hardware
Realtek HD Audio audio output speaker issue on Windows 10 RTM 10240
Hello Everyone. I have a Jabra bluetooth speaker (the Solemate Mini). On Windows 8.1 I plug it in to my laptop using the 3.5mm to 3.5mm cable and then, when I watch a movie, it correctly outputs to the speaker and does not use my laptop speakers....
Drivers and Hardware
10061 Missing Audio Driver
Hello, I recently updated to 10061, and now my headphones don't work. A yellow triangle with an exclamation point is on top of the name in the device manager, as well as an error 10 in the properties. Obviously it just has bad drivers, but these...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 02:00.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums