Winamp Issues with winamp.m3u and permissions

  1. Posts : 130
    Windows 10 Pro

    Winamp Issues with winamp.m3u and permissions

    Hey guys,

    So far I've been less than impressed with Windows 10's system permissions. I am in the Administrators group, as the only user on my PC, but yet I still have to provide UAC confirmation any time I try to do anything system-related. A bit ironic, no?

    Well, for some programs this is a huge issue. I'm using an older version of Winamp to play my music (long story short, the new versions have a lot of shareware crap built in, since they stopped making it a free program and instead wanted you to pay...)
    It's an old program, probably from 2003 or something, but it's worked fine on every version of Windows so far. Rather than using %appdata%, it just stores its settings locally. Winamp.ini and winamp.m3u store the settings and location of most recently played file respectively, and they're located in C:/Program Files (x86)/Winamp

    Right, so here's the thing. I have a mIRC script that reads Winamp's activity, and can show what song I am playing. If I run the app normally, it will not modify winamp.m3u (even though I've already edited the permissions of that file and the entire Winamp folder so that Users have full control... shouldn't matter since I'm admin but I digress). If I do "run as administrator", play a song and close the program, the m3u DOES get updated with the new song's location. However... my mIRC script doesn't behave when I do that, since the script still runs as a normal user like any other program, and somehow it just takes the bitrate, filesize and filetype of whatever I was listening to when the script was first run.

    This whole situation, and subsequently the UAC prompts to do stuff on my own computer, when I am the sole ADMIN user, make me like:

    But anyway. I tried the compatibility wizard, which set it to XP SP3 compatibility. That seemed to work, as it was now able to run as a "standard user" but still modify that m3u... except now my mIRC script gets completely lost and cannot pull any data at all. It just keeps saying I'm listening to the same song I was listening to initially, even when it's a completely different file.

    All I know is that if I don't use compatibility mode, and I don't run the program as admin, it cannot modify the winamp.m3u file, and as a result my script does not work properly.

    Any idea how to fix this? I tried properties, security and gave Users full permission... but it doesn't seem to help. I'm now able to write and delete files to the folder without UAC prompts (which is as expected since I did change the permissions of the entire folder) but Winamp itself just cannot mess with that file.
      My Computer

  2. Posts : 17,640
    Windows 10 Pro

    This is not a Windows 10 issue, it's working as it should, protecting the Program Files folder as designed. By default Windows protects the system folders with global security settings, everything placed for instance in Program Files and Program Files x86 folders inherit these global settings only giving users and groups permissions to Read, Read & execute and List folder contents.

    Your case is a typical example of this, another is for instance trying to save a text document from Notepad to Program Files or Windows folders; it won't work when Notepad is run normally giving Access Denied error, but can be done if Notepad is run as the built-in administrator.

    In your case it's not you as an admin user who should get the write permissions, it's (as far as I know) the group ALL APPLICATION PACKAGES:

    Winamp Issues with winamp.m3u and permissions-2015-08-23_12h22_54.png

    However, I do not recommend changing the default security settings of system folders. A far more simple solution would be to reinstall the software in question in another location, not in a system folder. Install your older WinAmp for instance to D:\WinAmp and you should have no issues, subject to you being able to edit your mIRC script to change the location from where it retrieves the information.

      My Computer

  3. Posts : 130
    Windows 10 Pro
    Thread Starter

    That didn't work. I gave full control to everything and it still won't let me modify that file unless I "run as admin"

    Winamp Issues with winamp.m3u and permissions-ywtnj0g.png

    It wasn't an issue on Windows 7 and I never used 8 so this is new to me. Super annoying, though.

    On that note, why does the built-in Administrator account get a pass while I don't? Can I make my account the same level of privileged as that one? I'd use that account instead of my own, but it can't run Metro apps...
      My Computer

  4. Posts : 130
    Windows 10 Pro
    Thread Starter

    I know I made this post months ago, but I've finally figured it out.

    It has to do with "VirtualStore" in the local appdata directory. I'm not sure why, but when I run the program for the first time it puts some of the files in there instead of in the normal spot.

    Even after changing the permissions, it continued to use VirtualStore... so the easy solution was just to delete the files in VirtualStore.

    All I needed was to add my username to "full control" of the Winamp folder and viola.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:11.
Find Us

Windows 10 Forums