Win10XPE - Build Your Own Rescue Media [2]

Page 25 of 32 FirstFirst ... 152324252627 ... LastLast
  1. MaloK's Avatar
    Posts : 993
    Windows 7
       #241

    AuraticTrance said:
    I don't see any Run or RunOnce keys on mounting loading the hives, and PATH doesn't have the root folder

    to my surprise there are two autoruns.cmd - one in Sys32 and one in root
    Try to search the whole registry for "autorun.cmd"
      My Computer

  2. AuraticTrance's Avatar
    Posts : 56
    Windows 10 Pro 1903
       #242

    I guess the one in System32 should be running somehow

    MaloK said:
    Try to search the whole registry for "autorun.cmd"
    Ok, i'll quickly test and be back

    - - - Updated - - -

    MaloK said:
    Try to search the whole registry for "autorun.cmd"
    I didn't find any autorun.cmd, maybe i'll try adding one and see. I could see PECMD.exe to load an ini file in RunOnce
      My Computer

  3. MaloK's Avatar
    Posts : 993
    Windows 7
       #243

    If it not running from there, you can try to add it to startup.

    Code:
    [HKEY_LOCAL_MACHINE\.Default\Software\Microsoft\Windows\CurrentVersion\RunOnce\Autorun"="hiderun.exe /w Autorun.cmd"
    It's a string value. And will run from System32.
      My Computer

  4. AuraticTrance's Avatar
    Posts : 56
    Windows 10 Pro 1903
       #244

    MaloK said:
    If it not running from there, you can try to add it to startup.

    Code:
    [HKEY_LOCAL_MACHINE\.Default\Software\Microsoft\Windows\CurrentVersion\RunOnce\Autorun"="hiderun.exe /w Autorun.cmd"
    It's a string value. And will run from System32.
    It's quite strange, the things in System32\autorun.cmd seem to be executing and running like for instance OskTray_x64.exe, passphrase start menu shortcut is being created at the start of WinPE
      My Computer

  5. MaloK's Avatar
    Posts : 993
    Windows 7
       #245

    AuraticTrance said:
    It's quite strange, the things in System32\autorun.cmd seem to be executing and running like for instance OskTray_x64.exe, passphrase start menu shortcut is being created at the start of WinPE
    If it's the case your search is over, use the one in System32.
      My Computer

  6. AuraticTrance's Avatar
    Posts : 56
    Windows 10 Pro 1903
       #246

    MaloK said:
    If it's the case your search is over, use the one in System32.
    It isn't easy - i did a test by copying the contents of Root\autorun.cmd into system32\autorun.cmd which was mainly creating shortcuts with nircmd

    But the problem is boot.wim loads into drive X: and the USB is on Y:\Programs. Not sure how do i set drive letter of USB. It is easy if the batch file was running in the same drive it would be ~dp0 simply

    Not sure of exactly how the author tried to implement this to make the root\autorun.cmd run 20seconds after startup
      My Computer


  7. MaloK's Avatar
    Posts : 993
    Windows 7
       #247

    AuraticTrance said:
    It isn't easy - i did a test by copying the contents of Root\autorun.cmd into system32\autorun.cmd which was mainly creating shortcuts with nircmd

    But the problem is boot.wim loads into drive X: and the USB is on Y:\Programs. Not sure how do i set drive letter of USB. It is easy if the batch file was running in the same drive it would be ~dp0 simply
    I knew that will popup...

    The best solution would be to mount and modify the Sytem32\autorun.cmd in boot.wim to call Y:\autorun.cmd at the end.

    Remove command duplicates from your y:\autorun.cmd and make your changes in it instead, this way you won't be forced to modify your boot.wim every time you want to add something.

    - - - Updated - - -

    MaloK said:
    I knew that will popup...

    The best solution would be to mount and modify the Sytem32\autorun.cmd in boot.wim to call Y:\autorun.cmd at the end.

    Remove command duplicates from your y:\autorun.cmd and make your changes in it instead, this way you won't be forced to modify your boot.wim every time you want to add something.
    What... 20 seconds delay... forget previous post... Contact Bob... Lolll... This could be chained directly...

    Create a Runonce for you own script...
      My Computer

  8. Kyhi's Avatar
    Posts : 3,728
    Windows 3.1 to Windows 10
    Thread Starter
       #248

    Bob's winpe is win10 PESE based and he altered the project a lot....

    Have not seen Bob around since lance can back from long vacation and completely rewrote PESE to support XPE....
    Reason - Win10 PESE was turned over to Bob (at his request and with Chris's permission) when XPE became stable enough - then lance ran with it - completely rewrote every script and that pissed Bob off...
      My Computer

  9. OliverJia's Avatar
    Posts : 42
    Windows 10 LTSC 2019
       #249

    Maybe off topic but I think I'll still want to ask Kyhi - would Win11XPE something ChrisR or you would consider since Win11 went official?
      My Computer

  10. MaloK's Avatar
    Posts : 993
    Windows 7
       #250

    Considering I can still use a winXP based PE to recover almost everything at the moment. This should give them a merry good break. I'm using 2004 as source and don't foresee any major constraint regarding RE/PE Recovery abilities coming anytime soon.
      My Computer


 
Page 25 of 32 FirstFirst ... 152324252627 ... LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:37.
Find Us




Windows 10 Forums