Windows 10: New Core Temp does not work properly in Win 10 Pro Solved

  1.    21 Aug 2015 #1

    New Core Temp does not work properly in Win 10 Pro

    Hi folks!

    I just can't get the new Core Temp version 1.0 RC7 to work properly with my Win 10 Pro RTM installation. I am using it with Desktop Gadgets All CPU Meter. I can get it to do everything but load itself at Windows 10 startup. The option to select it in the Options menu will not stay checked once I press the Apply button. As soon as I open the application again to see if it is checked, it has for some reason become unchecked, and when I restart my PC I have the same problem. I have also tried running it from the Start Up folder in the C: Program Data folders but it won't start from there either.


    I have Googled the problem and several people say the new 1.0 RC7 version does work with the 10240 release--but not for me. I have even tried running it in compatibility Mode for Win 7 and 8 but still no joy!

    Has anyone else had this problem and figured out the solution? Is there perhaps a corrupted Registry value that needs to be changed?


    PS I have also tried PC Meter but it won't start or hook into my All CPU desktop gadget to read the CPU core temps either. And I have tried the Compatibility Mode changes as well, but still no joy--again!
    Last edited by Todd; 21 Aug 2015 at 08:55.
      My ComputerSystem Spec

  2.    21 Aug 2015 #2

    OK, I found out how to autostart Core Temp using the Task Scheduler as shown in the first post on this page: ALCPU Forums Vista - Guide

    He says to do the following, and it worked perfectly for me, (though when I opened Task Scheduler it gave me about 20 successive Error messages that I had to clock OK on before I could actual reach the Task Scheduler).

    1. Run core temp and disable 'Start Core Temp with windows' enable 'start minimized'
      enable 'enable plugins' if using the vista sidebar gadget or anything that needs CT access.
      all other options are at the discretion of the user.
      Click OK.
    2. Remove the program from the Startup folder or any RUN/STARTUP registry key. - Disabling 'start CT with Windows' should actually have removed the registry key entry anyway.
    3. Move Core Temp.exe to a directory that is NOT 'Programs x86' or anywhere else controlled by Windows. I created a directory in my 'Users/my login name' directory called 'startupapps' and put 'Core Temp.exe' in there. (Note: strictly speaking this is not required, but some have reported they needed to do this so I simply wrote what I tested and checked as working.)
    4. Launch the Task Scheduler (Control Panel -> Administration Tools -> Task Scheduler)
    5. From the Actions panel on the right, select Create Task...
    6. Give the Task a description of 'CoreTemp' (or anything else you feel like if you want to be cryptic)
    7. Go to the Security Options on the General tab
    8. Select an user account with administrative privileges
    9. Select the radio button Run only when user is logged on
    10. Check the box Run with highest privileges
    11. Go to the Triggers tab and click New...
    12. In Begin the task, select At log on
    13. In the Settings options, select All users
    14. In the Advanced Settings options, check the box Enabled
    15. Click OK to close the dialog
    16. Go to the Actions tab and click New...
    17. For Action, select Start a program
    18. In the Settings options, browse for the Program/Script you want to execute on startup
    19. Click OK to close the dialog
    20. Go to the Settings tab
    21. Check the box Run task as soon as possible after a scheduled start is missed
    22. Uncheck the box Stop the task if it runs longer than
    23. Click OK to save and close the task properties
    24. Logout.
    25. Login.
    26. Wait - Core Temp will eventually load - usually instantly, but may be up to 30 seconds or so.

    Core Temp will now start when you login *without* any request for permissions even when UAC is enabled.

    Though he wrote this for the Windows Vista OS, it worked perfectly for me in Windows 10 Pro too!

    The Core Temp 1.0 RC7 (allegedly written specifically for Windows 10) can be found here:
      My ComputerSystem Spec

  3. JohnBurns's Avatar
    Posts : 368
    Windows 10 1803 Build 17134.319
       15 Nov 2015 #3

    Todd, I know this is an old thread - but I just found it by Googling for CoreTemp. I want to thank you for posting and making such detailed instructions. I got CoreTemp installed and working on my Windows 10 pc which I just updated. Running great. Thanks again. John
      My ComputerSystem Spec

  4.    16 Nov 2015 #4

    Hey, you're welcome John!
      My ComputerSystem Spec


Related Threads
Windows 10 Temp Folder in Performance & Maintenance
I have 19 items in my temp folder that will not delete. They all start with AppX. When I try to delete, I get a can't delete in use by another file message. I have tried searching the items but nothing. I have been unsuccessful in...
Over 50GB of Temp Files in AppData Subfolder in Performance & Maintenance
I have over 50 GB of folders and files in the following directory: C:\Users\Chris\AppData\Local\Temp Can those files be removed? I was wondering where all my space was going... prior to upgrading to Windows 10, I had 135-140GB free out of 240GB,...
CPU temp -- is this running too hot ? in Drivers and Hardware
Hi there running a fairly heavy but not unduly load the CPU seems to be running at about 75 deg C peak -- Avg about 61 deg C. Is this likely to cause trouble over prolonged periods. I know that these devices can run extremely hot but I don't...
Hi there Build 9879 doesn't work properly in Unity mode ---(VMware workstation 10.0.4 and 11.0) Not a mega issue but Unity mode is great if you want to concurrently test things without flipping back into the VM's full screen mode. Part of...
Hi there I see a load of posts about people running W10 as a VM -- I'm curious to know if it's running OK, whether they can install VMware tools (or vbox additions if they are using vbox) and what version of VMware / vbox are they using. I...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:43.
Find Us