Dymo Labelwriter 450 has stopped working

Page 1 of 2 12 LastLast

  1. Posts : 37
    Windows 10 Pro
       #1

    Dymo Labelwriter 450 has stopped working


    This has been working perfectly until today when the print jobs just get stuck in the print queue. Further investigation suggests that the USB connection may not be working, in Device Manager the USB controllers list contains an entry “Unknown USB Device (Device Descriptor Request Failed)” with an error exclamation on it.

    I have tried uninstalling and reinstalling the software - no luck.

    The form feed button on the front of the printer is not working although the blue LED illuminates normally.

    Any ideas on how to fix this appreciated.
      My Computer

  2. fireberd's Avatar
    Posts : 2,455
    Win 11 Pro
       #2

    I have a 450 Turbo.

    The unknown USB device suggests its status may be corrupted.
    Try this, power the unit on then go to the Device Manager and the unknown USB device. Right click on that entry and then Left click "Uninstall". DO NOT uninstall the driver/software. Then disconnect the 450. Restart Windows and after its initialised connect the 459 and Windows should detect and install it. If it was just the status corruption this will fix it.
      My Computers


  3. Posts : 37
    Windows 10 Pro
    Thread Starter
       #3

    Fireberd,

    Thank you so much, that worked!
      My Computer

  4. fireberd's Avatar
    Posts : 2,455
    Win 11 Pro
       #4

    Great. Glad I was able to help.

    Jack
      My Computers


  5. Posts : 37
    Windows 10 Pro
    Thread Starter
       #5

    Oops spoke too soon!

    The problem has re-appeared as per the original post 3 days ago?
      My Computer

  6. fireberd's Avatar
    Posts : 2,455
    Win 11 Pro
       #6

    Several possibilities. (1) hardware problem with the Dymo unit (2) bad USB cable (3) USB port.
    Try a different USB port, if you haven't done this and/or a different USB cable. If problem persists I would suspect the Dymo unit.
      My Computers



  7. Posts : 37
    Windows 10 Pro
    Thread Starter
       #7

    I'm not getting any errors showing in Device Manager any longer but still no joy getting the printer to work. I have tried different USB cable and USB port without success.

    Is there anyway that I can test the printer before I bin it? It seems strange that this issue only started when I changed the PC hardware so I don't want to bin the printer if its still OK?
      My Computer

  8. fireberd's Avatar
    Posts : 2,455
    Win 11 Pro
       #8

    If its shown in the Device Manager with or without an error, uninstall it (DO NOT uninstall any drivers/apps). Leave it connected and restart the PC. See if its working.

    Do you have another PC or a friend with a PC that will allow you to connect it for testing? That would be my next suggestion to see if it works OK on another PC and doesn't quit like it is with your new hardware PC. That will tell you if its the unit or something in your PC.
      My Computers


  9. Posts : 37
    Windows 10 Pro
    Thread Starter
       #9

    Thanks again fireberd,

    Well its certainly getting more interesting!

    I loaded the software on another PC and the printer worked fine. I then reconnected the printer to the original PC and (so far!) its working again?

    The only additional measure was to disconnect the printer from power overnight, perhaps this may be a way of resetting the firmware or something similar?
      My Computer

  10. fireberd's Avatar
    Posts : 2,455
    Win 11 Pro
       #10

    You loaded the printer software on another PC and it worked OK, but will it last or will it fail like the original PC? Have to leave it on the different PC for a while to see.
      My Computers


 
Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 00:01.
Find Us




Windows 10 Forums