Windows 10: Administrator Problem

  1.    13 Aug 2015 #1

    Administrator Problem


    Hello, I installed Windows 10 on my HP desktop and when I tried to modify an Excel spread sheet it said I was not the administrator. I purchased the complete 2007 Ultimate Office and this is the first time I have ever had a problem. How can I correct this?
      My ComputerSystem Spec

  2.    16 Aug 2015 #2

    The error happens on saving, not when inside the spreatsheet you change a letter or so, right?

    I do not know an exact solution right now, but does it tell you the reason, for why you would have to be an administrator to save a spreadsheet?

    If the reason in fact is that the file suddenly is write-protected, then there is at least one other thread about this issue here in this forum: MS office issues - Windows 10 Forums
    Last edited by Joergi; 16 Aug 2015 at 19:03. Reason: link added
      My ComputerSystem Spec

  3.    16 Aug 2015 #3

    The message I get when I change something is as follows - CD Collection.xlsx is read only, then I get - To save a copy, click OK then give the workbook a new name in the save as dialog box. I tried this and it said I was not the administrator and I could not continue.
      My ComputerSystem Spec

  4.    16 Aug 2015 #4

    It happens to Word documents as well. Even though when you look at the properties of the actual document, the 'read-only' box is not ticked, the documents only open in 'read-only' mode. This is causing me big problems at the moment. I can't even save the document under another name because it says I don't have permission, but I can't work out how to find the permission to do it! Getting very tempted to go back to Windows 7.
      My ComputerSystem Spec

  5.    16 Aug 2015 #5

    BigDude97, what you describe can be two different problems. Am I right that the Spreadsheet should not be read-only? Or is it intended to be read-only?
      My ComputerSystem Spec

  6.    16 Aug 2015 #6

    I just found a solution on another thread..... I printed it out, but I can't remember where I found it exactly. You need to make sure that the Administrator has FULL control for the relevant folder. Once you do that under Properties, Security.... you should find that you can now save the documents in your folders as you did before. Make sure you are on the Documents folder when you do this, and it will cascade the permission to all subfolders that you may have created over time.
      My ComputerSystem Spec

  7.    16 Aug 2015 #7

    Joergi said: View Post
    BigDude97, what you describe can be two different problems. Am I right that the Spreadsheet should not be read-only? Or is it intended to be read-only?
    I am the only administrator on the computer and have never assigned anything read-only , can adjust anything anytime until now. Should I try to call HP the computer maker or try to call MS again? The last time I called they had a 300 minute waiting period.
      My ComputerSystem Spec

  8.    17 Aug 2015 #8

    So the file should in fact not be read-only.

    There are two possible reasons:

    1. The file might be used by another program, e.g. by a virus scanner. I think this is rather unlinkely in your case; in my experience, if this is the problem, the files while already opened suddenly become write-protected. You can check, if this is the problem by booting Windows in safe mode and trying again. A guide on how to boot Windows 10 in safe mode is available here: 4 Ways To Boot Into Safe Mode In Windows 10 - I would recomend using method number 2 (Shift + Restart combination).

    If the problem is also present in safe mode, then it most likely is not another program, which accesses the file.

    2. NTFS file and folder permissions might be wrong. I assume that your spreadsheet is located somewhere inside your own user folder, e.g. in C:\Users\BigDude\... Here is a guide on how to properly set permissions for your user folder:

    By default, Windows sets NTFS permissions for your user folder (e.g. for C:\Users\BigDude\) and these then are inherited to all subfolders like to the Desktop\, to the folder Pictures\ and so on. Rightclick your user folder, select Properties > Security > Advanced.

    For your user folder, the owner should be set to "SYSTEM".

    Below in that window, you should see exactly three different permissions:

    One for "SYSTEM", one for "Administators" and one for your username (e.g. BigDude).
    For each of them the following should be set: "Full control", inherited from "not inherited", applies to "this folder, subfolders and files".

    It may be that one of these three permissions is missing in your case. Also it might be, that you also have another entry, wich gives "unknown account" some kind of permission. This entry most likely is superfluous as it does no longer reference an existing user.

    For the different subfolders like Desktop\, Pictures\, Documents\ and so on, the owner should not be "SYSTEM", but it should be your user account.

    Apart from that, the same permissions as for your user folder itself should be set.

    Applying those settings should basically fix issues with missing permissions for files inside the user folder.

    Afterwards, you can rightclick the spreadsheet, go to Properties > Security > Advanced and verify that the file gets the right permissions: The file should not have any permissions set for itself, but it should correctly inherit the permissions of the according folder.
      My ComputerSystem Spec


 

Related Threads
Apps & Features Run as Administrator in Windows 10 in Tutorials
How to Run an App as Administrator in Windows 10 Some legitimate applications require a full administrator access token (elevated) to perform their functions or tasks. For example, when a program that you are trying to run is giving you a Access...
Windows 10 Administrator Problem in User Accounts and Family Safety
Having an issue with the Windows 10 upgrade. I am not sure that I am going to explain this well. I am upgrading on a Lenovo T420 from Windows 7. I was not going to upgrade right away to Windows 10 until I could read about it and some of the early...
Administrator Account in User Accounts and Family Safety
Hi everyone, I had upgraded to Windows from windows 8.1 to windows 10. When I was on windows 8.1, I enabled built-in Administrator account and that is the only user which has the admin privileges. But after upgrading to windows 10 that built in...
Administrator password problem in General Support
I was originally having problems with needing admin access to do everything, and while attempting to follow an online tutorial to fix this problen, I have landed myself in an even bigger one. On start up the computer automatically tries to log in...
administrator group in AntiVirus, Firewalls and System Security
I forget; how do i make my user a member of the administrator group?
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:44.
Find Us