Can i install a missing system app (PPI Projection)?


  1. Posts : 71
    windows 10
       #1

    Can i install a missing system app (PPI Projection)?


    Here is my story in short:

    Did a clean install last week and received the latest version of 64 bit Windows 10 (the May 2020 update) version 2004 (build 19041.264). Tried to use project to this computer and in due course realized that the entire PPIProjection system app was MISSING from the install (seriously!). tried searching with the key word and the laptop did not return a single hit (on my other laptop there were not less than 14 hits including many in the SxS folder - but this laptop is running a windows 10 version prior to the above)

    So what do i do....
    Goggled on the net, came across some stuff i could do and eve read Shawn Brink's terrific article on reinstalling, registering and troubleshooting apps etc

    So i lift the app from my other laptop which has it in windows -systemapps and paste it in windows - program files- windowsapps (for which i had to take ownership of the folder and objects within)

    Then i tried to register the app with the following Powershell command (run with and without admin UAC control)
    $ManifestPath = 'C:\Program Files\WindowsApps\Microsoft.PPIProjection_cw5n1h2txyewy\AppxManifest.xml'
    Add-AppxPackage -Path $ManifestPath -Register -DisableDevelopmentMode

    I kept getting this message
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073CFF, To install this application you need either a Windows
    developer license or a sideloading-enabled system.
    Deployment of package Microsoft.PPIProjection_10.0.18362.449_neutral_neutral_cw5n1h2txyewy with package origin
    Unsigned failed because no valid license or sideloading policy could be applied. A developer license
    (http://go.microsoft.com/fwlink/?LinkId=233074) or enterprise sideloading configuration
    (http://go.microsoft.com/fwlink/?LinkId=231020) may be required.
    NOTE: For additional information, look for [ActivityId] f1d7c80a-3e5c-0001-c203-d8f15c3ed601 in the Event Log or use
    the command line Get-AppPackageLog -ActivityID f1d7c80a-3e5c-0001-c203-d8f15c3ed601
    At line:1 char:1
    + Add-AppxPackage -Path $ManifestPath -Register -DisableDevelopmentMode
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (C:\program file...ppxManifest.xml:String) [Add-AppxPackage], Exception
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

    So i even go to settings - update and security - for developers and turned on the setting "install apps from any source including loose files" (this section has a changed interface in the latest build of windows 10) . Ran the commands to register again but continued receiving the above listed error

    I am now tearing my hair in frustration and would like to ask experts here what i can do?

    When i clean installed the windows package i had imaged my laptop system drive. I mounted the image and looked within the windows -systemapps and program files- windowsapps folders BUT Microsoft.PPIProjection_cw5n1h2txyewy is not there too and this is a fresh install using media creation tool

    So refreshing the laptop will do nothing, I guess

    I AM STUMPED!

    Any help pleeeeeease?!??
      My Computer


  2. Posts : 35,468
    Win 10 Pro (21H2) (2nd PC is 21H2)
       #2

    I guess you've seen this:
    Manual Install Microsoft.PPIProjection when its missing - Windows 10 - Spiceworks

    Regarding your error message:
    To install this application you need either a Windows
    developer license or a sideloading-enabled system.
    maybe this helps:
    https://docs.microsoft.com/en-us/win...or-development

    but I'm guessing you've been there, done that.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 16:59.
Find Us




Windows 10 Forums