Page 1 of 2 12 LastLast

  1. Joined : Aug 2015
    Posts : 5
    windows 10
       11 Aug 2015 #1

    .NET Framework 3.5 error 0x800736B3


    hey there, so i recently upgraded to windows 10 and today while trying to launch a game i got a message saying i don't have .NET Framework 3.5 installed. every time i try to install it, though, it doesn't work and it always gives me the same error: Reference assembly not installed in the system, error 0x800736B3. i tried enabling it in Windows Features, but it stops halfway through and says changes couldn't be applied. i've tried following various instructions but nothing seems to work. any help is greatly appreciated!
      My System SpecsSystem Spec


  2. Joined : Jun 2015
    Posts : 1,604
    Windows 3.1 to Windows 10
       11 Aug 2015 #2

    Insert your setup media and run this cmd.

    Dism /online /enable-feature /featurename:NetFx3 /Source:X:\sources\sxs /all /LimitAccess

    replace x with the drive letter of your setup media
      My System SpecsSystem Spec


  3. Joined : Aug 2015
    Posts : 5
    windows 10
       11 Aug 2015 #3

    i tried that already (many times) and i always get the same thing back:

    C:\Windows\system32>Dism /online /enable-feature /featurename:NetFx3 /Source:E:\sources\sxs /all /LimitAccess


    Deployment Image Servicing and Management tool
    Version: 10.0.10240.16384


    Image Version: 10.0.10240.16384


    Enabling feature(s)
    [==========================100.0%==========================]


    Error: 14003


    The referenced assembly is not installed on your system.


    The DISM log file can be found at C:\Windows\Logs\DISM\dism.log
      My System SpecsSystem Spec


  4. Joined : Jun 2015
    Posts : 1,604
    Windows 3.1 to Windows 10
       11 Aug 2015 #4

    you have you setup media ? look into that sxs folder it is the only package included

    Attachment 30598
      My System SpecsSystem Spec


  5. Joined : Aug 2015
    Posts : 5
    windows 10
       11 Aug 2015 #5

    it's there but as a rar file?

    Click image for larger version. 

Name:	Screenshot_8.png 
Views:	1887 
Size:	6.0 KB 
ID:	30600
      My System SpecsSystem Spec


  6. Joined : Jun 2015
    Posts : 1,604
    Windows 3.1 to Windows 10
       11 Aug 2015 #6

    you have a WinRAR file association to .cab file
      My System SpecsSystem Spec


  7. Joined : Aug 2015
    Posts : 5
    windows 10
       11 Aug 2015 #7

    so, um, what do you suggest?
      My System SpecsSystem Spec


  8. Joined : Jun 2015
    Posts : 1,604
    Windows 3.1 to Windows 10
       11 Aug 2015 #8

    based on the file size it is x86 version
      My System SpecsSystem Spec


  9. Joined : Aug 2015
    Posts : 5
    windows 10
       11 Aug 2015 #9

    yeah, when you open the archive there are only x86 files, so i guess i'll just redownload. thanks a lot, i never would have thought to look there!
      My System SpecsSystem Spec


  10. Joined : Aug 2015
    Posts : 1
    Windows 10 Pro
       11 Aug 2015 #10

    Kyhi said: View Post
    Insert your setup media and run this cmd.

    Dism /online /enable-feature /featurename:NetFx3 /Source:X:\sources\sxs /all /LimitAccess

    replace x with the drive letter of your setup media
    Thanks Kyhi - this worked perfectly!
      My System SpecsSystem Spec


 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Solved .NET framework prevents shutdown after Win8.1 -> Win10 upgrade
Since I've upgraded from Win 8.1 to Win 10, I can't turn off my PC without getting an exception in .NET Framework, and then a message that it is preventing shutdown. Google shows that this problem isn't exactly new and already happened to some...
General Support
Unable to install framework 3.5, error 0x800736B3
Hi! I just do clean install windows 10 and unable to install net framework 3.5 it give an error 0x800736B3 "The referenced assembly is not installed on your system" , I did try to enable group policy setting that I read from microsoft helper but...
Software and Apps
.NET Framework Error (0x800F081F)
Whenever I try to use anything that uses .NET Framework I need to re download it. The problem is that whenever i try to the error message "Windows couldn't find the required files to complete the requested changes. Make sure you're connected to the...
Software and Apps
Announcing .NET Framework 4.6
Read more: Announcing .NET Framework 4.6 - .NET Blog - Site Home - MSDN Blogs
Windows 10 News
How to uninstall net framework 4.6?
How to uninstall net framework 4.6?
Software and Apps
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:44.
Find Us
Twitter Facebook Google+



Windows 10 Forums