Built-in apps fail to launch  

  1. Posts : 20
    Windows 10 Pro

    Built-in apps fail to launch

    Not sure which forum to post this in -- since it has to do with apps, trying here.
    I'm at my wits end with my new Windows 10 laptop! The built-in apps (e.g., Connect, Feedback Hub, Microsoft Store, Movies & TV) show splash screens and then disappear after a couple seconds. Unfortunately, I can't say whether they've ever worked -- I've never tried to use them before!
    With respect to the Microsoft Store app, I've gone through the wsreset.exe process -- the result is a dialog box titled "MS-Windows-Store:PurgeCaches" which states: "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access this item." Of course, since Feedback Hub doesn't work either, I can't submit any.
    I'm the sole user -- therefore administrator -- of this laptop. I show as having full control of the entire folder/file structure.
    Looking at that app, I see it says: "Version 120001.1001.5.0, App 0 bytes, Data 0 bytes, Usage 0 bytes"
    Similarly. looking at the Movies & TV app, I see: "Version 10.20011.10711.0, App 0 bytes, Data 16.0 KB, Usage 16.0 KB"
    I tried resetting both of them -- no change in results.
    Ran some of the "Get-AppxPackage..." seen in other posts command in PowerShell (opened as administrator) to reinstall all apps -- no change in results. However, there were numerous failure messages. Most said: "Cannot find path Program Files\WindowsApps\...." -- for good reason: there is no such folder! A few were "Deployment failed with HRESULT..."
    I really Really REALLY don't want to reset the computer -- it's taken quite a while and trouble to get everything up and running smoothly!
    Laptop is Toshiba Tecra A50-EC running W10 Pro v. 1909.
    What else can/should I try?

    - - - Updated - - -

    Supplemental: Found WindowsApps folder (at bottom of all the "Windows ..." folders). Found I did not have access; took ownership. Reran the "Get-AppxPackage..." command in PowerShell -- far fewer error messages, many more apparent successful recoveries. However, now, instead of a couple seconds, the splash screen shows and then is gone in an instant!
      My Computer

  2. Posts : 40,568
    Win 10 Pro (22H2) (2nd PC is 22H2)

    Hi, as you don't know when this occurred, so neither a system restore point nor a disk image (nevertheless you do use disk imaging, I hope, as is so so often recommended here to help people recover from problems themselves in many circumstances - you say

    [QUOTE -- it's taken quite a while and trouble to get everything up and running smoothly![/QUOTE]

    It does, however, make me wonder if you've been doing some tweaks and modifications which have led to this problem.

    I note:
    I show as having full control of the entire folder/file structure.
    suggesting you have made changes to permissions.

    I really Really REALLY don't want to reset the computer
    I hear this so often. How have you tried to protect yourself?
    Routine use of disk imaging is a good way to help you avoid clean installing - so long as you have noticed the problem in a timely manner.

    First confirm that you see the same problem if you create a new user for test purposes, log in as that user and check.

    If you don't, post back.

    If you do, you could go straight for an in-place upgrade repair install.

    This keeps all progs and data and most settings.

    Tutorial available. You need a 1909 iso file (use the MS media creation tool - Google- to get one).

    Rt click the iso, click Mount.
    Open the new drive letter created in file explorer,
    Double click setup.exe
      My Computers

  3. Posts : 20
    Windows 10 Pro
    Thread Starter

    Downloaded W10 1909 ISO file, and both created a DVD and kept it on the desktop. Right-clicked file on desktop, but no "Mount" option. Was that what I was supposed to do?

    - - - Updated - - -

    Well! Figured out how to "mount" ISO file. Performed Inplace Upgrade Repair Install. Now I've got numerous file/folder access problems -- can't even do a deletion of a supposedly corrupted recycle bin 'cause it needs administrator permission, even though my account is clearly identified as administrator. AND the apps still don't work!
      My Computer

  4. Posts : 40,568
    Win 10 Pro (22H2) (2nd PC is 22H2)

    Thank you very much for taking the time to reply.

    1. 'Mount' is not available if you have assigned iso as a file type to another program as default.

    2. Prior to the in-place upgrade repair install, did you first check whether you had the same problem when logged in as a new user as per my post?

    3. Note that not all corruption can be magically and instantly fixed. Sadly some people think there's always some instant fix to random problems. For example, if you have made permissions changes which have adverse effects, an in-place upgrade repair install may not necessarily correct these. Likewise it will not fix user account specific issues. See (2).

    4. tenforums members tirelessly recommend you routinely use disk imaging to give you a second chance in many circumstances e,g, Macrium Reflect (free-paid). Do you have such disk images?

    5. Basic checks.
    As I know nothing about the state of your system, please run these basic checks:
    a. Check your disk(s)
    E.g. run HD Tune free Health and Error Scan tabs
    Download HD Tune 2.55
    and report the results

    b. If ok from an admin command prompt run
    chkdsk c: /scan
    and report the summary result.

    6.Permissions issues. As I suggested- and you made no comment:
    I note:
    I show as having full control of the entire folder/file structure.

    suggesting you have made changes to permissions.
    If the above checks are ok, and assuming your permissions are messed up, please try running

    Tweaking.com's free cautious repair tool selecting only repairs 1,2,3
    Built-in apps fail to launch-1.png
      My Computers

  5. Posts : 20
    Windows 10 Pro
    Thread Starter

    OK: I've been seeking help from both Windows10Forums and here, and trying suggestions from both. I'm preparing this single response to provide to the people on both so both know what I've tried, and with what results.
    1. No, I don't have a total disc image backup -- unless the full drive C:\ backups created using Norton Ghost 15 (yes, I know: ancient -- but works great!) count.
    2. Added MS account using pre-existing outlook.com account, logged out of local account and back in with it -- no change in function of apps like Store, Movies & TV, etc.
    3. Shut down completely and restarted, logging in using the MS account. No change.
    4. Downloaded W10 1909 ISO, and "mounted" using instructions found online (PowerShell: "MountDiskimage -ImagePath..."). Used it to perform Inplace Upgrade Repair Install. No change in performance of the apps, but major issues trying to regain ownership of my computer (e.g., All Users, Program Data, WindowApps, etc.)
    5. Decided to do a second InPlace Upgrade Repair Install. Unfortunately, I didn't think of the first one resetting power settings -- my laptop is connected to an external monitor, and stays closed itself. So, in the middle of the install, it went to sleep. When I woke it up, I had a black screen with a working cursor.
    6. Got running again by shutting down and restarting the computer with the W10 install disc in the drive. Was told noticed I had an install in progress; did I want to continue?
    7. Finished it, and, as evidenced by this, have some functionality back. However, I can't access my own Start Menu, even though the Security tab shows me with full control. Also, I keep being notified the Recycle Bin is corrupted -- do I want to empty it. But I'm told I need administrator permission to delete a particular folder, even though, again, I show as having full control in the Security tab. And restart gets me the sign-in screen for about 15 seconds, then the black screen with the cursor for about five minutes, and then my desktop.
    8. Yes, I have attempted to regain control over folders I feel entitled to see, like my own Start menu!
    9. Downloaded Tweaking.com Window repair tool and tried to install -- nothing happens on double-clicking -- no in-process indicator -- nothing. Tried opening as administrator -- now I get the rotating in-progress indicator, but nothing further. But, after about five minutes, I'm told Windows cannot access the setup file -- I may not have the appropriate permissions! Downloaded HD Tune -- same problem.
    10. I'm unable to access the Registry Editor (not that I have anything in mind to do there -- just thought I'd try. Ditto Local Services.
    11. I have run chkdsk and sfc -- all report clean.
    I'm about ready to reset back to out-of-box state, create an on-line account right from the start, and see what that does.

    - - - Updated - - -

    Coming back around from the dark side of the moon: performed full "back to out-of-box state" recovery; created on-line account using pre-existing outlook.com credentials, and now appear to have functioning built-in apps -- verified store, feedback hub, and movies & TV so far. Will now start configuring to personal tastes (e.g., restoring Quick Launch toolbar) and installing apps and files, constantly checking to ensure nothing changes things. I won't forget all the help you've given me -- THANK YOU!
      My Computer

  6. Posts : 40,568
    Win 10 Pro (22H2) (2nd PC is 22H2)

    Glad to hear you found a way forward. Now remember to protect yourself by

    a. creating a Windows disk image,
    b. keeping a note of what you change,
    c. updating your image file set e.g. by creatina a differential image after significant change or period of your choice
    d. Repeat (b), (c)

    e. When you upgrade, start from (a).

    E.g. Macrium Reflect (free-paid) + large enough external storage.

    Then you have a chance to restore your O/S or any imaged partition to a good previous state.
    Recommendation- for that reason, keep personal data off C: so it is unaffected by restoring an older version of the 'Windows' partition.
      My Computers

  7. Posts : 20
    Windows 10 Pro
    Thread Starter

    Thanks again!
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 11:10.
Find Us

Windows 10 Forums