Windows Store Apps Not Updating

Page 2 of 3 FirstFirst 123 LastLast

  1. Posts : 7
    Win10
       #11

    Tried #2 for a second time, still no good.

    In addition if I try to pause all or remove apps from the download queue, the store freezes. If I try to restart the Windows Update service, it hangs while stopping and I have to taskkill /f it. The store never seems to clue in on what's happening, and once I get windows update restarted it all goes back to pending.

    I hate Windows.
      My Computer


  2. Posts : 61,585
    64-bit Windows 11 Pro for Workstations
       #12

    Scar said:
    Okay, I just tried method #2 again and it worked!. It's updating and the mail and calendar apps both finally work. Thank you very much!. I've been using this site since the vistax64 days for each version of Windows and the community are second to none.

    Hope you find a fix Moofey.
    Great news Scar. I'm glad it was able to help. :)
      My Computers


  3. Posts : 61,585
    64-bit Windows 11 Pro for Workstations
       #13

    Moofey,

    Are you having any issues with Windows Update as well?

    Do you have a 3rd party AV or security program installed that may be blocking it?
      My Computers


  4. Posts : 7
    Win10
       #14

    Brink said:
    Moofey,

    Are you having any issues with Windows Update as well?

    Do you have a 3rd party AV or security program installed that may be blocking it?
    Windows Update seems to be working fine.

    I might have overlooked changes I've made to AV though. I just recently installed Malwarebytes as a potential replacement to defender (like win10 will let me replace it that easily... lol) but I never really paid attention to when my store issue started, so I have to look at the relation between the two when time permits.

    I'll post here after I get the chance to look at it
      My Computer


  5. Posts : 15
    Windows 10 Pro x64
    Thread Starter
       #15

    Brink said:
    Great news Scar. I'm glad it was able to help. :)
    What do you think was the cause of this Brink?, considering that step #2 solved my problem and #1 failed.

    Thanks.
      My Computer


  6. Posts : 15
    Windows 10 Pro x64
    Thread Starter
       #16

    Moofey said:
    Windows Update seems to be working fine.

    I might have overlooked changes I've made to AV though. I just recently installed Malwarebytes as a potential replacement to defender (like win10 will let me replace it that easily... lol) but I never really paid attention to when my store issue started, so I have to look at the relation between the two when time permits.

    I'll post here after I get the chance to look at it
    I have to say that I have Malwarebytes too. Things were working fine even with Malwarebytes installed(literally the same day I installed Windows 10 on July 29th) and all was fine till today. I even exited Malwarebytes as I was testing different methods and so on. So I don't really think that might be the problem but your case could be different.
      My Computer


  7. Posts : 61,585
    64-bit Windows 11 Pro for Workstations
       #17

    Scar said:
    What do you think was the cause of this Brink?, considering that step #2 solved my problem and #1 failed.

    Thanks.
    It most likely a corrupted app cache since part 2 sorted it for you.
      My Computers


  8. Posts : 15
    Windows 10 Pro x64
    Thread Starter
       #18

    Brink said:
    It most likely a corrupted app cache since part 2 sorted it for you.
    Thank you. Any way to avoid that or it's just random?.
      My Computer


  9. Posts : 61,585
    64-bit Windows 11 Pro for Workstations
       #19

    Moofey said:
    Windows Update seems to be working fine.

    I might have overlooked changes I've made to AV though. I just recently installed Malwarebytes as a potential replacement to defender (like win10 will let me replace it that easily... lol) but I never really paid attention to when my store issue started, so I have to look at the relation between the two when time permits.

    I'll post here after I get the chance to look at it
    I have MBAM installed as well with default settings, and it hasn't caused me any issues so far if it helps.
      My Computers


  10. Posts : 7
    Win10
       #20

    Yeah, and that's what I noticed with MBAM. Disabling or killing it completely didn't change the situation. Also double-checked Windows Update. It's hard to tell since I don't have any system updates to download but it seems to be working fine.

    If anything, clearing my store cache via deleting the registry key seems to have caused additional problems. Ever since I did that, when I first login on startup I'm looking at a black screen with a cursor for a couple minutes before it does anything. Startup in general seems to have gotten sluggish, too.

    EDIT: And it just started randmoly working again. Aside from the issue that I might have caused trying to fix this, WINDOWS, LADIES AND GENTLEMEN.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:37.
Find Us




Windows 10 Forums