This is a repeat of an earlier posting which seems to have a solved tick, when it has not been solved. Any suggestions welcome

I had an update to windows a few days ago. Now some of the apps are not launching. The following work as normal: Settings, calculator, paint, hearts deluxe, witcher 3, Machinarium. Those not working include: Asphalt, flow free, hill climb racing, super golf land - all games from the store. I have tried reinstalling them but to no avail. When I click on one there is a brief flash and the screen reverts to what it was. I have no problems with other programs installed.
I ran SFC - a few errors were found and reported as repaired.

Ran SFC a second time "Windows did not find any integrity violations"
Ran DISM - no problems reported
Ran SFC a final time, no integrity violations.
The problem with apps not loading remains as it was. The only other thing I have done in the last few days is to use disc cleanup to remove unwanted files on C drive, including "Old Windows"