cannot change file association

Page 1 of 8 123 ... LastLast

  1. Posts : 65
    Windows 10
       #1

    cannot change file association


    Suddenly, I cannot change my file association to the program I want.

    For example, I want to change ".txt" to use "notepad2.exe", not the default "notepad". Recently I was able to do that.

    If I right-click, properties, and choose my "notepad2", the change won't take effect. It will still stay the default notepad.

    And using windows 10 "choose default applications by file type", I can only choose app from App store. I do not want that. I want to use my simple "notepad2.exe".
      My Computer


  2. Posts : 1,720
    Windows 10 Home
       #2

    "If I right-click, properties, and choose my "notepad2", the change won't take effect. It will still stay the default notepad."

    R-click a txt file, then 'Open with', then 'Choose another app'. In next window, find and choose notepad2 then tick 'Always use this ...' at bottom.
    cannot change file association-screenshot_1.jpg
      My Computer


  3. Posts : 65
    Windows 10
    Thread Starter
       #3

    Attachment 208726

    "Always" is checked. The change does not happen.
      My Computer

  4. dalchina's Avatar
    Posts : 30,010
    Win 10 Pro (1903)
       #4

    You can investigate - and try restarting file explorer as an experiment -see attached doct.

    There are several such reports with recent Windows builds.
    One person commented it seems to work if you repeat the process (i.e. do it twice). Hmm, sthg wrong with Windows if so, but try it...
    Which build are you using? Windows key + R, winver

    Which program are you using as Notepad2.exe?

    Your attachment link seems invalid. To post a screenshot please use the Insert Image icon above your post.

    To post an attachment, 'Go advanced' & use the Paperclip icon.

    Thanks.
    cannot change file association Attached Files
    Last edited by dalchina; 17 Oct 2018 at 14:00.
      My Computers


  5. Posts : 65
    Windows 10
    Thread Starter
       #5

    This is notepad2 , by far my favorite notepad replacement : http://www.flos-freeware.ch/notepad2.html

    My current windows build : 17134.345

    I just cannot change program using "Change" next to "Opens with" in file properties.

    I also tried after restarting computer.
      My Computer

  6. dalchina's Avatar
    Posts : 30,010
    Win 10 Pro (1903)
       #6

    Please work thru and use the attached document, in my post above.
    Also note some have suggested using Open With twice in succession in that build.
      My Computers


  7. Posts : 65
    Windows 10
    Thread Starter
       #7

    I worked through the document. Yes I can change the extension with Filetypesman, but it doesn't correct the problem.
    I cannot change the file type association by "properties", "open with", "change",...
      My Computer

  8. dalchina's Avatar
    Posts : 30,010
    Win 10 Pro (1903)
       #8

    Please describe what you see with Filetypesman (screenshot). Have you checked whether the registry was updated? (Check again what filetypesman shows after a restart).

    Experimental:
    Have you tried making the change twice?

    Have you tried making the change, then restarting explorer?

    Presumably you ticked the box 'Always use this app...' in the Open With dialogue.

    I've downloaded Notepad2 and associated it with .txt using Open With, .... Browse to..

    cannot change file association-1.jpg

    cannot change file association-2.jpg

    cannot change file association-3.jpg
      My Computers


  9. Posts : 65
    Windows 10
    Thread Starter
       #9

    Here's an example with a ".abc" extension.

    ".abc" does not show in Filetypesman, cause it doesn't exist yet.
    It does not show in "Choose default application by file type" too.

    It doesn't show after trying to change extension twice.
    Same after restarting explorer.

    The box "Always use this app" is now absent. But it was not working when the box was there too.
    If I click "More apps", I see more app choices, then scroll down and can click "Look for another app on pc", where I can choose the .exe with file explorer. But it's not working too.


    cannot change file association-1.png



    Now with an extension that already exist.
    For example .chm :

    cannot change file association-2.png

    Here I can only select an app from the the app store.

    In Filetypesman, there's .chm.
    If I try to change to notepad2 twice, and restart windows explorer and Filetypes man, the modified time does not change.

    cannot change file association-3.png


    As I said, it was working before. I could change anything I want to notepad2, using "properties", "change"...
      My Computer


  10. HeM
    Posts : 362
    Win 10 Pro x64 v.20Η2
       #10

    trogne said:
    ...I just cannot change program using "Change" next to "Opens with" in file properties...
    YES! We understood that. It's a (known) bug. No one can change file association by this way or by Settings/Apps/Default app, in some cases.

    The workaround: Right click on file > Open with > Choose another app and if app appears on list, select it with "Always use..." checked. If this doesn't work OR app does not appear on list, navigate to desired app(.exe), click OK, open the file with it, then go again to Open with > Choose another app, select it from the list on which now appears, check "Always use...", then OK and...that's it.
    If, following exactly this, issue persists...I don't know...reinstall or wait.
    Last edited by HeM; 18 Oct 2018 at 09:16.
      My Computer


 
Page 1 of 8 123 ... LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 23:54.
Find Us




Windows 10 Forums