1803 - Can't set vim as default app for .txt, .log, or .ini files.


  1. Posts : 3
    Windows 10 Pro
       #1

    1803 - Can't set vim as default app for .txt, .log, or .ini files.


    I've tried doing it the same way I've done in the past - right click, open with, check the box to "always use this program." It opens in the requested program, but doesn't change the default. Okay. Fine. I go into settings to choose default apps by file type. Scroll down to .log, and change it to vim. It doesn't register. It doesn't change from notepad. Okay. Try this another way. Go into set defaults by app. Vim doesn't even show up there.

    Is there somewhere I set this in the registry or something?
      My Computer

  2. dalchina's Avatar
    Posts : 29,978
    Win 10 Pro (1903)
       #2

    Go into set defaults by app. Vim doesn't even show up there.
    Presumably that's because VIM isn't written so as to register itself as a potential handler of these file types.

    If you wanted to experiment further you could use Nirsoft's Filetypesman, which both lets you see the details (from the registry) for each file type, and modify these.

    Thus you could see if there has been any change when you try to use Open With- compare one that works with one you have problems with.

    1803 - Can't set vim as default app for .txt, .log, or .ini files.-1.jpg
      My Computers

  3. Berton's Avatar
    Posts : 10,525
    Win10 Pro Versions 2004 and 2009/20H2, Win10 Pro IP_Dev, Win10 Home 1909
       #3

    I just installed VIM 8.1 on my computer, latest update, from download : vim online using the first clickable link:
    MS-Windows: Click this link to download the self-installing executable (using ftp).
    The right-click of a .txt file offers Open with, worked fine. In Control Panel VIM does show in the Choose default apps by file type section.
      My Computers


  4. Posts : 1,285
    X
       #4

    Vim works fine here as the default handler for .txt, .ini, and .log
    I'm using Vim 8.0
      My Computer


  5. Posts : 3
    Windows 10 Pro
    Thread Starter
       #5

    I was able to get it set using the assoc and ftype commands. No idea why it wasn't working through the shell or the control panel, but it wasn't just vim. I couldn't change it to anything. And now that I've set it using ftype, I can change it through both the shell and the control panel. ¯\_(ツ)_/¯
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 17:32.
Find Us




Windows 10 Forums