Install as admin, can't uninstall from Settings Solved

Page 1 of 2 12 LastLast
  1.    17 Aug 2018 #1

    Install as admin, can't uninstall from Settings


    Hi, just came across this- I installed a program as admin (rt click, run as admin), hoping that might resolve a small snag, then wanted to uninstall it. From Settings I could not, nor is there a way there to start the uninstallation as admin.

    Was this just an odd one-off? (Just curious really- I uninstalled it another way). Thanks.
      My ComputerSystem Spec

  2.    17 Aug 2018 #2

    Your description is a bit vague.

    Generally (OK, almost always) installation requires admin rights as it writes to non user-specific parts of the registry. Something other than HKCU basically.

    Tell me the program and I'll try it but sure it could have played with authority - anything you run under an admin account can.

    You can use nSudo (if you want) to remove stuff but you must understand that any program you run can do anything anyway if you are running as an admin user. There is no need for it to ask for UAC or anything.

    That isn't a problem with nSudo (you could just run half a dozen PoSh commands) it is a problem with how it is trivial to escalate privileges in Windows if you are a local admin.

    That is how malware works. You are running as Admin, malware takes authority.

    Oops.
      My ComputerSystem Spec

  3.    17 Aug 2018 #3

    Hi, not much more I can add, really. I'm logged in as admin, and for some reason I decided to try re-installing Classic Shell (old version) via rt click, run as admin, on the install exe file.

    That didn't solve the problem (didn't think it would - the Control Panel menu no longer expanding as it always had- yes, played with the setting for that, no luck).

    I went to Settings, Apps... and tried to uninstall it.

    That failed (no I didn't note the message, but it was sthg about being unable to perform the uninstall).

    There was no option there to 'run as admin'.

    I thought it odd that the uninstall attempt should be rejected.

    I launched Geek uninstaller, and started the uninstall from that, which ran normally.

    Just thought it odd the uninstall sequence couldn't be started from Settings - previously I had uninstalled CS from there. Only difference- I'd specifically selected rt click run as admin.

    A curiosity, really- maybe just a quirk and I've no idea if that's generally true.
      My ComputerSystem Spec

  4.    17 Aug 2018 #4

    Well if you don't want to name the program I doubt anyone can help man.
      My ComputerSystem Spec

  5.    17 Aug 2018 #5

    2nd line:

    Classic Shell (old version)

    Classic Shell - Start menu and other Windows enhancements
      My ComputerSystem Spec

  6. Cliff S's Avatar
    Posts : 22,048
    Win10 Pro, Win10 Pro N, Win10 Home, Win10 Pro Insider Fast Ring, Windows 8.1 Pro, Ubuntu
       17 Aug 2018 #6

    dalchina said: View Post
    2nd line:

    Classic Shell (old version)

    Classic Shell - Start menu and other Windows enhancements
    I never use Classic Shell(I love Win10's UI as it is), but does it have a service running maybe?

    Then maybe safe mode needs to be used to uninstall.
      My ComputersSystem Spec

  7.    17 Aug 2018 #7

    Hi, as I said, I had uninstalled it quite normally previously.

    First I tried CS 'repair' - no change with problem.
    I then uninstalled and reinstalled normally - - no change with problem.
    I thought 'what else could I try?'
    I uninstalled, then reinstalled (run as admin) - then found I couldn't uninstall via Settings.

    I've not tried with any other program, but find it a curiosity.
      My ComputerSystem Spec

  8.    17 Aug 2018 #8

    I don't think it is a general thing.

    Normally (always I think) when you install something the installer requests administrator privileges so that it can write to areas ("Program Files" for example or some parts of registry, etc) that as a standard job it couldn't.

    I can't imagine Classic Shell (or whatever it is called today) is peculiar in this sense or asks unusual permissions.
      My ComputerSystem Spec

  9.    17 Aug 2018 #9

    Not to worry- I doubt I've ever used run as admin when installing anything. The error message was a little interesting- certainly one I'd never seen. As I said, a mere curiosity..
      My ComputerSystem Spec

  10.    17 Aug 2018 #10

    If it happens again, try uninstalling from Control Panel > Programs and Features, instead of from Settings.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
i see it as a program that can be uninstalled. what it is? what happens if i remove it? Thanks! did a lot of google searching and no one is talking about it
No admin rights for admin account after clean install in User Accounts and Family Safety
Recently I did a clean install from the windows installation tool off a CD I made. Soon after logging on and making my first account (again!) I couldn't open the C drive. I messed with the owner options and made my account the owner so I could open...
Hello there I just installed Win 10 upgrade from Windows 7 on my computer and I am having some problems to modify system settings regarding pen and touch, specially "Flicks" settings, that I need to disable to have a better performance using a...
I installed Arduino software, part of which included installing a number of drivers. I uninstalled the software using the internal software uninstall feature. Apparently it removed the drivers, but for some reason they still show up in the Windows...
Frustrated with admin rights - Please help me. Just purchased new PC - HP Pavilion desktop and upgraded to Windows 10 during installation. I've downloaded Google Chrome as my default search engine with no issues. I've attempted several times to...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 17:48.
Find Us