Windows 10: devicecensus.exe

Page 1 of 3 123 LastLast
  1.    14 Jun 2018 #1

    devicecensus.exe


    Hi since Tuesdays updates every time I boot I get a red X in reliability history with devicecensus.exe stopped working.
    Anyone else seeing this?

    Windows 10 Pro 1803.

    Thanks
      My ComputerSystem Spec

  2.    14 Jun 2018 #2

    Some users have reported deleting devicecensus.exe from their PCs with no adverse effects (see devicecensus.exe - Microsoft Community). However, another such MS thread says that devicecensus is used to gather information about your PC to target builds through Windows Update (devicecensus.exe - Microsoft Community). Thus, it seems to me you could kill the task except before getting ready to run Windows Update (and launch it manually just beforehand) to cut down on such occurrences. Not sure there's any other fix until and unless MS addresses the instability problems that are being reported on your PC. I'd suggest posting something about this to the Feedback Hub to be sure to bring it to Microsoft's attention. OTOH, there is already a thread labeled "devicecensus.exe crashed" up there, so you may decide just to upvote that thread instead. I just did that, based on your post!
    --Ed--
      My ComputersSystem Spec

  3.    14 Jun 2018 #3

    Hi
    Thanks for the reply, I changed my feedback to basic and changed ask for feedback = never.
    This has stopped errors.
    If Microsoft want to spy by default, they may want to try and get it working first!
    Thanks again.
      My ComputerSystem Spec

  4.    14 Jun 2018 #4

    Good solution! There's always another way to get from where you are, to where you want to be, if only you *THINK* hard enough. You figured it out in a pretty good way.
    --Ed--
      My ComputersSystem Spec

  5.    15 Jun 2018 #5

    I got it again today, it must be a botched scheduled event I have to hunt down and disable.


    It's a task called 'device Information' in scheduled tasks.
      My ComputerSystem Spec

  6.    16 Jun 2018 #6

    It's gone for two days after removing Eset and using Defender.
    Cannot find the reason this is happening.
      My ComputerSystem Spec


  7. Posts : 12
    Windows 10 x64 1803
       05 Jul 2018 #7

    I have the exact same problem. You can find answers.microsoft.com threads here, here, and here.

    It seems to be related to KB4284835, that's when this process went bad.

    I'm shutting it down in the Task Scheduler until Microsoft hires some more QA people. I have no idea what that breaks, but I'm guessing absolutely nothing but a daily crash.
      My ComputerSystem Spec

  8. Polo6RGTI's Avatar
    Posts : 427
    Windows 10 Pro WS x64 17134.320
       05 Jul 2018 #8

    I've also had the DevicesCensus error the day after I updated to 1803.

    Simply block(debug) it by adding this key to the registry.
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\DeviceCensus.exe]
    "Debugger"="C:\\Windows\\System32\\systray.exe"
    Or use this script
    Code:
    @echo OFF
    :: Check for administrative permissions 
    >nul 2>&1 "%SYSTEMROOT%\system32\cacls.exe" "%SYSTEMROOT%\system32\config\system" 
    :: If error flag set, we do not have admin. 
    if '%errorlevel%' NEQ '0' ( 
    echo Requesting administrative privileges... 
    goto UACPrompt 
    ) else ( goto gotAdmin ) 
    :UACPrompt 
    echo Set UAC = CreateObject^("Shell.Application"^) > "%temp%\getadmin.vbs" 
    echo UAC.ShellExecute "cmd.exe", "/C """"%~f0""""", , "runas", 1 >> "%temp%\getadmin.vbs" 
    cscript "%temp%\getadmin.vbs" 
    exit /B 
    :gotAdmin 
    if exist "%temp%\getadmin.vbs" ( del "%temp%\getadmin.vbs" ) 
    pushd "%CD%" 
    CD /D "%~dp0" 
    :: BatchGotAdmin (Run as Admin code ends)
    
    :: ======================= Block DeviceCensus.exe =======================
    echo.
    reg query "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\DeviceCensus.exe" > NUL 2>&1
    if %ERRORLEVEL% EQU 0 goto blocked
    :block
    reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\DeviceCensus.exe" /v Debugger /d "%Windir%\System32\systray.exe" /f
    echo.
    echo DeviceCensus.exe is now blocked.
    goto end
    :blocked
    echo DeviceCensus.exe is already blocked.
    :end
    echo.
    echo.
    echo Press any key to exit...
    pause >nul
      My ComputersSystem Spec


  9. Posts : 12
    Windows 10 x64 1803
       05 Jul 2018 #9

    Polo6RGTI said: View Post
    I've also had the DevicesCensus error the day after I updated to 1803.

    Simply block(debug) it by adding this key to the registry.
    Does that actually fix the devicecensus.exe error, or does it simply make it not run?
      My ComputerSystem Spec

  10. storageman's Avatar
    Posts : 439
    Windows 10 Pro 1803 17134.137
       05 Jul 2018 #10

    rhansen said: View Post
    Does that actually fix the devicecensus.exe error, or does it simply make it not run?
    It doesn't fix it, just blocks. I would not worry about this. All three of my W10 systems are getting that error every time I power them up and yes it started after the last CU. Its really sad that MS can't get their act together. I do not ever remember having these kind of issues under W7.
      My ComputersSystem Spec


 
Page 1 of 3 123 LastLast

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:09.
Find Us