Windows 10: Reinstall default apps from image file


  1. Posts : 16
    Microsoft Windows 10 Pro 64-bit 16299 Multiprocessor Free
       27 May 2018 #1

    Reinstall default apps from image file


    Hi,

    I've messed a lot with the pre-installed apps, but now decided to reinstall them.

    I've deleted everything under C:\Program Files\WindowsApps. Then I copied the same directory from Windows ISO and pasted there. Also I set the folder to default permissions.

    Then I entered the following command at Power Shell: Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    It processes C:/Windows/SystemApps fine, but gives this error for others: Add-AppxPackage : Cannot find path 'C:\AppXManifest.xml' because it does not exist.


    I also found a script at MS site called reinstall-preinstalledApps. But when I run it, gives this error:

    Add-AppxPackage : Cannot find path 'C:\Program Files\WindowsApps\Microsoft.WindowsCalculator_2018.312.1947.1000_neutral_~_8wekyb3d8bbwe\AppxMetadat a\AppxBundleManifest.xml' because it does not exist.
      My ComputerSystem Spec

  2.    27 May 2018 #2

    Two relatively simple ways if the Powershell commands won't work (see Tutorial below)-
    a. in-place repair install of existing build (See tutorial if unsure) this keeps all progs and data
    b. upgrade to build 1803 (assuming that's problem free for you!)

    That should repair most other damage you may have done.

    For reference:
    Reinstall and Re-register Apps in Windows 10 | Windows 10 Tutorials
      My ComputerSystem Spec


  3. Posts : 16
    Microsoft Windows 10 Pro 64-bit 16299 Multiprocessor Free
    Thread Starter
       27 May 2018 #3

    Thanks. I've already updated to 1803, but it didn't reinstall apps. So probably I'll have to go with your first option.
      My ComputerSystem Spec

  4.    27 May 2018 #4

    Sorry, just realised I was wrong about the upgrade- upgrades now respect the fact that you've uninstalled apps. (True for the last 2 or 3.. they hadn't used to). However upgrading should have corrected permissions, so the Powershell command might then have been expected to work, if that was what was stopping it. If, however, you've done something since upgrading to 1803 that stops that working, an in-place upgrade repair may fix it.
      My ComputerSystem Spec


  5. Posts : 16
    Microsoft Windows 10 Pro 64-bit 16299 Multiprocessor Free
    Thread Starter
       27 May 2018 #5

    Np, thanks anyway. I've changed the owner to Trustedinstaller, and now I can't enter the WindowsApp directory.
      My ComputerSystem Spec

  6.    27 May 2018 #6

    Try an in-place upgrade repair, or if you were very lucky, Tweaking.com's repair tool (free) might help if you only select the permissions repair.

    (Before hacking the OS you shuold make sure you have a current disk image (e.g. Macrium Refect (free) ) which you can then restore if things go wrong- without technical help or other lengthy trial and error attempts. We strongly recommend its routine use).
      My ComputerSystem Spec


 

Related Threads
I'm trying to stop PDF files from opening in IE11, I want them to open in Adobe reader. When I go through the settings menu and get to the screen "Choose Default Apps by File Type" I cannot scroll down that page it stays locked on the top section. ...
I haven't reinstalled Windows 10 or updated it in about a year. When I did, there were several new apps that are completely junk. I have a .bat file that I use to clean stuff up but it's a little outdated and I had to go into the Start menu and...
Did a fresh install of Windows 10 recently and usually after I finish the setup I uninstall programs and apps that I do not use, this includes many of the default Windows apps. This time, I accidentally uninstalled the Photos and the Windows Store...
>.NBF file in Default apps in General Support
Is it possible to remove the .NBF from the list. 113119
I uninstalled all the default apps (with CCleaner) knowing that each new build re-installs them. Build 14926 no longer re-installs uninstalled apps. I've tried every means I can find to re-install the apps but nothing works. Can I roll back to...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 04:52.
Find Us