Some Start Screen Apps Not Working After 1803 Spring Creators Update

Page 1 of 3 123 LastLast
  1.    04 May 2018 #1

    Some Start Screen Apps Not Working After 1803 Spring Creators Update

    ....... after the 1803 Spring Creators Update some apps with live tiles are not working.

    One of them is the Asparion Clock tile and the other is the World Clock - Time Zones.

    I uninstalled the apps and reinstalled twice, still not working.

    If I click on the app tile, the app window opens for a second and disappears again.

    Usually I'm using only the Asparion Clock and tried the World Clock - Time Zones as a substitute, but got the same problem

    Does anyone know how to fix this ...?...
      My ComputerSystem Spec

  2.    10 May 2018 #2

    tommygun I am facing same problem after updating to 1803. Most of my apps on start menu doesn't launch. Games and others apps. Windows store and x box works perfectly fine and some other apps. Has anyone able to solve this problem. I would appreciate if anyone can help us solve this problem.
    Thanks in advance.
      My ComputerSystem Spec

  3.    10 May 2018 #3

    Try to do in-place upgrade and see if this band-aid solution would work.
      My ComputerSystem Spec

  4.    14 May 2018 #4

    I update my pc regularly. I'm in latest version of windows 10 (1803), Before I had no problem of apps crashing but after update almost all windows store apps are crashing before even launching. Is there any solution besides going back to previous version of windows. Only apps downloaded from windows store are crashing. Other third party software works fine. I tried resetting apps preferences, uninstalled apps and re-installed, reset windows store, troubleshooted windows store apps and nothing seems to work.
    Do anyone has any idea what problem is this?

    Thanks in advance.
      My ComputerSystem Spec

  5.    15 May 2018 #5

    ....... apparently it's not just me having this problem.

    No solution on my end as yet.

    Waiting for you guys coming up with a fix .......
      My ComputerSystem Spec

  6. Posts : 136
    Win10 Pro x64 1607
       15 May 2018 #6


    Before going back or in-place upgrade, you may try this:
    Create a new local user account (admin) and see if issue persists.
      My ComputerSystem Spec

  7.    15 May 2018 #7

    The Ďmoderní apps are a nightmare on windows 10. So prone to breaking. Iíve had some success resetting the apps giving me trouble in the past. Go into settings and from memory select to list your apps. Find one thatís giving you grief and click advanced. From there should be an option to reset the app. Click that, give it a minute or so and then try to relaunch the broken app. Itís hit or miss whether it works but itís worth a try

    another way that has rescued some apps without need for draconian measures is ccleaner. Install that and use that to uninstall the offending app. Now go back into store and redownload the app. I think ccleaner does a more thorough job of purging the corrupt app
      My ComputerSystem Spec

  8.    20 May 2018 #8

    Thanks for your quick reply. But I have tried creating new local user and it didn't work at all. I have tried resetting apps data and re-installed but still apps crashes while at launch.

    Those apps were working before upgrade. Apps that are not currently working for me. Asphalt 8, Tiny trooper, Facebook for windows, and other apps that are from windows store. Some very light don't crash maybe apps that are using GPU are crashing.

    My pc is Acer aspire F5 575G with 8GB RAM, 256GB SSD and 2GB Nvidia 940 mx graphic.
    I guess my only solution is to roll back my window version. Will my new installed software and settings will be removed if I roll back my window version?
    Help if anyone is able to solve this problem.
      My ComputerSystem Spec

  9.    20 May 2018 #9

    ....... 1st of all thanks for all of your suggestions.
    Tried all that before opening this thread - Still puzzled what these high end programmers are doing ...?...
      My ComputerSystem Spec

  10.    03 Jun 2018 #10

    My store will not download anything or update those installed since 1803 Pro was installed.

    Tried in place upgrade, still the same.

    However, have a laptop running 1803 Home, store and all apps working fine.

    Maybe a MS problem with 10 Pro 1803?
      My ComputerSystem Spec

Page 1 of 3 123 LastLast

Related Threads
So I "upgraded" to this. They added the nifty feature (not) of web search in the Start Menu. You cannot just disable it with the remove Cortana registry key. That disables Cortana, but not the Web Search. I believe I found all the settings to...
​I just installed the Spring update 1803 on several machines from USB & DVD made from the iso. One machine it made a disk 0 partition 3 466 MB & also had the System Reserved 500 MB. PC works normally but why did it do this? I did other machines i...
Hi there just a note to those who tried the original Spring Creators update (from the Ms site - legal one) before Ms pulled the release --although the esd files still on the ms servers yesterday. I'm not on any insiders ring. I did check...
another way to get Creators Update (spring) in Windows Updates and Activation
Hi there This appears to look OK but if I'm breaking any rules mods please delete. How To Download Windows 10 Spring Creators Update Before Anyone Else? This downloads the ESD's -- there's a whole slew of them including GB for GB version...
Basically, I am unable to access anything except settings. All my files icons are locked and just opening up the File Explorer makes it go "Not Responding". I would take a screenshot and post it here, but that is impossible because I can't open...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:01.
Find Us