All Windows Store apps report "The parameter is incorrect" Solved

  1.    24 Apr 2018 #1

    All Windows Store apps report "The parameter is incorrect"


    It all began when I was trying to get Firefox to open a downloaded Word .doc file. Firefox absolutely refused to realize that I had Word installed. So I did what I usually do when Firefox is obstinate about opening a file; I tried to locate Winword.exe and manually associate it with .doc files. Except I couldn't find Winword.exe anywhere.

    I finally found it in a folder I had never seen before, "C:\Program Files\Windowsapps". The problem was that the folder was hidden and had some very strange permissions on it. So I took ownership of the folder and all subfolders and gave myself full control. That was a mistake.

    Now when I open *any* Windows Store/Metro app I get the message "The parameter is incorrect". How can I repair the permissions on "C:\ProgramFiles\WIndowsapps"? I've already given ownership back to "TrustedInstaller", but I'm still getting "The parameter is incorrect." I also tried "sfc /scannow" but that didn't help.

    BTW, all "classic" desktop apps work fine and Windows boots without any issue. But Office365 is totally hosed...

    Click image for larger version. 

Name:	2018-04-24.png 
Views:	25 
Size:	7.7 KB 
ID:	185997
      My ComputersSystem Spec

  2.    25 Apr 2018 #2

    Can't really find much useful about this precise problem. But attacking it via problem analysis, here's what I'd do myself, if faced with this issue, in 3 phases

    Phase 1: Run the Windows Store Apps Troubleshooter (TF Tutorial)

    If that doesn't work, onto Phase 2:

    Phase 2: Uninstall all store apps, then re-install and re-register them
    1. Uninstall all store apps with this command from an administrative PowerShell session
    Code:
    Get-AppxPackage -AllUsers | Remove-AppxPackage
    2. Reinstall and Re-register Store apps (TF Tutorial)

    If that doesn't work, onto Phase 3:

    Phase 3: Perform an in-place upgrade repair install of Windows 10 (TF Tutorial)

    HTH, and best of luck in getting this fixed.
    --Ed--
      My ComputersSystem Spec

  3.    25 Apr 2018 #3

    I tried everything up to Phase 3. Before nuking my entire install of Windows, I decided to try reinstalling Office. That worked - for my Office apps. Word, Excel, etc. all start fine now. However, all the other Metro apps remain hosed.

    Given that re-installing Office (from the MS installer) fixed the problem, are there any other tricks before I take the drastic step of re-installing Windows? None of the Powershell commands seemed to work...
      My ComputersSystem Spec

  4.    26 Apr 2018 #4

    An in-place upgrade repair install isn't quite a clean install. That said, it leaves apps and applications alone. But because you uninstalled all the UWP stuff using PowerShell, I'm hopeful it will put things back the way they should be. This process only takes 15 minutes or so, so you'll know pretty quickly if it helps or not. Only if it fails does a clean install come into the picture. Here's a link to that tutorial again: Repair Install Windows 10 with an In-place Upgrade.
    HTH,
    --Ed--
    Last edited by EdTittel; 26 Apr 2018 at 08:28. Reason: Shorten URL
      My ComputersSystem Spec

  5.    26 Apr 2018 #5

    Thanks it worked. I was worried about losing several hundred gigabytes of downloaded games, but all I had to was rerun the launcher. I also had to reinstall some drivers, which was a little surprising. I've also lost some OEM software; is there any way to get that back?

    Otherwise, Windows Store and Office 365 all appear to be working now. Thanks.
      My ComputersSystem Spec

  6.    27 Apr 2018 #6

    Glad you got it (mostly) sorted. As for the OEM stuff, you'll probably have to find it, download it and reinstall it. If you can't remember, you may be able to mount your backup and explore its contents and get the info you need from there. Hope it all goes well.
    Best wishes,
    --Ed--
      My ComputersSystem Spec


 

Related Threads
I'm trying to prevent a pesky program from running by revoking it's permissions, but I can't because whenever I disable inheritance on it (whether by converting inherited permissions to explicit permissions or just removing the permissions...
Hi All, My first post! A couple of weeks ago when I turned my PC on and clicked one of drives I received a message that "This Folder Is Empty". I found this solution after a google search: 1.diskpart 2. list disk 3. select disk {number} 4....
Please help! I am using am iMac with Bootcamp running Win 7. I have just upgraded to Win 10 with no problems. Except I can now not read my 2 x WD USB external drives. I am getting "the parameter is incorrect" error. In disk management it says the...
Hey guys, So you know how it's possible to move your shortcuts into folders and rename said folders on regular "desktop" apps? Is this possible with Windows Store "Metro" apps as well? What I'd really like to do, for example, is have a folder...
When I go to store/account/my apps it never loads just opens a white page with a circle of spinning dots in centre so I cant restore my bought apps. Any ideas how to fix? On build 9926 thanks

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:03.
Find Us