Store app won't let me rate & review anymore Solved

  1.    21 Apr 2018 #1

    Store app won't let me rate & review anymore


    I just noticed that the Store app won't let me rate & review apps anymore. It says I need to sign in but I am already signed in with a Microsoft Account and clicking on the Sign In button it displays under the message doesn't do anything. I tried re-registering the Store app through Powershell. I also signed out and signed back in within the Store app and tried restarting my laptop.
    Click image for larger version. 

Name:	Screenshot (4)_LI.jpg 
Views:	3 
Size:	474.0 KB 
ID:	185547

    As you can see, I'm logged in but it says I need to log in to rate and review. Has anyone else had this issue and been able to solve it? Thanks in advance.
      My ComputersSystem Spec

  2. Masterchiefxx17's Avatar
    Posts : 451
    Windows 10 Professional 64bit
       22 Apr 2018 #2

    Were you leaving any profanity reviews that may have gotten you banned from posting? Do you have the same problem on a Microsoft App in the store?

    Are you logged into Windows 10 with a local or cloud account?
      My ComputerSystem Spec

  3.    23 Apr 2018 #3

    No, I didn't leave any profane reviews in the store app so I didn't get banned for that. What's odd is if I go to the store website in a browser I can leave reviews just fine. This problem only occurs within the standalone store app. I'm logged into Windows 10 with my personal Microsoft account. I also have an office 365 account through my college, but I removed it from "Sign in to a work or school account" because it wouldn't let me sync my settings anymore.
      My ComputersSystem Spec

  4.    24 Apr 2018 #4

    I'd like to add that this morning I clicked on a link from the News app to rate and review it. The invitation link did open up the Store app and it did allow me to rate it, write a review, and submit it. Afterward, still in the store app, it still showed the sign in link under the ratings for the News app instead of showing my newly submitted review and update option. I went to the web page in a browser and it does show my new review with an option to update it on the web page.
      My ComputersSystem Spec

  5.    04 May 2018 #5

    I went ahead and marked it solved because I did a clean install of the April 2018 Update and it is working now. The clean install also fixed a few other issues I was having as well, so something must have been corrupted in my previous install that sfc and dism were missing.
      My ComputersSystem Spec

  6. Masterchiefxx17's Avatar
    Posts : 451
    Windows 10 Professional 64bit
       05 May 2018 #6

    That does happen and it's nice to have those build updates to fix the problem.
      My ComputerSystem Spec


 

Related Threads
Not for the first time in W10 I noticed a notification slide off the screen before I had a chance to read it.. I need to access those notifications, after all, I'm in charge of the West's nuclear arsenal and could have missed something damned...
Review Files Pop-Up in Performance & Maintenance
Every time I turn on the computer I get a Pop-Up telling me to review MS Defender Files they want me to approve sending to MS. When I click on the Pop-Up it takes me to a window that has no files showing. Am I doomed to forever see this...
Latency Monitor - Please Review in Drivers and Hardware
System: Windows 10 64-bit ASUS z170-AR ASUS GTX 1060 6GB Turbo EVGA 700w 80Plus Bronze PSU Corsair 3200mhz LED RAM @ 2x 8GB Corsair h90 liquid cooler Intel 600 series 256GB m.2 Seagate FireCude 2TB SSD HDD
Website Review in Chillout Room
Been working on my site and I would like some feedback on the look: Site: Bunnyj.me.eu TIA., Jeff
Windows 10 review (build 10074) Windows 10 review (build 10074): Microsofts new OS is maturing nicely | PC Pro

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:29.
Find Us