Windows 10: Powershell Pro's Unite!~ (help me reinstall a default app) Solved

Page 1 of 2 12 LastLast
  1.    4 Weeks Ago #1

    Powershell Pro's Unite!~ (help me reinstall a default app)


    So I got a little overzealous with my bloatware pruning and have managed to rectify 99% of it. The glaring item/entry I can not re add is the Xbox Game Speech Window.

    The package is Microsoft.XboxSpeechToTextOverlay

    Anyone care to walk this simpleton through the proper commands to powershell it back into place?
      My ComputerSystem Spec


  2. Posts : 6,412
    10 Home x64 (1709) (10 Pro on 2nd pc)
       4 Weeks Ago #2

    This tutorial tell you how, but doesn't include that particular app. Option two is a list of command lines for reinstalling individual apps.

    Reinstall and Re-register Apps in Windows 10

    It is included in this tutorial though, so it should be possible to work out the correct command line from the two.

    Uninstall Apps in Windows 10


    Or we could just ask @Brink
      My ComputersSystem Spec

  3.    4 Weeks Ago #3

    Yea I saw the tutorial. I couldn’t quite make it out and didn’t want to muck things up.

    Course I was tired and had two toddlers hanging from my pants so perhaps this morning with fresh eyes lol.

    Should he happen across this in the meantime however
      My ComputerSystem Spec

  4.    4 Weeks Ago #4

    ok so i gave it a try - this is what i ended up with ..

    Add-AppxPackage : Cannot find path 'C:\AppxManifest.xml' because it does not exist.At line:1 char:100+ ... fest.xml' ; Add-AppxPackage -DisableDevelopmentMode -Register $manife ...+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : ObjectNotFound: (C:\AppxManifest.xml:String) [Add-AppxPackage], ItemNotFoundException + FullyQualifiedErrorId : PathNotFound,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
      My ComputerSystem Spec


  5. Posts : 2,343
    Windows 10 Pro x64 FCU - XP/Vista/Win7/Win8.1 in VM for testing
       4 Weeks Ago #5

    I would expect Shawn @Brink to be here sometime n the next 4 hours, so time to make the toddlers breakfast
      My ComputerSystem Spec


  6. Posts : 28,522
    64-bit Windows 10 Pro build 17650
       4 Weeks Ago #6

    Hello @klepp0906,

    Have you already tried the command below in an elevated PowerShell?

    I'm not sure it will work if the account you run it in has it uninstalled though.

    Get-AppXPackage *Microsoft.XboxSpeechToTextOverlay* | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}
      My ComputersSystem Spec

  7.    4 Weeks Ago #7

    Hi brink, I just tried to run it and it did nada.

    no text and brought me back to C:\

    thanks for the reply btw. Ive just spent a solid week top to bottom daily getting my pc back to pre mobo dying/upgrade condition and now im fretting i managed to break the install lol.

    Fwiw ive looked high and low and apparently the Winstore folder is front and center to this working? Problem is i dont have it on this pc, and ive checked two other windows 10 pcs and it doesnt exist there either.

    Worst case, is said package uploadable so i can add it where I need it to get it back on the pc? >< I cant format,i cant. Im on home stretch and about to actually be able to settle in for the long haul/USE the pc and now this.

    (yea i know i sound desperate)
      My ComputerSystem Spec


  • Posts : 28,522
    64-bit Windows 10 Pro build 17650
       4 Weeks Ago #8

    If this is for a Microsoft account, then you might check in "My Library" in the Store app to see if this app is listed to be able to select to reinstall.

    Install Your Apps from My Library in the Store in Windows 10 Windows 10 Tutorials
    Last edited by Brink; 4 Weeks Ago at 11:02.
      My ComputersSystem Spec

  •    4 Weeks Ago #9

    I did check that im afraid. Its simply not there. During my digging i found this site Provisioned Packages (Provisioned Apps) in Windows 10 Pro s IT Blog which links to all the apps in the store and notice one of if not Thee only app with a notation indicating its not in the store - is the one im looking for.

    Argh. I know this can be done w/out dumping windows. Just well outside my "hardware enthusiast/gamer" scope :P

    Thoughts?

    as usual - thank you for your time and help!
      My ComputerSystem Spec

  •    4 Weeks Ago #10

    if i run this on a pc that has it installed - this is what i get (if its helpful?)

    PS C:\Windows\system32> Get-AppxPackage *Microsoft.XboxSpeechToTextOverlay*

    Name : Microsoft.XboxSpeechToTextOverlay
    Publisher : CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US
    Architecture : X64
    ResourceId :
    Version : 1.21.13002.0
    PackageFullName Microsoft.XboxSpeechToTextOverlay_1.21.13002.0_x64__8wekyb3d8bbwe
    InstallLocation : C:\Program Files\WindowsApps\Microsoft.XboxSpeechToTextOverlay_1.21.13002.0_x64__8wekyb3d8bbwe
    IsFramework : False
    PackageFamilyName : Microsoft.XboxSpeechToTextOverlay_8wekyb3d8bbwe
    PublisherId : 8wekyb3d8bbwe
    IsResourcePackage : False
    IsBundle : False
    IsDevelopmentMode : False
    Dependencies : {Microsoft.VCLibs.140.00_14.0.25426.0_x64__8wekyb3d8bbwe, Microsoft.XboxSpeechToTextOverlay_1.21.13002.0_neutral_split.scale-100_8wekyb3d8bbwe}
    IsPartiallyStaged : False
    SignatureKind : Store
    Status : Ok
    Last edited by klepp0906; 4 Weeks Ago at 12:25.
      My ComputerSystem Spec


  •  
    Page 1 of 2 12 LastLast

    Related Threads
    I uninstalled all the default apps (with CCleaner) knowing that each new build re-installs them. Build 14926 no longer re-installs uninstalled apps. I've tried every means I can find to re-install the apps but nothing works. Can I roll back to...
    In the past I have had to go around to each computer and set the default programs. Is there a way to create a batch file to set default programs silently for each user that signs on? Like we would like to have Adobe Reader DC, Internet Explorer, and...
    Hi there, So I was having a problem with my calculator app, it would open but I couldn't click the settings to move to any other mode. If I clicked it, it would open and close immediately, making it impossible for me to actually change anything....
    Hi there at one time there was a way to make Powershell the default cmd processor -- I can't find it any more. Any links. Cheers jimbo
    Show Command Prompt or PowerShell in Win+X Power User Tasks Menu in Windows 10 This tutorial will show you how to have either the Command Prompt or Windows PowerShell items show in your Win+X Power User Tasks menu in Windows 10 ...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    © Designer Media Ltd
    All times are GMT -5. The time now is 08:53.
    Find Us