Several programs not installing/running on windows 10

  1.    10 Mar 2018 #1

    Several programs not installing/running on windows 10


    Hello all,

    I recently upgraded to windows 10 Pro back in January from windows 7 ultimate. Since the upgrade, I've noticed that several programs that I try to install are having issues. Below I have listed the programs that I have tried, along with the problems that I am experiencing with each of them.

    Twitch: Program will install, but when running it will pop up on the taskbar and immediately disappear. Process is visible in task manager, but will go away when the program disappears from taskbar. Have tried reinstalling several times with different versions of the program with no luck.

    Razer Synapse and Razer Surround: Similar to Twitch, these programs will open and appear to start running only to disappear completely.

    RiftCat: Installer will download, but will not start up, even when run as administrator.

    For each of these programs, I have tried running as administrator, and also tried using the microsoft install/uninstall troubleshooter to no avail. I have looked online for other individuals with the same problem, but have come across nothing.

    Thank you in advance for any help that you may be able to provide!
      My ComputerSystem Spec

  2.    10 Mar 2018 #2

    Hi, have you checked these programs are compatible with Win 10? (See their site).

    Have you tried troubleshooting compatibility and installing them in compatibility mode?
    (Rt click, Troubleshoot compatibility).

    Remember you can also run them in compatibility mode.

    Finally, please provide a URL per program is still having problems. Thanks.
      My ComputerSystem Spec


 

Related Threads
Question on self running programs in Software and Apps
I am new to Windows as I am mainly a Mac user. However, I have a laptop that is gathering dust and I am a fan of participating in distributive programing through BOINC and provide computer support with my Mac when I am not using it. I would like...
So I went ahead and installed BASH to see if it will be of any use to me as as Linux and Raspberry Pi enthusiast. It's very easy. First, make sure that "Developer Mode" is enabled under Settings>>>Update & Security>>>For Developers ...
Yesterday I was playing Dota2 and everything seemed fine. Afterwards I installed Aptana Studio, Node.js, and some Microsoft Redistributable packages that it said were necessary. Now My entire computer is lagging. I can't figure out why.
Solved Running programs from NAS in Network and Sharing
Ever since installing Windows 10 (clean) I'm facing several network related issues. Before going in depth I'd like to figure out if it's a problem with my PC or if it's a problem with Windows 10 in general. I'll just stick to one problem for now....
programs not running... in Installation and Upgrade
Friends came over... wanted to show them the Windows 10 beta I am running. When i click on the start icon, nothing. When I click on IE-11 nothing. Yet when I click on File-explorer or FireFox there isn't a problem. I have rebooted and...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:39.
Find Us