Windows 10: Apps on Taskbar Slow to Launch

  1.    26 Feb 2018 #1

    Apps on Taskbar Slow to Launch


    I've noticed lately that apps on the task bar usually don't load at all, or very slowly, after clicking on them once. I now have to left click several times when previously one click would immediately launch the app. What could have caused the slowdown?

    Toshiba laptop
    Windows 10, version 1709
      My ComputerSystem Spec

  2.    27 Feb 2018 #2

    Do you have anything else running in the background........?

    Try using CCleaner or cleaning the History and the Search Engine History (Settings > History > Search Engines)



    Maybe if the cache is cleaned up a bit, it might allow things to run smoother.

    Just a few ideass.....
      My ComputerSystem Spec

  3.    27 Feb 2018 #3

    The only thing running in the background is Bitdefender AV. Also, I did run CCleaner. The apps still launch slowly. I'll have to try the the other things you mentioned. Thanks.
      My ComputerSystem Spec

  4.    27 Feb 2018 #4

    Mr Ed said: View Post
    The only thing running in the background is Bitdefender AV. Also, I did run CCleaner. The apps still launch slowly. I'll have to try the the other things you mentioned. Thanks.
    Go to Task Manager.........Startup.............Disable

    It lists all the APPs and programs that start automatically when you log in.

    Many of them are not necessary.

    And some are added automatically with an update or a download.

    Disable all the ones that are not necessary for restarting your computer.

    That should help as well.
      My ComputerSystem Spec

  5.    27 Feb 2018 #5

    Are they slower when launched from taskbar than launched from start menu?

    For example if you have Edge browser (or anything else) on taskbar does it take longer to lauch than if you hit the key and launch it from the menu there?

    If they are the same do you feel it is a general slowdown rather than taskbar related or the slowdown only relates to opening rather than running things once they get going?
      My ComputerSystem Spec

  6.    28 Feb 2018 #6

    Well, as I did a little more investigating, I felt there was a general slowdown and I also noted my HDD was spiking to 100%, so I went ahead and reset my PC. Now I'm OK. The only dumb thing I did was not make a copy of my favorites in my browser, so they were lost during the reset process. Anyhow, lesson learned: before resetting PC, copy favorites or print 'em out.
      My ComputerSystem Spec

  7.    28 Feb 2018 #7

      My ComputerSystem Spec


 

Related Threads
So I've discovered an interesting problem that I'm having with my computer. When I am at home, connected to my wireless network, it takes windows a very long time to launch apps. Everything from PDF reader to Excel/Word take at least 30 seconds to...
Hi there W10 X-64 pro (build 10547) and vmware workstation rel 12 - in full screen mode can't launch apps from taskbar. Works fine in Windowed mode This happens on LINUX Hosts - (Opensuse, Centos and Mint) Cheers jimbo
Hello I have chrome pinned to the task bar but it won't simply launch the application like it does with all the my other icons. I have to keep right clicking it and then choosing chrome within the menu - kinda annoying. Is there a way to...
Solved Store Apps won't launch in Software and Apps
So after the yesterday's upgrade to Windows 10, I decided to download it again and make an USB for a fresh installation. Done that. But after I booted into the OS, I noticed that Store Apps won't launch at all. Even the defaults like Mail and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:00.
Find Us