Windows 10: Get-appxpackage -allusers does not seem to be working.

  1.    04 Jan 2018 #1

    Get-appxpackage -allusers does not seem to be working.


    Let's say I do:
    Get-appxpackage *onenote*
    and
    Get-appxpackage -allusers *onenote*

    And I find there are entries for this product.

    So, I run:
    Get-appxpackage -allusers *onenote* | Remove-AppxPackage

    And I find that the localuser does not have the package, but allusers does.

    Something wrong with the way I'm doing it?

    I _am_ using a powershell with elevated privileges.
      My ComputerSystem Spec

  2.    05 Jan 2018 #2
      My ComputerSystem Spec

  3.    05 Jan 2018 #3

    That is the page I am working off of.

    Also attempted by taking ownership of the WindowApps folder (in Program Files), but that's not making a difference either. I can still use the command:
    Get-appxpackage -allusers *onenote*
    And get back an entry on the product.

    P.S. Deleted the folder, and now the info has a empty InstallLocation.

    (Should of mentioned in the title that I was attempting to DELETE the apps.)
    Last edited by cDreamDancer; 05 Jan 2018 at 17:45. Reason: Titled Post Wrong
      My ComputerSystem Spec

  4.    06 Jan 2018 #4

    If present for all users, why would it be present in particular (exclusively) for the local user as well?

    Are you saying you can't remove an app at all?

    Maybe you could post a couple screenshots of running these commands and someone could comment further.
    I can't recommend you start changing permissions.
    Last edited by dalchina; 08 Jan 2018 at 03:23.
      My ComputerSystem Spec

  5.    07 Jan 2018 #5

    dalchina said: View Post
    Are you saying you can't remove an app at all?
    Exactly.
    Click image for larger version. 

Name:	ps-remove-package.png 
Views:	2 
Size:	20.6 KB 
ID:	171428
    As seen above, did the Get for "Microsoft.WindowsPhone"
    I then used a Remove (with verbose flag) on the app.
    This is followed up with another Get. I should not be getting anything, the app has been removed.
    Yet, there it is.
      My ComputerSystem Spec


 

Related Threads
I am trying to uninstall all W10 built in Apps. I am using an Admin power shell with cmd, i.e. "Get-AppxPackage *3dbuilder* | Remove-AppxPackage" but I get a response saying that "Get-AppxPackage" is not recognized. I have checked the forum but...
Hi there. I like to remove the default apps that are bundled with Windows 10. Since upgrading to Windows 10 1511, the following commands do not appear to be working for me in Windows PowerShell (running as Administrator ofc) Get-AppxPackage...
I have a question about using App-AppxPackage to install default Windows app. Using Windows Calculator as a example, I noticed C:\Program Files\WindowsApps consists of the following: ...
I'm trying to run Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} from Power Shell as administrator in order to restore broken Search and Cortana functionality....
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 06:27.
Find Us