I'm sticking to version 17.2.1 at the moment the later versions cause my Adobe Lightroom CC to crash when I try to use the develop module! :(