I do use Image Guardian with number of licensed Reflect installation, but have not updated to version 3417. And thanks to you, I won't do it either. The version 2917 works just fine, even if it is a...