Windows 10: DISM restorehealth fails to run after latest CU

Page 1 of 3 123 LastLast

  1. Posts : 57
    Win 10 home x64 version 1709
       09 Dec 2017 #1

    DISM restorehealth fails to run after latest CU


    After updating my desktop PC last night to Win 10 1709 edition 16299.98 using an elevated command prompt(administrator) I ran sfc/ scannow and DISM /online /cleanup-image /restorehealth to cheack for any issues. SFC ran fine and found zero issues but dism /online /cleanup-image /restorehealth failed to run. Attached is the DISM log file and below is the error message. I have not attempted to restore back to before the updaate installed, yet. Microsoft Windows [Version 10.0.16299.98]
    (c) 2017 Microsoft Corporation. All rights reserved.

    C:\WINDOWS\system32>dism /online /cleanup-image /restorehealth

    Deployment Image Servicing and Management tool
    Version: 10.0.16299.15


    Error: 193

    An error occurred while attempting to start the servicing process for the image located at C:\.
    For more information, review the log file.

    The DISM log file can be found at C:\WINDOWS\Logs\DISM\dism.log

    C:\WINDOWS\system32>
    Attached Thumbnails Attached Thumbnails Screenshot (3).png  
    DISM restorehealth fails to run after latest CU Attached Files
      My ComputersSystem Spec

  2.    09 Dec 2017 #2

    According to what little info I can find on this error, it could be caused by corruption of the DISM environment itself, as represented by the binary files in which it resides on disk. This is kind of a dicey problem to fix. You might want to consider performing a so-called repair install, wherein you upgrade your current Win10 installation to the same version of Windows you're currently running. I see you're on build 16299.15: any reason why you haven't updated to the current 16299.98? You can use the Heidoc Windows ISO downloader to grab the 16299.15 release, though, so you might want to grab a copy. For more info on performing a repair install see this tutorial: Repair Install Windows 10 with an In-place Upgrade Installation Upgrade Tutorials .
    HTH,
    --Ed--
      My ComputersSystem Spec


  3. Posts : 57
    Win 10 home x64 version 1709
    Thread Starter
       09 Dec 2017 #3

    I am running 16299.98. DISM is using the 16299.15 version. Checked my laptop which also is 16299.98 and DISM runs the same version and it runs just fine. This all occurred last night. I have a 12GB monthly cap which renewed today so I turned off metered connection last night and let it auto update. It first updated MS office but no CU so I had it check again for updates and it found the CU and downloaded the AMD 64 package and installed it without issues during the process. This morning I ran my usual health checks after CU's, such as sfc/ scannow which was OK and then dism restorehealth and got the error. No dism commands will run. Tried checkhealth and scanhealth and sxtartcomponentcleanup and all gave the same error 193. Running tweaking windows repair now to reset file permissions etc. to see if it will fix it.
      My ComputersSystem Spec

  4.    09 Dec 2017 #4

    Hi,

    I am running 16299.98. DISM is using the 16299.15 version.
    That is how it should be. No idea why DISM isn't working properly for you. It works fine on my machines.

    Cheers,
      My ComputersSystem Spec


  5. Posts : 57
    Win 10 home x64 version 1709
    Thread Starter
       09 Dec 2017 #5

    Tweaking Windows Repair tool failed to fix DISM issue. During the repair I noticed a large number of missing reparse(sp?) points mostly in the c:\windows\SAVE folder. I will use the Heidoc utility to download a WIM ISO for 1709 tonight during my ISP's freezone period. I made one for 1703 but forgot to do so for 1709. With it I can attempt a repair install.
      My ComputersSystem Spec

  6.    09 Dec 2017 #6

    Hi,

    Sounds like a good plan.
    No Windows\SAVE folder here.

    Best,
      My ComputersSystem Spec


  7. Posts : 7
    windows 10 Pro build 16299.98
       10 Dec 2017 #7

    Hello,

    Gcwizard, could you please keep us posted as to how your repair install went. I've the same problem as you, error 193 dism unable to start and tried what you have tried to no success. I also have tried the repair install and the repair simply did not complete. I hope you have better luck! Right now my only option is a clean install, or go back to an old image before 16299.

    Here's a past Microsoft forum discussion link concerning this problem:

    https://answers.microsoft.com/en-us/...d311199?auth=1

    Regards, EG
      My ComputerSystem Spec


  8. Posts : 57
    Win 10 home x64 version 1709
    Thread Starter
       10 Dec 2017 #8

    I tried restoring back to before the latest updates but that failed. I downloaded a WIM copy of 1709 edition 16299.15 last night using Heidoc. I used Rufus to make a bootable drive and like you the repair install failed during the actual install process after all the preparation, etc. Rufus logs showed the image file I downloaded was in UDF format, unsure if this could be the issue with the failed install/repair. I too am looking at a clean install. I had to uninstall the last two updates to get back to version 16299.19 as I was at the latest. Same language and x64 like current OS. Did everything by the Brink tutorial using non-secure UEFI boot and disabling Windows Defender but it failed. Depressing but at least it still functions normally with the exception of DISM. CHKDSK and SCF /SCANNOW show zero issues. This is the computer I use to run a business with and will have to move bucu GB's to a separate drive and start over. I have it all backed up in multiple ways and locations but I still backup again to a separate drive to be certain I lose nothing. Over 50 software titles to re-install and putting data back into some of them. I will have to do the same with profiles for browsers and email as well. PIA! Not the first time but will take most of my spare time for a week or more to complete this. I have 3 computers networked so I have access to internet and my mail if issues arise in the clean install process. Thank You Microsoft! 4th time I have had to do this over the years on multiple PC's, all caused by updates. I used Heidoc to download the ISO but will likely use MS media creation tool to get the latest version thru MS downloads and not have to do the same updates that caused my DISM issues. I screwed up failing to make a Image backup thru Macrium Reflect after updating to 1709. After the clean install and restoration of data and software I will create a new image. Trying now to find out how to determine what edition/version is on the recovery partition although a clean install will replace it with what is installed. Just want to learn how to see this. Tried with DISKPART commands but was unable to find this info.
      My ComputersSystem Spec


  9. Posts : 7
    windows 10 Pro build 16299.98
       10 Dec 2017 #9

    GCWizard,

    Thanks for posting back about the results of your attempt at a repair install. Of course I am not surprised it failed, although I am quite sorry you had the same result as I.

    But here's something to consider before going thru a clean install process- as you quoted :

    ' at least it still functions normally with the exception of DISM. CHKDSK and SCF /SCANNOW show zero issues'

    To me this is the thing, as you I have many custom settings, programs, etc. Do I really need to do a reinstall seeing that everything seems to work normally-exception DISM?

    I just wish I can find more info on this, this issue seems quite uncommon.

    Thanks for posting this issue on the Forum.

    EG
      My ComputerSystem Spec


  10. Posts : 14,213
    windows 10 professional version 1607 build 14393.969 64 bit
       10 Dec 2017 #10

    There used to be a method to interfere with the servers and block windows upgrades.
    That was using a metered connection.
    Maybe the metered connection is interfering with the DISM.
    Can you turn off the metered connection and see if there is a different or same error code?

    The problem displayed in the logs was: hr:0x800700c1


    DISM DISM Manager: PID=8536 TID=14724 A problem ocurred loading the image session. Retrying... - CDISMManager::CreateImageSession(hr:0x800700c1)

    ERROR_BAD_EXE_FORMAT193 (0xC1)

    2) create a bootable windows 10 iso

    Download Windows 10


    These DISM commands may take a long time to run/complete:
    3) open administrative command prompt and copy and paste:
    Dism /Online /Cleanup-Image /RestoreHealth /Source:esd:E:\Sources\Install.esd:1 /limitaccess
    (change the drive letter E: to the the applicable drive letter seen in file explorer for the iso)
    4) Dism /Online /Cleanup-Image /RestoreHealth /Source:wim:E:\sources\install.wim:1 /limitaccess
    (change the drive letter E: to the applicable drive letter seen in file explorer for the iso)

    Let us know the results for the 3 different DISM
    1) off metered connection
    2) using esd
    3) using wim
      My ComputerSystem Spec


 
Page 1 of 3 123 LastLast

Related Threads
sfc and dism....restorehealth in 16299.64 in Performance & Maintenance
In the previous build (16299.19) I had the issue of contracticting reports between sfc /scannow (reported "corrupt files unable to repair"), and dism.....restorehealth (reported "operation completed successfully"). ref : sfc and dism ..... old...
After updating to Creators (Win 10 ver 1703), I ran SFC /scannow from admin-level command prompt, which found no integrity violations. I then ran DISM RestoreHealth option (I don't have exact syntax memorized, I always copy/paste from Brink's...
SFC Scannow or DISM/RestoreHealth using Image in Performance & Maintenance
Windows 10 user. Having some trouble with my system after coming back from a weekend. Nothing major...just having trouble playing some games that require plugins etc Regardless if it's related, I just wanted to run an SFC/Scannow or...
Error DISM restorehealth in Performance & Maintenance
Hello I use the Windows DVD 10 and option 3 with IMAGE_HEALTH and have an error 50: http://www.eightforums.com/performance-maintenance/68326-sfc-scannow-dism-restorehealth-repair-corrupt-files.html 0x800f081f and operation not fix !!
There is a link between all of them, and after doing tests I think I found a way to make things right. What I did on 2 computers (1 with BIOS and 1 with UEFI). Both have only one SSD. I kept the things as simple as possible. Both are x64 versions of...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:26.
Find Us