Page 1 of 2 12 LastLast
  1.    1 Week Ago #1
    Join Date : Sep 2017
    Posts : 26
    windows 10

    ASUS Windows 10 starting to bog down


    I've had my ASUS model Q524U since Sept 19. I've been pleased with it. WIth all the extra space, it could update without me knowing, unlike my earlier model that did not have 16GBs and 2TB HDD. Well, all of a sudden, too many times, when I turn it on and it is up and running, the browser is slow. I try to close browser and then the cursor gets lost. I try to control/alt/ delete to get task manager up to stop whatever is the issue, and get no response. I looked to see if it had been updating and it says last time was in Oct 17. It's Nov 8. The first time it did this, I pushed start button to force quit. It took forever to boot back up saying it was doing something to computer....can't remember anymore what that was.

    This time when it finally warmed up after it shut itself down....probably cuz i hit control/alt/delete?.... I checked the task manager to see what might be hanging things up. The "disk" column was at 100%. Now, about an hour later, it's around 6%. The things that were running seemed reasonable. I'm not well versed in this stuff tho. I noticed the ASUS GIFTBOX was right up there with what was most active. Some have advised uninstalling it. Should I?

    Any ideas why my computer, with all kinds of room, doesnt't have enough to boot up quickly and responsively from the git each time?
      My ComputerSystem Spec
  2.    1 Week Ago #2
    Join Date : May 2016
    Posts : 749
    Windows 10 Pro

    What type of software maintenance have you done on it?
      My ComputerSystem Spec
  3.    1 Week Ago #3
    Join Date : Nov 2013
    Houston
    Posts : 2,105
    3-Win-7Prox64 2-Win10Prox64

    Hi,
    Which internet provider do you use ?
    Xfinity/ Comcast has had it's share of issues for seems like a week now.
      My ComputersSystem Spec
  4.    1 Week Ago #4
    Join Date : Sep 2017
    Posts : 26
    windows 10
    Thread Starter

    Plankton,
    My computer has Windows Defender, which says everything is fine...if that's what you mean.
    Thrash Zone,
    I do use Comcast, but my husband has not had problems with his browsers. However, he just tested his speed. It's 66 mbps. Mine is 32. What? Why would mine be any different than his?
    Thanks for you input.
      My ComputerSystem Spec
  5.    1 Week Ago #5
    Join Date : Sep 2017
    Posts : 26
    windows 10
    Thread Starter

    Hmm. We have two routers. I signed into the other one and my speed is now 60ish. Weird. My husband's computer, which is an older but nicer HP, is having no issues with the other router.
      My ComputerSystem Spec
  6.    1 Week Ago #6
    Join Date : Sep 2017
    Posts : 26
    windows 10
    Thread Starter

    Husband says the router I was on (same as one he is on) has less range. But I was sitting next to him when computer firsrt bogged down. Not sure what I'm saying. But maybe using our 2nd router with more range will be the fix.
      My ComputerSystem Spec
  7.    1 Week Ago #7
    Join Date : Nov 2013
    Houston
    Posts : 2,105
    3-Win-7Prox64 2-Win10Prox64

    Hi,
    Sounds like it
    Not sure about the speed being normal at 60 either I suppose you might
    All I know is my speed bites lol
      My ComputersSystem Spec
  8.    1 Week Ago #8
    Join Date : Sep 2017
    Posts : 26
    windows 10
    Thread Starter

    p.s. Sorry for jabbering on. But do you know if it's okay for me to delete ASUS GIFTBOX?
      My ComputerSystem Spec
  9.    1 Week Ago #9
    Join Date : Nov 2013
    Houston
    Posts : 2,105
    3-Win-7Prox64 2-Win10Prox64

    Hi,
    I've never heard of asus giftbox :/
    Anything in it
      My ComputersSystem Spec
  10.    1 Week Ago #10
    Join Date : Jul 2016
    Posts : 44
    win 10
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
ASUS Laptop stuck on ASUS Logo with spinning circle under it
Hello im having a problem with my ASUS Laptop K401U. It just started about 2 hours ago, so whenever I turn on my laptop it just stuck on the ASUS Logo with spinning circle under itI still can access the BIOS, but dont know what to do about it...
General Support
Win 10: Services stuck on starting/stopping, programs not starting
Hi all! I'm facing this issue that is really annoying since I can't find out what is the cause. It started about one week ago, I notices some programs were not starting at windows start (ex: Coretemp, Malwarebytes). Moreover, the pc always got...
General Support
Windows 10 not starting up
Hey everyone, Recently I encountered an issue with Windows 10. Initially the problem started as a simple network adapter issue where the adapter was forced to be shut down by windows due to an error (code 43 on device manager). I tried to use the...
General Support
My ASUS G74SX doesn't boot past the ASUS logo!
The other day, I tried to do a factory reset on my laptop, but it failed, and I could only click cancel. Now, when I booted up my computer, it goes to the ASUS logo, then a black screen, still backlit, with an underscore flashing in the upper left...
Performance & Maintenance
Solved Starting an app in Windows 10
Hi, I have Windows 10 home 64bit and I wanted an app (Kodi) to run at startup. I placed a shortcut to it in the folder than opened when I types shell:startup. The app didn't start, but it does appear in the task manager startup with status...
Software and Apps
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:26.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums