Windows 10: Windows Resource protection could not perform the requested operation Solved

  1.    05 Nov 2017 #1

    Windows Resource protection could not perform the requested operation


    I managed to receive a couple of blue screens after updating Nvidia driver to 388.13 so I rolled back and then things went calm again , but then Windows came up with a notification that my C: disk needing a scan and if I should schedule one upon restart , it took roughly 2 hours stuck at 20% then booted to Windows normally on its own , which drove me to check if Windows installation is still ok so I ran SFC /ScanNow but however I got the message : Windows Resource protection could not perform the requested operation at 91% .

    Googling it and fixes recommended either I do a check disk again or run SFC again from safe mode where I did both with same result so any suggestion ?

    P.S Please do not direct me to DISM , I do know of DISM but usually I just end up with a log file hinting which files needing to be replaced and refusing any image I provide as a source to provide them and then if I replaced them by copies I find online the problem persist to remain .
      My ComputerSystem Spec

  2.    05 Nov 2017 #2

    Hi, I would first examine the chkdsk report, as it seems you don't know the outcome of that.

    See the following- it would be worth doing (1) anyway as it doesn't take long.

    1. First check your disk:
    Download and run Hard Disk Sentinel (trial) and make sure all disks are reported as good.
    If not, do not continue, and post back .

    2. Now check your file system:

    From an admin command or powershell prompt
    [Windows key + X, click command prompt (admin)]
    chkdsk C: /F
    Your PC will need to restart.
    Post back the result, which you can get after a restart as follows:
    Read Chkdsk Log in Event Viewer in Windows 10 Performance Maintenance Tutorials
    or
    How to read Event Viewer log for Chkdsk in Windows 10 [Tip] | Reviews, news, tips, and tricks | dotTechdotTech
    or
    How do I see the results of a CHKDSK that ran on boot? - Ask Leo!
    Make sure the result is clear or fixed- else do not proceed.
      My ComputerSystem Spec

  3.    07 Nov 2017 #3

    @dalchina sorry for the delay , the laptop had a 4 days task to perform before I could restart , here are the results :
    Checking file system on C:The type of the file system is NTFS.Volume label is WINDOWS10.A disk check has been scheduled.Windows will now check the disk. Stage 1: Examining basic file system structure ... 822272 file records processed. File verification completed. 7468 large file records processed. 0 bad file records processed. Stage 2: Examining file name linkage ... 36626 reparse records processed. 931976 index entries processed. Index verification completed. 0 unindexed files scanned. 0 unindexed files recovered to lost and found. 36628 reparse records processed. Stage 3: Examining security descriptors ...Cleaning up 181 unused index entries from index $SII of file 0x9.Cleaning up 181 unused index entries from index $SDH of file 0x9.Cleaning up 181 unused security descriptors.Security descriptor verification completed. 54854 data files processed. CHKDSK is verifying Usn Journal... 38982168 USN bytes processed. Usn Journal verification completed.Stage 4: Looking for bad clusters in user file data ... 822256 files processed. File data verification completed.Stage 5: Looking for bad, free clusters ... 12211699 free clusters processed. Free space verification is complete.Windows has scanned the file system and found no problems.No further action is required. 203340061 KB total disk space. 153233996 KB in 542826 files. 317000 KB in 54855 indexes. 0 KB in bad sectors. 942269 KB in use by the system. 65536 KB occupied by the log file. 48846796 KB available on disk. 4096 bytes in each allocation unit. 50835016 total allocation units on disk. 12211600 allocation units available on disk.
    Windows has finished checking your disk.Please wait while your computer restarts.
    So basically despite it remains stuck at 20% for a while then boots , the task is completed without errors .
    now the problem remains that i still can't get scan now to complete .

    Also I realized an odd behavior in start menu , certain installed apps would not show , I can run them from the store but not from start menu , on the other side there is an app at the bottom named ms-resource:appDisplayName , I googled and they name such thing phantom app , there is a Powershell command line to refresh store apps but despite completing successfully nothing changed .

    Others keep whining this is a build 1709 bug that wont just go so I am not sure if this is a sign of corruption or not .
      My ComputerSystem Spec

  4.    17 Dec 2017 #4

    I reached a conclusion after several tackles that the best way to fix windows corruptions is through Media Creation tool by Microsoft to re-install windows , this move has advantages above resetting windows that it does not remove profiles / software / files .
      My ComputerSystem Spec


  5. Posts : 14,213
    windows 10 professional version 1607 build 14393.969 64 bit
       17 Dec 2017 #5

    Open administrative command prompt and copy and paste: (make sure that the computer is not on a metered connection)

    1) sfc /scannow
    2) dism /online /cleanup-image /scanhealth
    3) dism /online /cleanup-image /restorehealth
    4) When these have completed > right click on the top bar or title bar of the administrative command prompt box > left click on edit then select all > right click on the top bar again > left click on edit then copy > paste into the thread
      My ComputerSystem Spec


 

Related Threads
I was just finally able to update to Windows 10 build 14931 after working on it for about a week on and off. By all appearances the update looks successful and my machine seems to work just fine after the update however when I do my regular checks...
I just installed the latest slow ring preview build, version 14931.1000 and when I performed an SFC /SNANNOW I get to 19% and then the command comes up Windows Resource Protection could not perform the requested operation. I tried three times and...
Hello, I hope I'm posting this in the correct thread....I am also having problems with SFC /SCANNOW as mine stops at 20% with this error Running SFC /SCANNOW stops at 20% with error Beginning verification phase of system scan....
Long story short, I had some problems with my computer slowly starting to be unable to open certain programs (Steam,Battle.Net Launcher,Certain internet sites) and so I put a ticket into chrome and blizzard. Blizzard had the best response and it...
Here's a screenshot of the error: https://i.gyazo.com/a56cb035ad5ab238709815ecce63eddd.png I get this popup every few minutes, unless I just leave it up permanently. I've been googling for a solution for a couple hours now, and have tried...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 08:33.
Find Us