My son is having a problem with a few of programs (Meshmixer, Simplify3D, and Cura) on his PC. These programs are 3D modeling related and therefore require lots of computing power from the PC and GPU. He can open up the program but when he clicks "Import" or "Export" (anything that opens up the file explorer dialog) the program crashes. He's been able to download the 32-bit version of Simplify3D and that will allow the program to work but Meshmixer does not have a 32-bit version. The Windows Event Viewer showed that the error's faulting module was "ntdll.dll".
We've tried the following:
  • Restarting the computer
  • Reinstalling the programs
  • Doing a full Windows 10 repair (keeping the programs and files)
  • Checking the hard drive for errors (none detected)
  • Running MalwareBytes & removing all detected malware (nothing significant was detected)
  • Based on someone else's experience with a similar problem, we tried
    • Uninstalling all Adobe products
    • Uninstalling all Google products
    • Logged out of the normal PC account and created a special Admin account to see if the problem was related to user settings

  • Done a clean reboot of the PC (booting the PC without any of the non-mandatory drivers and startup programs)
  • Updating EVERYTHING on the computer including all drivers
  • Contacting Microsoft support (who didn't fix anything)
  • Disabling the GPU (Nvidia Geforce GTX 1060 6gb) and using the small GPU on the motherboard
  • Uninstalling Acronis and Norton


The next step would be a clean re-install of Windows 10 but we're hoping to find another way to fix this since that's an extreme measure, there are over 60 programs that would have to be re-installed.

Son's desktop is a Dell XPS
i7-4790 CPU, 64 bit, Win10 Home, 16GB RAM, 2TB hard drive

Thanks