Windows 10: Windows 10 and DISM help required please Solved

Page 1 of 2 12 LastLast
  1.    21 Jun 2017 #1

    Windows 10 and DISM help required please


    Is this the correct place to get help for DISM on Windows 10?

    Thank you,
    Nolly
      My ComputerSystem Spec


  2. Posts : 6,468
    10 Home x64 (1709) (10 Pro on 2nd pc)
       21 Jun 2017 #2

    There's a tutorial on DISM that should help you..,.

    Use DISM to Repair Windows 10 Image

    ...but feel free to ask if that is not enough help to get you going.
      My ComputersSystem Spec

  3.    21 Jun 2017 #3

    Bree, Thank you for your quick reply.

    I am trying to ascertain if all is well with my Windows 10. A look at the DISM log file reports a different image version from that installed. The log file has two Warnings and Two Errors in it!

    If I supply the information in the log file, would you please help me understand.

    Nolly
      My ComputerSystem Spec


  4. Posts : 6,468
    10 Home x64 (1709) (10 Pro on 2nd pc)
       21 Jun 2017 #4

    Nolly1959 said: View Post
    If I supply the information in the log file, would you please help me understand.
    Attach the log file to a post, it would be to much and too difficult to read if you paste directly into a post. You may need to send it to a compressed .zip file first to meet the site's attachment size restrictions.

    How to Upload and Post Screenshots and Files at Ten Forums
      My ComputersSystem Spec

  5.    21 Jun 2017 #5

    DISM log file


    Here we go, I hope.



    Nolly
    Windows 10 and DISM help required please Attached Files
      My ComputerSystem Spec


  6. Posts : 6,468
    10 Home x64 (1709) (10 Pro on 2nd pc)
       22 Jun 2017 #6

    Thanks...

    The log appears to be for two runs of DISM. In the second attempt the key lines appear to be...
    Code:
    2017-06-21 14:27:49, Info                  DISM   DISM.EXE: Host machine information: OS Version=10.0.15063, Running architecture=amd64, Number of processors=4
    2017-06-21 14:27:49, Info                  DISM   DISM.EXE: Dism.exe version: 10.0.15063.0
    ...
    2017-06-21 14:28:14, Info                  DISM   DISM.EXE: Executing command line: Dism  /Get-WimInfo /WimFile:C:\test\offline\install.wim
    ...
    2017-06-21 14:28:14, Error                 DISM   DISM WIM Provider: PID=9408 "WIM open failed." - CWimImageInfoCollection::Initialize(hr:0x80070003)
    You say that...
    A look at the DISM log file reports a different image version from that installed.
    DISM reported that: Host machine information: OS Version=10.0.15063 which is the Creators Update. Were you under the impression you had an earlier version? Did you then try to use an earlier install.wim in C:\test\offline\install.wim ?

    You don't need to specify an install.wim (or install.esd) for DISM to use. DISM can run without that, it will use the current system as its source. Try it without...

    To check without making repairs use:
    dism /online /cleanup-image /ScanHealth

    To repair use:
    dism /online /cleanup-image /restorehealth
      My ComputersSystem Spec

  7.    22 Jun 2017 #7

    Yes, I did mention that the image version from the log file is different from what I have installed. This is most likely incorrect but winver reports the following:

    Version 1703 (OS Build 15063.413).

    OK the OS Build is the same. It was the 1703 that fooled me.

    Believe I have already run one of the cleanup-image commands. Guess I should run ScanHealth and only run RestoreHealth if there are errors.
      My ComputerSystem Spec


  • Posts : 6,468
    10 Home x64 (1709) (10 Pro on 2nd pc)
       22 Jun 2017 #8

    Until the 19th May there was a problem in the Creators Update (1703, os build 15063) with DISM reporting corruption but being unable to repair it. This was fixed by Microsoft updating something on their servers that was causing DISM to fail with 'source not found' when it tried to refer to it.

    If you haven't run DISM successfully yet you may still have the incorrect info on your system and the ScanHealth may still report corruption. Since the fix at Microsoft's end the RestoreHealth will successfully repair this. See this thread...

    Creators update component store shows corruption but unable to repair
      My ComputersSystem Spec

  •    22 Jun 2017 #9

    Bree, Thank you.

    See if I get any errors.

    Nolly
      My ComputerSystem Spec

  •    22 Jun 2017 #10

    Tried running /ScanHealth three times and got the same error each time at different stages of completion.

    Here is the last attempt.

    C:\windows\system32>dism /online /cleanup-image /ScanHealth

    Deployment Image Servicing and Management tool
    Version: 10.0.15063.0

    Image Version: 10.0.15063.0

    [===========================96.2%======================= ]
    Error: 0x80010108

    The object invoked has disconnected from its clients.
    An error occurred closing a servicing component in the image.
    Wait a few minutes and try running the command again.

    The DISM log file can be found at C:\windows\Logs\DISM\dism.log

    C:\windows\system32>
      My ComputerSystem Spec


  •  
    Page 1 of 2 12 LastLast

    Related Threads
    Normally when a tests completes without reporting anything wrong I'm happy camper. I have been wanting to ask a question about the DISM "scan" completing rather quickly. I seem to remember the command taking some time to finish, but for a while...
    Hello, as you already know from the title I have problems with the windows utilities that fix corruptions. After I upgraded to build 1607, those utilities worked, but now after a few weeks I tried to do them again after some driver updates just to...
    Windows 10 Recovery Help required in Performance & Maintenance
    Hi! I need to restore from a backup image. Firstly the restore from the original installation disc cannot find the image, even though there are at least 4 sat on various connected HDD's. Also, if I create a recovery drive on a USB stick, is that...
    Hello, I've run into a problem where my windows apps will not open. Calc opens with a gray screen just showing the calculator logo...calendar opens to a blue screen only showing the calendar logo, etc. I can't run SFC /scannow due to error...
    Does anyone know what the requirements are for Windows 10?
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 05:51.
    Find Us