Page 1 of 2 12 LastLast
  1.    09 Jun 2017 #1
    Join Date : Nov 2014
    Posts : 20
    windows 10

    SFC Fails within Recovery Enviroment


    I started getting the dreaded startup repair loop, and am unable too boot in Win 10 Insider build 16199. I have a multiboot, with Win 7, which works fine.
    I went to the command line within WinRE and ran chkdsk on the Win 10 partition, which found no errors. I then ran SFC /SCANNOW. First step ran fine. It then ends with the message "Windows resource protection could not perform the requested operation." Then back to the command line. Any ideas? Many thanks for the help.

    Jon
      My ComputerSystem Spec
  2.    09 Jun 2017 #2
    Join Date : Aug 2016
    S/E England
    Posts : 4,477
    10 Home x64 (1709) (10 Pro on 2nd pc)

    Yes, you'll get that if you just type SFC /SCANNOW. Without any options you're trying to run it on the online system (currently WinRE) not on your installed Windows - that's an offline system at present.

    From the recovery environment command prompt you need to use SFC's /OFFWINDIR option (and perhaps /OFFBOOTDIR) to tell it the system you want it to check. If from the WinRE command prompt your Windows system appear to be on the D: drive and installed in the \Windows folder then the command is:

    SFC /SCANNOW /OFFWINDIR=D:\WINDOWS

    I`d be careful with the /OFFBOOTDIR option as you have a dual boot system, I`m not sure what the effect could be. I don`t have a dual-boot system to test it on. On a single-boot system this runs successfully:

    SFC /SCANNOW /OFFBOOTDIR=D:\ /OFFWINDIR=D:\WINDOWS

    Code:
    /OFFBOOTDIR     For offline repair specify the location of the offline boot directory
    /OFFWINDIR      For offline repair specify the location of the offline windows directory
    Type SFC /? for the full Help

    Edit: There's more on using SFC at boot in Options One and Two here...

    Run SFC Command in Windows 10

    ...and on using it with dual-boot systems in Method Two here:

    SevenForums - SFC /SCANNOW : Run in Command Prompt at Boot
    Last edited by Bree; 09 Jun 2017 at 21:33. Reason: more info
      My ComputersSystem Spec
  3.    10 Jun 2017 #3
    Join Date : Nov 2014
    Posts : 20
    windows 10
    Thread Starter

    Bree, thank you for your response. I will try your advice and let you know the results.
      My ComputerSystem Spec
  4.    18 Jun 2017 #4
    Join Date : Nov 2014
    Posts : 20
    windows 10
    Thread Starter

    I finally got around to running SFC from WinRE with the additional parms pointing to the Win10 partition. After completing the message was it found corrupted files, but was unable to to repair all of them. Logging not available in offline mode. Any ideas are greatly appreciated. Thanks.
      My ComputerSystem Spec
  5.    18 Jun 2017 #5
    Join Date : Aug 2016
    S/E England
    Posts : 4,477
    10 Home x64 (1709) (10 Pro on 2nd pc)

    Good. Now try sfc again. From the tutorial...

    Note
    If SFC could not fix something, then run the command again to see if it may be able to the next time. Sometimes it may take running the sfc /scannow command up to 3 times with Fast Startup turned off and restarting the computer after each time to completely fix everything that it's able to.

    If not, then run the Dism /Online /Cleanup-Image /RestoreHealth command to repair any component store corruption, restart the PC afterwards, and try the sfc /scannow command again.
    Run SFC Command in Windows 10

    Like SFC, DISM can be run offline at boot. See this post for an example of the parameters required.

    Use DISM to Repair Windows 10 Image - post #400
      My ComputersSystem Spec
  6.    18 Jun 2017 #6
    Join Date : Nov 2014
    Posts : 20
    windows 10
    Thread Starter

    Bree, I'll check it out. One of the perks of retirement is time isn't much of factor 😁 Many thanks for the heads up.
      My ComputerSystem Spec
  7.    23 Jun 2017 #7
    Join Date : Nov 2014
    Posts : 20
    windows 10
    Thread Starter

    Ok, I created a WinPE Khly (sp) boot USB drive. Neither SFC or DISM will run. Are they not supported in that environment? Also, I got past the automatic repair loop by using Macrim to repair the MBR. Now I'm now getting an error about a Malwarebytes driver corruption. It happens both regular and safe boot. Is there any way to uninstall an app without booting the Win10 partition? Thanks for any advice.
    Jon
      My ComputerSystem Spec
  8.    23 Jun 2017 #8
    Join Date : Aug 2016
    S/E England
    Posts : 4,477
    10 Home x64 (1709) (10 Pro on 2nd pc)

    Quote Originally Posted by w1mnk View Post
    Ok, I created a WinPE Khly (sp) boot USB drive. Neither SFC or DISM will run. Are they not supported in that environment?
    You'd have to ask @Kyhi that. The usual way to boot to a command prompt would be to boot from Windows 10 install media (not sure how you'd make that for your Insider build 16199) or a Recovery Drive USB (Control Panel\All Control Panel Items\Recovery > Create a recovery drive).
      My ComputersSystem Spec
  9.    23 Jun 2017 #9
    Join Date : Nov 2014
    Posts : 20
    windows 10
    Thread Starter

    I have an ISO for 16193. If I burn that to USB, I should be able too use that, right? Thanks.
    Jon
      My ComputerSystem Spec
  10.    23 Jun 2017 #10
    Join Date : Aug 2016
    S/E England
    Posts : 4,477
    10 Home x64 (1709) (10 Pro on 2nd pc)

    Not being an Insider I can't say, but it sounds like it's worth a try.
      My ComputersSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Set F11 recovery option in acronis true image 2017 now fails to start
Set F11 recovery option in acronis true image 2017, failed to start, can't remember the error message, something about starting from a floppy, I think. So booted from true image disk and deactvated the F11 option, now I cannot get my PC to boot.......
Backup and Restore
System Image Recovery fails with error 0x80070002
Hi everyone, I've got a Surface Pro 3 and a system image backup from an exactly similar device on an external hard drive. When I boot to installed Windows 10 (same occurred with 8.1) and try to recover the backup, the system finds the backup file...
Backup and Restore
Windows 10 start button fails, search fails restart fails
Not cause by virus .. this just started today. I tried a restore point of yesterday .. nothing. I have tried several suggestions from the web but nothing seems to do it? I know it would be better if i could name them but can't remember the exact...
General Support
Lenovo recovery F11 function key dissapeared from preboot enviroment.
Hello. I've just copied my 500gb disk into 128gb SSD disk using EUSEUS Partition Master. After that MBR,boot and BCD was screwed up. I couldn't boot from SSD. So i've just used Windows 10 installation DVD then fixed mbr,boot and rebuilded bcd....
Installation and Upgrade
Windows Corrupted files sfc and DISM image recovery fails
Hello everyone I have been trying to fix my windows 10 corrupted files but I have been unabled to recover it. I tried every possible way of recovering using DISM commands, but to no avail. I tried also the sfc /scannow but as usual this command...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:51.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums