Page 1 of 2 12 LastLast
  1.    02 Jun 2017 #1
    Join Date : Sep 2016
    Posts : 165
    Windows 10 Pro 64 bit

    System Restore Point errors: 0x8007045b and 0x80070057


    Hi,

    I am very tired, afraid and angry.

    Today I was surfing with Edge and I encouter a web page with a loopy popup that want to make me win an Apple iPhone.

    Trying to closing that pop-op it will reopen again and my Edge starts with the opened tab so that pop-up will always start.

    I know that probably I don't have any virus (I check also my host file, is clean), and I know that I have to lanch Edge without Internet so I should close that pop-up forever, but I am paranoid and I want to back to my latest Restore Point.

    So I did it but... arrrrgh, damn Windows 10, when the system started again I had:

    "Error: 0x8007045b - Cannot extract file from \WpSystem\S...\AppData\Local\ - Impossible to complete the restore point" (sorry for the bad translation).

    So, I ran into Windows RE and try there with the Restore Point but:

    "Error: 0x80070057 - Error during the analys of the unit etc."

    Arrgh, I am agry, because it's the second time I have problem in Win10 with the Restore Point that NEVER gave me problem since the old XP.

    I also tried to use OLDER restore points with the SAME RESULTS.

    I am confused and afraid... maybe I can tollerate to use my OS without any restoring point, just cleaning that damn pop-up adware page and running a scan with Defender but... I will be able to make again working my System Restore???

    So:

    1) What I can try again to use and back my OS to my latest Restore Point

    2) If It's impossible (aaargh!) after I cleaned and make sure my OS is clean what I must to to make my Restore Point Function to be fully working for the future???

    Please help me, I totally am in your hands.

    PS: I also tried to rename the folder "Packages" that is under "\Local" without any results :-(
      My ComputerSystem Spec
  2.    03 Jun 2017 #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,002
    Win 10 Pro (1703)

    Hi, see
    https://support.microsoft.com/en-gb/...-restore-point

    The exact error message is significant to determine whether this is relevant or not.

    "Error: 0x8007045b - Cannot extract file from \WpSystem\S...\AppData\Local\ - Impossible to complete the restore point" (sorry for the bad translation).
    Compare:
    System Restore
    failed to extract the file

    C:\Users\<User Name>\AppData\Local\Packages\microsoft.windowscommunicationsapps_8wekyb3d8bbwe\....

    From the restore point.
    An unexpected error occurred during System Restore. (0x8007045b)

    (I simply searched for
    system restore 0x8007045b
    )
      My ComputerSystem Spec
  3.    03 Jun 2017 #3
    Join Date : Sep 2016
    Posts : 165
    Windows 10 Pro 64 bit
    Thread Starter

    I am so unhappy, that procedure is the first thing I did and gave me the second kind of error i wrote in my post. :-(
      My ComputerSystem Spec
  4.    03 Jun 2017 #4
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,002
    Win 10 Pro (1703)

    Could you post the exact full error messages you mentioned:
    "Error: 0x8007045b - Cannot extract file from \WpSystem\S...\AppData\Local\ - Impossible to complete the restore point" (sorry for the bad translation).

    Error: 0x80070057 - Error during the analys of the unit etc.

    However, it is possible that 'fixing' system restore may not be possible, based on previous cases.Your concern appears to be a fear of a possible virus.. but some pages do generate annoying popups.Simply considering system restore alone, I would be tempted to delete all restore points and turn it off, then enable it again, and see if it works.

    Some here regard system restore as 'good when it works, but not to be relied upon' and rely on disk imaging (which everyone should use routinely anyway).
      My ComputerSystem Spec
  5.    03 Jun 2017 #5
    Join Date : Sep 2016
    Posts : 165
    Windows 10 Pro 64 bit
    Thread Starter

    In fact, I gave up about using a Restore Point so I ordered my OS as is now, checked with Defender, everything seem to be fine, that adware was only a page that dind't make other damage to the OS, I think.

    Said that, I MADE another Restore Point (today) and I try to back to it (for a test) but this time I got:

    Error 0x80070091 related to the WindowsApps folder in C:

    Once, I managed with success with this issue, I had to use the "takeown" and "icacls" commands, renamed that folder to ".OLD" and the had success. Also, in order to delete the .OLD folder I had to use "Winpese-x64" live cd.

    Now I try to delete all restore points and reactivate it and check.

    I am sure this issue is related to Windows 10 Windows Store Apps.

    I am so angry with Windows 10... you said "Some here regard system restore as 'good when it works" but I am tiderd of that "good when it works" stuff!!!

    I start to think that I will back to Windows 7 soon, without all this issues, no privacy problems, no blurry screen problems, no System Restore problems...
      My ComputerSystem Spec
  6.    03 Jun 2017 #6
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,002
    Win 10 Pro (1703)

    There is a very long thread (which I happened to start) with a fix for Error 0x80070091. After a few weeks- during which I did nothing to fix it- I found SR working again.

    My Win 10 is very stable- lots and lots of progs installed- far more than most people have, no BSODs.

    Point is with System Restore- it's a partial fix when it works which can be helpful. Note that MS leaves it disabled in Win 10- so I wonder why that is...?

    Disk imaging is much more robust and complete.

    There are a few things I detest- Win 10's rubbish start menu. I don't use it.

    I have control over Windows updates by setting them to notify- so I download when I want to.

    But I can understand some people finding Win 10 extremely frustrating- and MS's actions raise some worrying questions.
      My ComputerSystem Spec
  7.    03 Jun 2017 #7
    Join Date : Sep 2016
    Posts : 165
    Windows 10 Pro 64 bit
    Thread Starter

    I followed it once, and It worked very well but I lose time to use a live cd to delete the renamed WindowsApp.OLD folder.

    Also, now I have TWO WindowsApps folders (C and D) so I am afraid the issue will be once for one and once for the other.

    I am now deleting the system restore points (it's very slow it's many GB) and try to see what's happen. But I am sure that it will be Always an issue or another.

    PS: IN FACT, after the delete of ALL old restore points, make a new RP, tried to back to it and... ALWAYS the latest ERROR (0x80070091).

    So, I must live with it, that if I sometimes I Will need RP, I must hope that your method works (that once worked to me) and also that I won't get other EFS related issues.

    Disk imaging is GOOD but need too much time!!! I use (in the past, now) RP before installing ANY software to be sure and imaging only once a month or more.

    This issue is solved with the Creators Update?
    Last edited by Pipppero2007; 03 Jun 2017 at 06:55.
      My ComputerSystem Spec
  8.    03 Jun 2017 #8
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,002
    Win 10 Pro (1703)

    The 800700091 is reported as resolved in the Creator's Update.
      My ComputerSystem Spec
  9.    03 Jun 2017 #9
    Join Date : Sep 2016
    Posts : 165
    Windows 10 Pro 64 bit
    Thread Starter

    Quote Originally Posted by dalchina View Post
    The 800700091 is reported as resolved in the Creator's Update.
    Please read this:

    System Restore error 0x80070091 - Microsoft Community

    "I have Creator's - it was installed with no option to delay given to me. In addition to having Bing, Edge and Defender forced on me I still have the System Restore problem."
      My ComputerSystem Spec
  10.    03 Jun 2017 #10
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,002
    Win 10 Pro (1703)

    Obviously depends whose report you read...
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Solved can not create/restore system point
Hi. can not create/restore system point. Please help, Thanks.
Backup and Restore
an inquiry on system restore point?
any way to create a system restore point -not on the pc but externally? -perferbaley my large capacity external hdd:shock:
Backup and Restore
Solved 0x80070057 error at the end of system image restore
A couple of days ago I made a system image backup (there were no error messages that it was unsuccessful), now I need to restore it, I boot Windows 10 DVD, point to a network location and start the restore, but after an hour or so, at the end it...
Backup and Restore
Solved Settings Greyed Out After Using System Restore Point
After restoring my computer back two days using System Restore, I noticed in PC Settings>Personalization>Start>Choose which folders appear on Start, that all the options are greyed out except "Settings". I was wondering if there was a way to fix...
Backup and Restore
System Restore not making restore point before updates.
So why did Microsoft change this? If I remember correctly all previous versions would create a system restore point before doing Microsoft updates. Since 10 installed all updates that come in for me are downloaded and installed without a restore...
Backup and Restore
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 10:59.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums