Page 1 of 3 123 LastLast
  1.    31 May 2017 #1
    Join Date : May 2015
    Posts : 85
    Microsoft Windows 10x64 Pro

    High CPU usage by IE 11


    For the last couple of weeks IE 11 is constantly using about 10% of my CPU power all the time. I've run several different security checks and they all come up without any issues. I've disabled all add
    Attached Thumbnails Attached Thumbnails Capture.JPG  
    Last edited by MSRadell; 01 Jun 2017 at 21:47.
      My ComputerSystem Spec
  2.    01 Jun 2017 #2
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 3,954
    Windows 10 Pro Build 1703

    Hi MSRadell.

    Have you tried resetting IE?

    Ken

    Edit 1:

    How many home / start pages are you using? Have you tried with none?
      My ComputerSystem Spec
  3.    01 Jun 2017 #3
    Join Date : May 2015
    Posts : 85
    Microsoft Windows 10x64 Pro
    Thread Starter

    Yes, Iíve tried resetting IE, Iíve actually done it several times. I only have one homepage set (CNN.com) and Iíve already tried removing it. Iím not quite sure when it started but itís within the last couple of weeks.
      My ComputerSystem Spec
  4.    01 Jun 2017 #4
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 3,954
    Windows 10 Pro Build 1703

    Might I suggest Process Explorer as part of Sysinternals. It might give you more insight.

    https://technet.microsoft.com/en-us/...sexplorer.aspx


    Ken
      My ComputerSystem Spec
  5.    01 Jun 2017 #5
    Join Date : Apr 2017
    Posts : 8,561
    windows 10 professional version 1607 build 14393.969 64 bit

    See if the Internet Explorer troubleshooter from the Microsoft easy fix changes the performance:

    https://support.microsoft.com/en-us/...-fix-solutions
      My ComputerSystem Spec
  6.    01 Jun 2017 #6
    Join Date : May 2015
    Posts : 85
    Microsoft Windows 10x64 Pro
    Thread Starter

    Quote Originally Posted by Caledon Ken View Post
    Might I suggest Process Explorer as part of Sysinternals. It might give you more insight.

    https://technet.microsoft.com/en-us/...sexplorer.aspx


    Ken
    I use that utility all the time. Hereís a screen capture showing what Internet Explorer is doing:

    Click image for larger version. 

Name:	Capture.JPG 
Views:	1 
Size:	24.4 KB 
ID:	137655
      My ComputerSystem Spec
  7.    01 Jun 2017 #7
    Join Date : May 2015
    Posts : 85
    Microsoft Windows 10x64 Pro
    Thread Starter

    Quote Originally Posted by zbook View Post
    See if the Internet Explorer troubleshooter from the Microsoft easy fix changes the performance:

    https://support.microsoft.com/en-us/...-fix-solutions
    I tried the link provided and downloaded the file for diagnosing Internet Explorer performance. However it won’t run and it says that another file that’s required is missing.
      My ComputerSystem Spec
  8.    02 Jun 2017 #8
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 3,954
    Windows 10 Pro Build 1703

    So no real information from Process Explorer.

    Can I ask what security checks you've run? Have any installed themselves into IE?

    In a previous post you said you disabled addins, have you removed them?
      My ComputerSystem Spec
  9.    02 Jun 2017 #9
    Join Date : May 2015
    Posts : 85
    Microsoft Windows 10x64 Pro
    Thread Starter

    Quote Originally Posted by Caledon Ken View Post
    So no real information from Process Explorer.

    Can I ask what security checks you've run? Have any installed themselves into IE?

    In a previous post you said you disabled addins, have you removed them?
    As far as security goes I have Norton Security installed on the machine and I have run Malwarebytes when I discovered the problem. Neither 1 of them or picking up any issues.
      My ComputerSystem Spec
  10.    02 Jun 2017 #10
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 3,954
    Windows 10 Pro Build 1703

    How about another browser. I started Chrome and its usage hung around 3%-5%. After about 10 minutes it sunk to zero and would then pop to less than 2% and back to zero.

    With Malwarebytes are you scanning for rootkits.
      My ComputerSystem Spec

 
Page 1 of 3 123 LastLast


Similar Threads
Thread Forum
System and Compressed Memory (High memory usage)
Hello there, I am here today as I have had a problem with System and Compressed Memory since I installed Windows 10 back in December of 2015. Now keep in mind, this isn't a normal issue, as I have yet to actually find anything in regards to what...
Performance & Maintenance
High Memory Usage/ Low Memory Popup on Win10 8gb Laptop
It seems that I've been getting low memory issues ever since upgrading to Win10, but I'm not 100% certain if thats the issue. I thought about uprading to 16gb ram, but I'd like to know if theres some other fix for this. I can't multitask as I used...
Performance & Maintenance
High memory usage / Memory leak caused by Intel driver
Hello, I'm running a 64 bit Windows 10 laptop. On idle, the System process is showing a high memory usage of more than 150 MB, usually more than 200 MB. Using poolmon the pooltag SpDN showed up with a memory leak. It leads to the Intel Matrix...
Performance & Maintenance
High Memory Usage
Hello, I have a question. The system process (ntoskrnl.exe) using excessive amount of RAM. So, how do I fix that? Thanks
Performance & Maintenance
High memory usage
Hello everyone. I used win 7 before win 10 and now I have an issue with memory. For instance, playing games like nba2k15 my computer used about 2.6-2.8 GB of 4 GB but not more than 3 GB in win 7. Now it uses almost all 4 GB and of course it lags....
Performance & Maintenance
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:04.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums