Creators Update performance issues


  1. Posts : 8
    Windows 10 Pro
       #1

    Creators Update performance issues


    Hello everyone,

    I've bought a completely new rig, my specs are below:
    Gigabyte GA-Z270-HD3P
    i7-7700k
    32GB DDR4 Kingston HyperX
    250GB System SSD Samsung EVO 850
    Gigabyte GeForce GTX 1060 6GB

    On this I've installed the new creators update of Win10 Pro, and without adding anything else I was astounded about the lacking performance of the clean system, opening This PC takes a second, going into drives and folders from there takes a second, alt+tabbing to other windows takes a second, much longer than the blink it took on Anniversary on my older setup (i7-3770k, 16GB DDR3)

    my standard setup includes ESET Smart Security, SoftPerfect RAMDisk for TEMP and disabled pagefile for less SSD strain, but I didn't even come to that to notice the lag, it all started right up from the Hi there welcome screen.

    Now after I've finished the setup, I'm writing this while a Linux Virtualbox VM is running with 4GB RAM and 4 virtual CPUs in another window, no lags or lockups to be seen inside the VM, alt-tabbing into it and back here to Chrome takes again longer than a blink.

    Anyone else with similar problems, and a hint on what could be the cause, e.g. the classical early-adopter issues that some of the people have? I'd like to stop being nervous about it :)
    Thanks alot :)

    Dex

    Edit: this situation almost looks to me like Microsoft somehow accidentally enabling the new spectacular Game mode across the whole system, e.g. suppress overall system resources and give them over to all non-windows programs regardless if it's a game or not. Couldn't really think of any other explanation.
    Last edited by dexsk; 14 Apr 2017 at 11:57. Reason: Game Mode
      My Computer


  2. Posts : 17
    Windows 10 Pro
       #2

    dexsk said:
    Hello everyone,

    I've bought a completely new rig, my specs are below:
    Gigabyte GA-Z270-HD3P
    i7-7700k
    32GB DDR4 Kingston HyperX
    250GB System SSD Samsung EVO 850
    Gigabyte GeForce GTX 1060 6GB

    On this I've installed the new creators update of Win10 Pro, and without adding anything else I was astounded about the lacking performance of the clean system, opening This PC takes a second, going into drives and folders from there takes a second, alt+tabbing to other windows takes a second, much longer than the blink it took on Anniversary on my older setup (i7-3770k, 16GB DDR3)

    my standard setup includes ESET Smart Security, SoftPerfect RAMDisk for TEMP and disabled pagefile for less SSD strain, but I didn't even come to that to notice the lag, it all started right up from the Hi there welcome screen.

    Now after I've finished the setup, I'm writing this while a Linux Virtualbox VM is running with 4GB RAM and 4 virtual CPUs in another window, no lags or lockups to be seen inside the VM, alt-tabbing into it and back here to Chrome takes again longer than a blink.

    Anyone else with similar problems, and a hint on what could be the cause, e.g. the classical early-adopter issues that some of the people have? I'd like to stop being nervous about it :)
    Thanks alot :)

    Dex

    Edit: this situation almost looks to me like Microsoft somehow accidentally enabling the new spectacular Game mode across the whole system, e.g. suppress overall system resources and give them over to all non-windows programs regardless if it's a game or not. Couldn't really think of any other explanation.
    mate, I just read your post and holy I disabled Game Mode and now the hiccup almost gone, will disable any game mode services/xbox as well hope for the best.. also thanks.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:52.
Find Us




Windows 10 Forums