Windows 10: high cpu usage by windows modules installer worker post 3/14 update

Page 2 of 2 FirstFirst 12

  1. Posts : 6
    Windows 10 Home 64-bit
       15 Mar 2017 #11

    xraiderv1 said: View Post
    I notice hellishly slow performance..
    Check HD usage in perfmon. I noticed that oftentimes after Windows 10 updates are installed additional HD-intensive processes are triggered and run for 30 minutes or more. Games are slowed down visibly on my machine during this time.

    For example, I turned my Windows 10 Home machine on 15 mins ago and there is still some intense disk activity (see screenshot). CPU usage is at 2%-3%.
    Click image for larger version. 

Name:	Untitled.png 
Views:	3 
Size:	50.8 KB 
ID:	125303
    Last edited by tr00don; 15 Mar 2017 at 18:25.
      My ComputerSystem Spec

  2.    15 Mar 2017 #12

    thats the thing, I'm not at all sure what half of the processes were, and some seemed to point in the direction of the windows store, eg apps I already had being updated....but when I checked in that direction, only one app had even been touched.
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
No idea what is going up on here. Never was issue before. Taking up 33% of my drive process constantly, sometimes going up to 12.4 MB/s. Dism restore health command is also taking forever. Any idea how to fix ?
so, what is the windows module installer? what does it do?
I was trying to run sfc /scannow, which gave me: Windows Resource Protection could not start the repair service. I figured through google that it's the problem of the Windows Modules Installer, and the problem seemed to be the default setting...
Windows Modules Installer Worker in Performance & Maintenance
I just noticed for the first time that my Windows 10 Task Manager is showing significant (~25-30%) CPU usage for the Windows Modules Installer Worker. The latest update I did was some Windows Defender updates this morning. I am running 14393.321....
Windows 10 High CPU Usage After Update in Performance & Maintenance
Hey all I've been using W10 for a couple of months.. No big problems so after. After last week's updates, the cpu usage is around 20% idle. Which would be around 4-5% normally. My computer is always hot and fans do not stop. Anyone with a similar...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 12:19.
Find Us