SFC/SCANNOW cannot start the repair action

  1. Posts : 3
    Windows 10

    SFC/SCANNOW cannot start the repair action

    In the post Announcing Windows 10 Insider Preview Build 14291 for PC and Mobile there is some code to address this issue. I ran the script, but get an error "file wrpint.dll not found". I searched and found it in windows/WinSxS/......... It is found in many subfolders. The lowest subfolder in the set root command does not match the subfolders in windows/WinSxS.

    I have tried a number of solutions to get SFC/scannow to work with no success.

    Please advise.
      My Computer

  2. TexasBandit's Avatar
    Posts : 251
    Windows 10 Pro

    It looks like the problem with SFC may be very simple: incorrect syntax. The command should be SFC /Scannow. Notice the blank before the "/".
      My Computer

  3. Posts : 3
    Windows 10
    Thread Starter

    Syntax is not the issue

    Thanks for the catch on the syntax, but I corrected that this morning and still get the error 'could not start the repair service.
      My Computer

  4. Kyhi's Avatar
    Posts : 3,605
    Windows 3.1 to Windows 10

    try running from Command Prompt(admin)
      My Computer

  5. Borg 386's Avatar
    Posts : 29,518
    Win 7 32, Win 7 64 Pro, Win 8.1 64 Pro, Win 10 64 Education Edition

    I hope this tutorial will help:

    SFC Command - Run in Windows 10

    Note   Note
    If SFC could not fix something, then run the command again to see if it may be able to the next time. Sometimes it may take running the sfc /scannow command up to 3 times with Fast Startup turned off and restarting the computer after each time to completely fix everything that it's able to.

    If not, then run the Dism /Online /Cleanup-Image /RestoreHealth command to repair any component store corruption, restart the PC afterwards, and try the sfc /scannow command again.
      My Computer

  6. Victek's Avatar
    Posts : 311
    Windows 10 x64 v2004 OS Build 19041.804

    Kyhi said:
    try running from Command Prompt(admin)
    If you try to run it in a command window without admin rights you get the following response:

    "You must be an administrator running a console session in order to use the sfc utility"
      My Computer

  7. Posts : 3
    Windows 10
    Thread Starter

    The problem I am trying to solve is when I plug a USB hard drive into the laptop, it is not getting a drive letter associated with it. Thus application programs cannot see it. If I manually assign a drive letter then the application programs can see it. I have go so far as to run the 'Repair Install of Windows 10 with an in-place Upgrade'. That still did not solve the problem. Any additional ideas?
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:28.
Find Us

Windows 10 Forums