1.    06 Dec 2016 #1
    Join Date : Dec 2016
    Posts : 2
    Windows 7 x64

    Failed to Load the provider: .... PEProvider.dll


    Getting the above warning in dism.log (later causing error) with almost anything I try to do with DISM.

    Let be straight - I'm in such a state trying to fix this problem I didn't even notice this was a Windows 10 forum!. My problem is with Windows 7 64bit, so you may want to kick me out or take pity .

    Problem started with with the visual studio 2015 reditributable package, vc_redist.x64.exe. It fails during the Windows7_MSU_x64 phase with missing api-ms-win-crt-runtime-l1-1-0.dll . I tried to fix it with KB2999226 and it also fails, with 0x80240017. MS publish a fix for the problem, by extracting the KB and using DISM to patch it. :

    wusa.exe C:\packages\Patch\x64\Windows6.1-KB2999226-x64.msu /extract:extractedFix

    DISM.exe /Online /Add-Package /PackagePath:extractedFix\Windows6.1-KB2999226-x64.cab

    C:\packages\vcRedistD14\vc_redist.x64.exe /repair


    DISM fails with :

    2016-12-06 15:10:40, Warning DISM DISM Provider Store: PID=2804 Failed to Load the provider: C:\Users\Rick\AppData\Local\Temp\927F8070-C52A-441B-87E1-41346CA25327\PEProvider.dll. - CDISMProviderStore::Internal_GetProvider(hr:0x8007007e)

    which later leads to 4 errors and failure. So I put the WIndows DVD in I: and :

    C:\Users\Rick>Dism /Online /Cleanup-Image /RestoreHealth /Source:wim:I:\sources\install.wim:1 /limitaccess

    Same problem in dis.log with PEProvider.dll. In fact I've tried CheckHealth and RestoreHealth and they both fail because of PEProvider.dll. The dism directory holds many DLLs but not that one, neith is it in the system folders.

    Directory of C:\Windows\System32\Dism

    12/04/2011 08:17 <DIR> .
    12/04/2011 08:17 <DIR> ..
    21/11/2010 03:24 762,368 CbsProvider.dll
    14/07/2009 01:40 183,296 CompatProvider.dll
    21/11/2010 03:24 289,792 DismCore.dll
    21/11/2010 03:24 111,616 DismCorePS.dll
    14/07/2009 01:39 96,768 DismHost.exe
    14/07/2009 01:40 186,368 DismProv.dll
    14/07/2009 01:40 435,712 DmiProvider.dll
    12/04/2011 08:17 <DIR> en-US
    14/07/2009 01:40 53,760 FolderProvider.dll
    21/11/2010 03:24 313,344 IntlProvider.dll
    14/07/2009 01:41 107,008 LogProvider.dll
    14/07/2009 01:41 216,576 MsiProvider.dll
    14/07/2009 01:41 127,488 OSProvider.dll
    14/07/2009 01:41 271,360 SmiProvider.dll
    21/11/2010 03:24 444,416 TransmogProvider.dll
    14/07/2009 01:41 302,080 UnattendProvider.dll
    14/07/2009 01:41 471,040 WimProvider.dll
    16 File(s) 4,372,992 bytes
    3 Dir(s) 10,741,211,136 bytes free

    C:\Windows\System32\Dism>

    Looking back through dism logs, it seems to have been a problem for a while

    How can I fix this PEProvider.dll problem and get the vc 2015 redistributable installed please?.
      My ComputerSystem Spec
  2.    07 Dec 2016 #2
    Join Date : Dec 2016
    Posts : 2
    Windows 7 x64
    Thread Starter

    I'm also getting a similar problem with just about any use of DISM, even a simple wim mount :

    F:\Slip>dism /mount-wim /wimfile:F:\slip\Extract\sources\install.wim /index:3 /mountdir:F:\slip\dismmount

    Deployment Image Servicing and Management tool
    Version: 6.1.7600.16385

    Error: 0xc1420115

    The user attempted to mount to a directory that does not exist. This is not supported.

    The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

    F:\Slip>

    Log extracts :

    2016-12-07 17:30:58, Info DISM DISM Provider Store: PID=5576 Failed to get and initialize the PE Provider. Continuing by assuming that it is not a WinPE image. - CDISMProviderStore::Final_OnConnect
    ...
    ...
    2016-12-07 17:30:58, Error DISM DISM WIM Provider: PID=5576 Failed to mount the image. - CWimImageInfo::Mount(hr:0xc1420115)
    2016-12-07 17:30:58, Error DISM DISM WIM Provider: PID=5576 d:\w7rtm\base\ntsetup\opktools\dism\providers\wimprovider\dll\wimmanager.cpp:999 - CWimManager::InternalOpMount(hr:0xc1420115)
    2016-12-07 17:30:58, Error DISM DISM WIM Provider: PID=5576 d:\w7rtm\base\ntsetup\opktools\dism\providers\wimprovider\dll\wimmanager.cpp:2247 - CWimManager::InternalCmdMount(hr:0xc1420115)
    2016-12-07 17:30:58, Error DISM DISM WIM Provider: PID=5576 Error executing command - CWimManager::InternalExecuteCmd(hr:0xc1420115)
    2016-12-07 17:30:58, Error DISM DISM WIM Provider: PID=5576 d:\w7rtm\base\ntsetup\opktools\dism\providers\wimprovider\dll\wimmanager.cpp:516 - CWimManager::ExecuteCmdLine(hr:0xc1420115)
      My ComputerSystem Spec
  3.    07 Dec 2016 #3
    Join Date : Jan 2015
    Posts : 382
    Windows 10 Home x64

    You'd probably be better off posting in the 7 forum http://www.sevenforums.com/

    Not kicking you out, but as you've said this is the 10 forum. You'll probably get a more timely assist better related to Win7 in that forum.

    Good luck
    Last edited by CmmTch; 07 Dec 2016 at 17:47.
      My ComputersSystem Spec

 


Similar Threads
Thread Forum
Failed to load resource DLL?
What does "Failed to load resource DLL" mean? Why is my PC doing this? 103179
General Support
Solved The driver \Driver\WUDFRd failed to load for the device
Full event error: The driver \Driver\WUDFRd failed to load for the device {C5A047D8-CB5B-40E9-B9E3-316AB06B5A18}\WirelessKeyboardFilter` Driver environment: Windows 10 x64 desktop I have a wireless Microsoft mouse I do not have a Microsoft...
Drivers and Hardware
The driver \Driver\WUDFRd failed to load for the device ROOT\PARAGONBL
Hi there! I'm in a desperate need of help. This is the situation (sorry for my bad English as always...). Yesterday I left my PC running with a download in progress through MiPony. I told the program MiPony (for the first time) to shut down...
BSOD Crashes and Debugging
The driver \Driver\WudfRd failed to load for the device
Hi, I'm been having issues a looong time with different sorts of BSOD's but I've been able to cook it down to this last one after replacing both graphics card and Logitech headset. Latest error which occuring at least once per day: The...
BSOD Crashes and Debugging
Failed to load resources from resource file,Please check Setup
After clean install of windows 10 ,the program called Martindale complete drug reference show me this error message like i said in title. This program worked normal in windows 8.1 so i was force to install windows 8.1 and dual boot ,because i really...
Software and Apps
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 10:02.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums