Page 1 of 2 12 LastLast

  1. Joined : Nov 2016
    Posts : 4
    Windows 10
       2 Weeks Ago #1

    Windows File Indexing - current progress


    I wanted to include the contents of .tpl files in searches so I made the appropriate changes in Indexing Options and also chose to Delete and rebuild index which will apparantly take a long time. But how do I know when it is complete or what progress has been made so far?

    When I re-open Indexing options it says 'Indexing complete' but I have thousands of .tpl files so I know this can't be true and it is still not possible to search their content.

    Is there some kind of progress status somewhere?

    Many thanks for any insights!
      My System SpecsSystem Spec


  2. Joined : Jan 2015
    UK, Midlands
    Posts : 6,241
    Win 10 Pro (1607)
       2 Weeks Ago #2

    Hi, the only progress indicator I know of is Indexing Options.
    Have you checked to see if tpl types are indexed as here?
    And I assume
    appropriate changes
    means you have selected the folders where these files reside.
    Click image for larger version. 

Name:	Snap 2016-11-20 at 14.33.01.jpg 
Views:	2 
Size:	88.9 KB 
ID:	110772

    If you find explorer search inconvenient, we thoroughly recommend the free very fast tools
    Ultrasearch
    Locate32
    Everything by Void Tools

    These build and maintain an index of files and folders on all disks/partitions, and search is find-as-you-type with various levels of filtering or restriction. They do not index content.
      My System SpecsSystem Spec


  3. Joined : Nov 2016
    Posts : 4
    Windows 10
       2 Weeks Ago #3

    Thanks but done all that and .tpl did exist in the link so changed it to Plain Text Filter.

    But even without this new file type if I click 'Advanced' and then select 'Rebuild' I get a warning message that 'Rebuilding the index may take a long time to complete'. I click OK anyway and it still says 'Indexing complete' but cannot find text strings in the .tpl.

    I've done this before and sometime the next day it starts working. I was just wondering if there was a way to see progress and no when the re-index is complete ....
      My System SpecsSystem Spec


  4. Joined : Jan 2015
    UK, Midlands
    Posts : 6,241
    Win 10 Pro (1607)
       2 Weeks Ago #4

    If you watch Indexing Options after specifying sthg new to index you will see activity when indexing, and indication of how many items are indexed. That's your progress indicator. Complete is complete.

    Now you mention
    cannot find text strings in the .tpl.
    1. Can you find the files?
    2. If so, have you checked this for the folder(s) containing your files?
    Click image for larger version. 

Name:	Snap 2016-11-20 at 15.45.21.jpg 
Views:	14 
Size:	32.7 KB 
ID:	110791

    And Click image for larger version. 

Name:	Snap 2016-11-20 at 15.49.42.jpg 
Views:	14 
Size:	10.7 KB 
ID:	110793 this should be checked for tpl file type.

    After that, I'm wondering if its content isn't being indexed because Windows does not recognise it as of kind text. Perhaps you need to assign it as such.
      My System SpecsSystem Spec


  5. Joined : Nov 2016
    Posts : 4
    Windows 10
       2 Weeks Ago #5

    The .tpl bit in here is probably a red herring at the moment. I'll try it another way:

    - I go to Indexing Options in the control panel
    - I click 'Advanced'
    - By 'Delete and rebuild index' I click Rebuild
    - I get a warning that this could take some time but I click OK
    - I close everything and then return to Indexing Options again
    - It say indexing is complete

    One of my indexing locations is my F drive - a hard drive with 68GB of files on including .docs, etc. Apparently Windows 10 has rebuilt the entire index within 10 seconds? I just think that can't be true ....
      My System SpecsSystem Spec


  6. Joined : Jan 2015
    UK, Midlands
    Posts : 6,241
    Win 10 Pro (1607)
       2 Weeks Ago #6

    Screenshots help enormously. Could you please post one like this? (And yes, that's my '10 not '7).
    Click image for larger version. 

Name:	Snap 2016-11-21 at 08.03.06.jpg 
Views:	1 
Size:	47.8 KB 
ID:	110872
    It takes a minute or two to rebuild that index.

    As to whether your index is effective, I'll ask again, can you actually find any files (names, not content) that should be indexed?

    Now, and not immediately directly relevant to your issue, what I have found that despite everything being set up to index content of rtf files, taking and example of a folder and files which should be so indexed, whatever I do, rtf's content isn't indexed. (txt files are). I don't use Windows search content indexing normally, and use other tools as I mentioned. I find that very puzzling.

    (I used to use Google desktop search which does work - I recently set that up again- the only one I know of that supports OCR'g and indexing e.g. image base pdf's).
      My System SpecsSystem Spec


  7. Joined : Nov 2016
    Posts : 4
    Windows 10
       2 Weeks Ago #7

    Click image for larger version. 

Name:	windows-10-indexing.jpg 
Views:	2 
Size:	114.6 KB 
ID:	110882

    Thanks for you time on this - I've uploaded the screenshot.

    Searches work fine so perhaps re-indexing is a whole lot faster than I thought.

    Re .tpl files Windows 10 doesn't seem to be able to read the contents while Windows 8 could so perhaps just a glitch in this version.

    Thanks for the pointer to UltraSearch - I've downloaded that and it can do the job with .tpls ... unless my screenshot brings on any revelations ...
      My System SpecsSystem Spec


  8. Joined : Jan 2015
    UK, Midlands
    Posts : 6,241
    Win 10 Pro (1607)
       2 Weeks Ago #8

    Search indexing backs off if your PC is even slightly busy. If everything's fast, indexing should be fairly quick, depending on how many items and how much content indexing there is to do, as you'd expect. I can see mine progress in stages- just 12,000 or whatever it was.

    Having noted rtf's aren't being indexed (as they should) - and I've not checked other file types- it's quite possible your tpl files aren't being indexed.

    The registry contains this:
    Click image for larger version. 

Name:	Snap 2016-11-21 at 11.11.02.jpg 
Views:	1 
Size:	39.7 KB 
ID:	110884
    (PerceivedType).
    I even tried changing that to text as per txt files which are indexed, restarting and rebuilding- no difference.
    Windows also allocates file types to a 'kind' as per the document below. For example, two video file types - divx and flv- are not by default designated as of kind video, but can be so set manually so their thumbnails appear.

    I'm wondering as above if that is relevant (I've now shown it's not- doxcx, rtf, pdf and txt are all of kind documents, but the 1st 3 aren't indexed by content), or there's simply a bug in Windows search- which, as I said, really isn't worth the effort of trying to use beyond the trivial.

    Windows search has too many quirks and oddities to be reliable for all uses- it's useful for fairly trivial searches, and to support start menu and settings searches. But you can use more complicated syntax.. if you can recall it on the odd occasion it's needed.

    E.g. Maybe

    ?x*.* NOT yx*.* kind:video foldername:Videos\Myfamily date:last week

    (If I've got that right, which is very unlikely). Yes, well. I rest my case.
    Advanced Query Syntax (Windows)
    Last edited by dalchina; 2 Weeks Ago at 08:18.
      My System SpecsSystem Spec


  9. Joined : Sep 2015
    Posts : 25
    Windows 10 Pro x64 1607
       2 Weeks Ago #9

    .docx and .pdf file are indexed with the correct filter. I can't tell you about .rtf files, I don't use them often enough.

    Click image for larger version. 

Name:	Image 001.jpg 
Views:	10 
Size:	158.1 KB 
ID:	110907Click image for larger version. 

Name:	Image 002.jpg 
Views:	10 
Size:	147.8 KB 
ID:	110908
      My System SpecsSystem Spec


  10. Joined : Jan 2015
    UK, Midlands
    Posts : 6,241
    Win 10 Pro (1607)
       2 Weeks Ago #10

    Thanks- I have a pdf filter listed- I'm guessing it simply doesn't work. I'm going to try changing my pdf defaults.
    rtf - I've tried Wordpad and WPS (Kingsoft) as default- neither work.

    As for docx, I use WPS (Kingsoft) - but now I've checked that, there's no filter for that, so that explains that.

    For me it's no more than curiosity- Windows search is problematical, so I only use it minimally.
    Last edited by dalchina; 2 Weeks Ago at 12:37.
      My System SpecsSystem Spec


 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
please Ms fix file explorer -- not showing progress on copy
Hi Ms this fault I find really annoying and there's actually no excuse for this particular defect : When copying / moving files with File explorer - progress indicator doesn't show - which makes the whole thing unuseable if you are copying /...
Windows Insider
Latest build -- file explorer not showing progress when copy files
Hi there big big problem --latest (preview) build - file explorer not showing progress when copying / moving files. This - unless fixed soon will cause me to revert to previous build. Anybody else got this or is it just something with my...
General Support
Solved Green progress bar in File Explorer
I don't remember how or when I made a change in File Explorer, but each time I call it up now, I get a slow moving progress bar in the bar where it identifies the location. I noticed there in the search bar it shows where it is going: "search (J:)...
Performance & Maintenance
File operations Progress dialog missing
When I copy,paste,move a file I no longer get a progress dialog. The operation happens but there is no indocation of progress and it is tempting to repeat the operation as you're not sure anything is happening. I still get the diallg on my other...
General Support
Search indexing is indexing my D: drive instead of C:
dual boot system 10 on C:, 7 on D: Search indexing insists on indexing drive D: instead of C: No matter how many times I uncheck indexing locations on D: and choose proper locations on C:, when indexing starts to rebuild it reverts back to D: I...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:35.
Find Us
Twitter Facebook Google+



Windows 10 Forums