Windows 10: Let's run Win10 on really really old hardware

Page 22 of 22 FirstFirst ... 12202122

  1. Posts : 5,985
    10 Home x64 (1709) (10 Pro on 2nd pc)
       1 Week Ago #211

    Mark Phelps said: View Post
    So, as an experiment, I decided to install the latest Win10 32-bit version on my old Fujitsu tablet (running Intel 915GM) and while it surprised me by actually working, without useful video drivers, the experience using it was painfully slow.
    It would be. AIUI that would have a Pentium M cpu. I've tried W10 on an old laptop with an AMD V120 and that ran like treacle. Win7 runs fine - W10 crawls. The Passmark benchmarks say my cpu's benchmark is 50% higher than yours...
    PassMark | CPU Performance Comparison - V120 vs. Pentium M

    IME a benchmark of at least 1000 is needed to run W10 at any sort of usable speed.
      My ComputersSystem Spec

  2. Posts : 2,404
    Windows 10 Pro 64-bit 1709 (FCU build 16299.248)
       1 Week Ago #212

    Unfortunately while both Intel 915 and 925 had the potential for Aero graphics, they were not too fast, so Intel decided not to include WDDM drivers for these chipsets leaving out a lot of netbooks and old notebooks. The first Intel chipset to have WDDM drivers is 945G. For NVidia this is FX 5 series (GeForce 4 and earlier only have XPDM drivers). For ATI I don't know, never liked ATI so I never had one.
      My ComputerSystem Spec

  3. Posts : 1,923
    Windows 10 x86 14383 Insider Pro and Core 10240
       5 Days Ago #213

    I found that the early Windows 10 Insider preview x86 and Threshold builds up to 10240 and some Redstone 1 Insider preview builds failed during upgrade from Windows 7, and would not clean install on an Acer Travelmate 2423 notepad with Celeron M 1.50 GHz and Mobile Intel® 915GM/GMS, 910GML Express Chipset Family (2nd PC spec). The setup failures would occur during the OOBE phase, tending not to create a new user structure, or failure to initialise the network due to Network and WIFI drivers not installing correctly. They would terminate setup with the indeterminate " Something happened..." error message, and setup needed to be terminated uncleanly, unable to proceed further.

    Upgrading Windows 7 Pro to Redstone 1 14393, Anniversary Update, on a non-GPT partition did lead to a working system but with some elements of the PNP system being scrambled during the OOBE phase of device setup. Once the system finally started, it was almost totally paralysed due to system interrupts overloadinging the CPU 100%. By patient sloooow use of Device Manager on an almost unusable system and disabling all conflicting devices (modem, network, WIFI, and graphics controller) the system interrupts would die down, to allow one of the network devices to be re-enabled, so that the system to be used with reasonable speed, except with any graphics-heavy process such as video streaming &c.

    The notebook remained unable to upgrade or clean install with setup for any Redstone 2 (Creators Update) or any more recent build. Applied wim deployment results in the plug and play situation remaining a catastrophe, with many devices having phantom twin entries in Device Manager, all with device driver failures, however, the system interrupts problem vanished, since the devices were not using resources.
    Click image for larger version. 

Name:	image.png 
Views:	3 
Size:	359.1 KB 
ID:	180928

    I am not sure if there is a way to edit the registry to remove these duplicated device references - does anyone know?

    The system also seemed to work better because of these free resources and the Microsoft basic graphics driver runs the system adequately. As long as I add a USB WiFI dongle, the system runs fine even up to insider skip ahead build 17618, but with some of the onboard devices not working.
    It seemed to me that Windows Setup itself fails because WinPE from Redstone 2 and later also does not have the capacity to install or use the older intel chipset drivers and cannot properly probe the pnp/pci bus to accommodate the devices.
    Last edited by Fafhrd; 5 Days Ago at 05:03.
      My ComputersSystem Spec

  4. Posts : 2,404
    Windows 10 Pro 64-bit 1709 (FCU build 16299.248)
       4 Days Ago #214

    Now that you know that specific devices cause the problem, you could try disabling them in BIOS (if possible) before clean-install RTM (10240) or TH2 build. Even better, you could first install Windows 7, disable these devices in Device Manager and then try to upgrade to 10. After successful installation of Windows 10, try manually forcing the Windows 7 drivers from Acer's site and then use show/hide tool to block all driver updates. Then create a restore point that you can try getting back if anything happens. Disable the devices again (just in case) and try upgrading to a more recent Windows 10 version. If you succeed reinstall Windows 7 drivers and block updates with show/hide tool. Post your results here to let us know.
      My ComputerSystem Spec

Page 22 of 22 FirstFirst ... 12202122

Related Threads
I haven't had the new PC delivered yet, but am wondering if, as Vista drivers for gaming hardware tended to be OK in Win7, should they and/or Win7 drivers work in Win10? Thinking of things like Saitek X52, Belkin Nostromo N52.. I could of...
10130 On raw hardware in General Support
So, I've been running Windows 10 in a VM since day 1... and have not run It on real hardware. After my primary drive started flaking out, I went out and bought a new SSD, and decided to just bite the bullet and install Windows 10 as my primary...
Solved Phantom hardware in Drivers and Hardware
I have a Lenovo laptop with 2 ssd installed no cd installed. I go to drive management and I have a cd with a dvd mounted with 3.9 GB showing I can open a command prompt and get a directory listing. 7768 I would like to know where this...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 12:36.
Find Us