Windows 10: SFC /Scannow won't start Solved


  1. Posts : 349
    Win10 x64 Pro -2 desktops, 1 laptop
       24 Sep 2016 #1

    SFC /Scannow won't start


    I tried to run SFC /Scannow but got the error message "Windows Resource Protection could not start the repair service".

    I saw on the web that this usually indicates that the Windows Module Installer and/or Trusted Installer is not running. The Windows Module Installer was running but I issues the start for it anyway. It didn't help. I rebooted. Still couldn't run SFC.

    Windows: Fix Error
    suggested the following procedure:

    1. Select “Start” and type “CMD“.
    2. Right-click “Command Prompt” then choose “Run as administrator“.
    3. If prompted, enter a username and password that grants admin rights to the computer.
    4. Type “sc config trustedinstaller start=auto“, then press “Enter“. You should get a “SUCCESS” message.
    5. Type “net start trustedinstaller“, then press “Enter“. You should receive a message that the service was started.

    All that worked as described, but SFC still refuses to start.

    Do I have any choices short of clean reinstall? I did a clean install of 1511 (actually, to of them) but just an upgrade-in-place for 1607. I have a lot of software installed and reinstalling them after a clean reinstall takes more time than I can afford right now.
      My ComputerSystem Spec

  2.    24 Sep 2016 #2

    Hi,

    "If you get the Windows Resource Protection Could Not Start the Repair Service error when trying to run SFC, then make sure that the Windows Modules Installer service is enabled and set to Manual."
    (from Brink's Tutorial on SFC)

    If that doesn't help you might try Tweaking.com's cautious repair tool; use only the relevant repair for services (26, possibly 27).

    There are other possible repair options, so don't despair yet.
      My ComputerSystem Spec


  3. Posts : 349
    Win10 x64 Pro -2 desktops, 1 laptop
    Thread Starter
       24 Sep 2016 #3

    Module Installer was not the problem so I tried the Tweaking.com tool. Repair services 26 &27 didn't help.

    It looked like one of the preliminary tests in the tool was an execution of SFC and it ran fine. I thought maybe it was because I was in Safe Mode, but that was not the case. SFC/Scannow still refuses to start even in Safe Mode.

    DISM next, or is it even an option if SFC won't start? (Sorry if that is a dumb question.)

    Update: Some serious user stupidity here. I've been trying to run SFC from a desktop icon (using Run as administrator). It fails to start that way. However, it runs ifI use the Command Prompt (Admin) from the right-click Start menu. So I obviously have something wrong with my desktop icon. I just recreated icon from the Apps list and it works now. I guess I'll mark this "Solved".
    Last edited by pokeefe0001; 24 Sep 2016 at 15:21.
      My ComputerSystem Spec

  4.    24 Sep 2016 #4

    Thanks for letting us know.
      My ComputerSystem Spec


 

Related Threads
Solved sfc /scannow says this. in Performance & Maintenance
Some of the damaged files couldn't be repaired: 50641 And, CBS.log says some errors similar to this one: 2015-11-26 16:02:04, Info CSI 00000442 Error - Overlap: Duplicate ownership for directory "\??\C:\WINDOWS\bcastdvr"...
Sfc /scannow in Performance & Maintenance
Hi I'm new to the forum When running SFC / SCANNOW I get an error message - Can someone help in fixing the issues that it refers to? "Windows Resource Protection found corrupt files but was unable to fix some of them. Details are included...
SFC /scannow errror in Performance & Maintenance
Hi, just wondering if these are anything I should try to fix or if I can just ignore them. When doing a sfc /scannow after it finished it reported this. I'm just trying to get my laptop ready for the upgrade and getting ready to clean it up and make...
SFC /SCANNOW results in General Support
Finally in this build 10049, I can run SFC /SCANNOW completely. I've extracted just the SR results from cbs.log showing repairs, but one did not fix. Has something to do with powershell. I've rebooted and rerun 3 times, the recommended. Any...
Greetings. After some troubble with my PC I wanted to restart in safe mode, but it can't do that. Breaks off and write something about a "hard crash", only the taskbar works, and I can also ust winkey+R and start regedit aso. Because of this I...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 11:26.
Find Us